Previous 1 23 24 25 26 27 Next 501 Replies Latest reply: Jan 26, 2015 4:29 AM by nikitok Go to original post
  • chaoskcw Level 1 Level 1 (0 points)

    Many of us have!

  • xpla Level 1 Level 1 (0 points)

    This is such a crucial feature. I can't believe Apple abandoned network search (only working with own servers).

  • Looter Level 1 Level 1 (55 points)

    xpla wrote:

     

    This is such a crucial feature. I can't believe Apple abandoned network search (only working with own servers).

    No it doesn't really work with those either.

  • ChazThePhoenix Level 1 Level 1 (20 points)

    Did you see the news report about the girl who was denied purchasing an iPad because she spoke Farsi in the store to her relative?  The sales boy said he can't sell to someone who was going to import it to Iran. She is an American citizen.

     

    Look up iDiscriminate

     

    Yes, the big machine has gone awry

  • imafromKC Level 1 Level 1 (0 points)

    Vance,

     

    There are so many posts I'm not sure if you've solved this or simply moved on but I have been having the same problem with my shares are 2 different places. I have had to clear all the ACLs using the sudo chmod -R -N /volumename from the command line. Once you do that there's no spotlight ACL any more. You can verify that by looking at the main share and seeing if the last ACL is spotlight (grayed out). At any rate I called Apple and Jane helped me through this.

     

    First, I creaated a new folder and went the server app and shared it. I then looked at ther permissions to see if spotlight was automatically added to the share. In my case it was. So next we went server.app and clicked on one of the shares (again none have the spotlight ACL) then hit the "-" button below to remove it from sharing. We then hit the plus button and choose the same folder to share it again. Sure enough the spotlight ACL was there. It kept all of my ACLs as "unsharing" it does not delete the permissions just the shared status. We then propogated the ACL permissions and sure enough. The spotlight icon in the upper right was blinking away. As I check the sub folders non of them had the spotlight permission until I propogated. After I did they all had it.

     

    Hope that works for you. Remember try a new share first. Be sure no one is logged in and using the share when you remove it then re-add it.

     

    Take care

     

    Ima

  • LostAccount Level 1 Level 1 (100 points)

    I am very delighted that you wrote back with this information. This is what makes this community so fantastic. Thank you, for the effort in calling AppleCare and sharing this insight with us. It's really valuable to a lot of other people here.

     

     

     

    I will try this as well!

  • Fugu Agency Level 1 Level 1 (0 points)

    Since this still isnt working with Mountain Lion, I'll give the above a try. Thanks very much.

  • hankrearden Level 1 Level 1 (0 points)

    This worked - here were the steps:

     

    - shut down computer

    - restart computer and hold down cmd + r during the startup, this will take you to OS X utilities

    - open the terminal in utilities

    - type 'passwordreset' and hit return (that may be incorrect - this is from memory)

    - select your HD and click on reset at the bottom

    - wait, took mine approx 25 minutes

    - restart

    - go to system prefs

    - spotlight

    - privacy

    - drag your network drive to the privacy window to add it to the list

    - click on show all

    - back to spotlight preferences and remove your network drive

     

    Worked right after that for me after years of not being able to search my network drives

  • C.Edwards Level 1 Level 1 (0 points)

    Hankrearden, that didnt work for me at all,

     

    what did work strangly is this, *with a catch at the end

     

    1: make sure network drive is mounted , for this examply my network drive name is called "shared", replace with whatever your network share is...

     

    2: open terminal, type mdutil /Volumes/Shared -i on

     

    3: verify indexing is on for volume in terminal again by typing mdutil /Volumes/Shared -s

    results should say indexing enabled for volume shared

     

    4: now either use Onyx and rebuild the spotlight index, or in terminal issue a mdutil /Volumes/Shared - E (this will erase and rebuild the spotlight index with your newly included destination,

     

    the index of course takes time depending on the amount of files to index, my share is a NTFS mount that I have read/write to on a windows 2003 server, and works just fine, in Lion 10.7.4

     

    *the only stinker is, I need to leave the volume mounted all the time. otherwise it will remove itself from the spotlight indexing if it cant be found.

     

    but it seems to work.

  • Rick Fernandez1 Level 1 Level 1 (55 points)

    Followed all these steps as described, and got the results as described after running each command. Nonetheless, when I try to find a file that I know is on my shared network NTFS mounted drive, it won't find it. Spotlight just spins and spins and returns nothing. So not working for me. Why isn't this fixed in Mountain Lion is the bigger question? I am very unhappy with Apple.

  • Hans Luijten Level 1 Level 1 (10 points)

    Interesting to see that ForkLift claims to use "simple" SpotLight search (http://wiki.binarynights.com/) and CAN actually search my network drives.

    However; when using the Finder or Total Finder (both using SpotLight as well) it doesn't work?

    So my guess is that ForkLift does not really use SpotLight or is using SpotLight without it's indexes?

     

    I've just upgraded from Lion to Mountain Lion and see the exact same thing there.

  • LostAccount Level 1 Level 1 (100 points)

    Dear Mountain Lion and Lion users:

     

    1 Make sure indexing is 'on' on the SMB volume, sudo mdutil -i on path-to-smb-volume

    2 The index is stored locally on the client's volume, the SMB/FTP server MUST remount with exactly the same name each time or it can't pair up the server with the local index.

     

    Give it time to index, leave them overnight if you wish but give it time, this should work.

     

    I ran this command after mounting the volumes, I only tried FTP so far and it worked. I have yet to try SAN SMB volumes.

  • Sinerg1 Level 1 Level 1 (0 points)

    Im using Mountain Lion and have given it time sadly, since the upgrade I can no longer search emails using Outlook 2011!

     

    On the plus side, I can search through network drives providing I did these steps;-

     

    1: make sure network drive is mounted , for this example my network drive name is called "shared", replace with whatever your network share is...

     

    2: open terminal, type mdutil /Volumes/Shared -i on

     

    3: verify indexing is on for volume in terminal again by typing mdutil /Volumes/Shared -s

    results should say indexing enabled for volume shared

     

    4: now either use Onyx and rebuild the spotlight index, or in terminal issue a mdutil /Volumes/Shared - E (this will erase and rebuild the spotlight index with your newly included destination

     

    Sadly Ive no idea why I cant search emails from Outlook

  • Mojo66 Level 1 Level 1 (50 points)

    Sinerg1 wrote:

     

    2: open terminal, type mdutil /Volumes/Shared -i on

     

    Confirmed for Mountain Lion! After typing above command, spotlight did indeed start indexing my network volume. While I still can't search the network volume through the magnifying glass, I can search it now in the finder and it'll immediately return results.

     

    Man I'm glad this discussion is over now.

  • Robbe Level 1 Level 1 (10 points)

    On Mountain Lion, this only works when I use AFP. mdutil will not turn on indexing on SMB-mounted volumes (at least in my setup with one Synology DS121j).

    Thanks for the hint!

Previous 1 23 24 25 26 27 Next