Previous 1 30 31 32 33 34 Next 501 Replies Latest reply: Jan 26, 2015 4:29 AM by nikitok Go to original post
  • bsauvage2 Level 1 (0 points)

    So the cifs trick didnt help, spotlight still can't see anthing on my shared drives, even aftet indexing.

    OSX 10.8.4, 2012 new imac, synology 412+.


    any other suggestions?

  • UmpaEG Level 1 (25 points)

    Here's what I do,


    I have found out that just having the nas mounted is not enough, the share you want needs to be mounted.  I'll give you an example,


    I have a WDShareSpace, on it I have a share called Fileserver, Amiga, Home e.t.c.  Now if I try to search the 'NAS' at this stage I cant find anything - however if I first 'mount' the share Amiga by double clicking the folder in finder a little black arrow apears at the side of that folder (its not really a folder its a share) This is on 10.8 by the way other versions might not have the arrow but the result is the same.


    Now so long as I have indexed that share with :-


    sudo mdutil -i on /Volumes/Amiga


    the system reports :-



              Indexing enabled


    and the system will now index and thus search the share. I don't think this is just an SMB - CIFS issue - its a network share issue because I have to do this no matter what the file system, the mac HD always searches ok.

  • bsauvage2 Level 1 (0 points)

    Thank you for your reply.

    Unfortunately I have done exactly as you suggest.

    Indexing enabled, as it says...

    Yet files still don't appear in spotlight search...

  • UmpaEG Level 1 (25 points)

    I might be getting confused as to what spotlight search is.  For this to work you need to press cmd>F select the share to search.  When I do this I get no indication that its actually doing anything but after a few mins it displays my results.


    If your typing your search in to the menu bar search, then no I have never had that search any drive other than the internal HD.

  • bsauvage2 Level 1 (0 points)

    ok then maybe my mistake is in the way I've setup the NAS.

    So I have this "DiskStation" setup under "Shared"; then underneath I have various 'shared folders' mounted when I start mac osx; these are the folders (Books, Documents, Music....etc) I had indexed through the cifs method.

    Now if I search (Command+F) on Shared (=Diskstation) it returns nothing; if I search directly on the shared folder I specify (Books, Documents...etc) then it works.

    => is there a way to do a search inside all the shared folders in one shot ? If not, should I change the way my diskstation is configured? and if I eventually manage (thanks to your forthcoming advice) to get this right, is it then possible to do that overall shared folders search straight from the Spotlight icon in the top right corner of the screen ?


    (sorry for so many questions, I'm totally new to macs)

  • bsauvage2 Level 1 (0 points)

    Can anyone please tell me if my mounting/expectations...etc are correct ?

  • UmpaEG Level 1 (25 points)

    I have not been able to search the nas as a whole. However subdirectories of nas shares will be searched when searching the share. The way I think of it is that shares are like drives or partitions. I know they look like plain old directories, but they aren't. Even easyfind wont search the nas as a whole, but it does seem to do it without indexing and does show a progress bar.


    I have lots of different versions of osx and none of them are any good at searching network drives from any manufacturer.

  • dirk123456 Level 1 (0 points)



    i just updated two of our Power Macs from Snow Leopard to Mountain Lion. We skipped the update to Lion because we had many problems (Active Directory issues) with the integration in our IT enviroment.

    Mountain Lion runs fine so far, but we have problems searching cifs/smb network shares too.


    I enabled Spotlight indexing (mdutil /Volumes/share -i) on the network shares and im able to search (Finder searchbar) within

    but not within subdirectories like



    This is really a huge problem and I cannot believe that this issue is still not solved. Apple..please fix it, that's really not a minor issue in my opinon.


    However is there anyone who is using a thrid party software (Tuxera/Paragon) for accessing the cifs/smb shares and doesn't have these problems? I am willed to spend some money for a workings solution.

  • wmike1503 Level 1 (0 points)

    I am staggered by this, well intentioned, advice.


    Are we really expected to accept messing around in such a manner with the 'world's most advanced OS' (Apple's words) just to get something to work that should be a fundemental facilty in ANY OS?



  • two freckles Level 1 (0 points)

    Not sure if this solution work for you however we did buy a synology station and using cloud station to sync files. It works just like drobpox on local network (so copies everything from NAS to local drives and spotlight then search without a problems). The positive thing is you got a backup off your data, negative is that files are sync times number of machines inside company plus if you got a lot of data you need big HD drives inside computers.


    There are still some bugs with cloud station though. We have noticed that whenever you try to duplicate .jpg files on Lion some conflics happens. From windows machiens everything is top. I cross fingers for synology team to solve this issue at least (they do stragle with it for a while now - but at least are trying despite Apple's aproach). Hope it helps.

  • Roohbir Level 1 (0 points)

    Hi Guys,


    Not sure if someone's already suggested this but after spending hours trying to find a solution to make spotlight searches work on my network drives, I just installed Easy Find which worked perfectly without configuring anything. I know it's not as ideal as having it work in spotlight but it did work for me in about 30 seconds instead spending hours trying to get spotlight to do the same thing


    If anyone from Apple is reading this, I can't believe the absurdity of spotlight not working out of the box on connected network drives, hoping for this to be resolved in Mavericks - would find this way more useful than tabbed finder windows or Apple maps on my Mac. Just my opinion.


    Hope you guys find it useful!


    Roohbir Singh

  • Denny-SKA Level 1 (0 points)

    mdutil /Volumes/{volume_name} -i on

    Replacing {volume_name} with the actual name of your network drive or folder.

  • jimsg4 Level 1 (20 points)

    I just updated our 2008 Mac pros to Lion so we could install and run Adobe CC. If this is how Apple is going to be, then the new Mac Pros in the budget will be switched to new PC's. We have 4TB of Art files on our networked server that can't be searched from The Mac Pro's now. Easy Find takes way to long.


    I have always used Apple products and supported them. This is where we will part ways unless they come up with a viable solution. Having to re-index 4TB of network files on 3 Mac Pros and then not being able to search inside sub directories is not acceptable. It's absolutely rediculous and they know it. I don't believe they will do a thing to help us. If they wanted to help us, this issue wouldn't be two + years old.


    I think this is the beginning of the end for the Mac. They just won't say it.


    If it were a problem with the iPhone or iPad searching, they would be all over it. We are second class citizens now.

  • MacSavvyDude Level 1 (0 points)

    Confirmed: solid working solution...Easy Find.

  • jimsg4 Level 1 (20 points)

    Easy Find takes way to long." We shouldn't have to rely on a 3 party program to try and do what the built-in functionality should be doing. Like with every other OS out there. We have 4TB of data on that needs to be searched on a regular basis. As nice as Easy Find is, it isn't good/fast enough.


    How many OS's out there that can't search a network drive? really? It's a joke! A joke that's going to prevent our company from upgrading to the new Mac pros and get PC's instead. As I said. I think this is the beginning of the end.