Skip navigation

Unable to search network drives with Lion...

189542 Views 492 Replies Latest reply: Apr 7, 2014 3:20 AM by DrNicolaus RSS
  • MacSavvyDude Calculating status...
    Currently Being Moderated
    Oct 29, 2013 9:18 AM (in response to dirk123456)

    Easy Find.

  • dirk123456 Calculating status...
    Currently Being Moderated
    Oct 29, 2013 9:34 AM (in response to Vance Jackson)

    I agree, all the solutions (spotlight indexing and easyfind) are workarounds and are not really satisfying.

    After skipping Lion, due to many bugs and problems, I was really happy with Mountain Lion in the beginning, but this bug is really annoying in a company it enviroment.

    Feels like a car without a horn...

  • jimsg4 Calculating status...
    Currently Being Moderated
    Oct 29, 2013 9:47 AM (in response to dirk123456)

    Well said! I can't even recommend a new Mac for business. How do I tell people, It's the best computer I have ever used, it just can't search your Network or NAS. It looks like Mavericks is having issues just connecting, let alone searching.

  • efreet Calculating status...
    Currently Being Moderated
    Oct 29, 2013 1:14 PM (in response to Vance Jackson)

    So anyone have tested Mavericks? Do you know if searching working there?

  • Rick Fernandez1 Level 1 Level 1 (55 points)
    Currently Being Moderated
    Oct 29, 2013 1:18 PM (in response to efreet)

    It seems to work but only partially. I can find files and folders in the root directory of my NAS drive. But it will not search within subfolders. Have no idea why. It's absurd that Mavericks has not resolved this issue. Inexcusable, really.

  • Stryckie Calculating status...
    Currently Being Moderated
    Nov 4, 2013 1:34 PM (in response to Vance Jackson)

    Has anyone tried SMBUp?

    I was really hoping Mavericks would fix this with its theoretical SMB2 implementation, but it didn't...

     

    I saw people were trying to use it to re-enable SMB file sharing, but wasn't sure if it would fix the search problem. https://discussions.apple.com/thread/3208098?start=0&tstart=0 (File sharing thread discussing SMB/ scan to drive, SMBUp talk starts on page 3, and dev notes on p 4)

     

    Alternately, has anyone tried MacPorts to install Samba?  http://hints.macworld.com/article.php?story=20120401160655922 (MacPorts install guide)

     

    Both of these are in reference to Lion, but since they both essentially are just installing a protocol they may still work.

     

    I would have to go through IT to get this enabled, so I would like to know if it works before I go try to wheedle my way into their hearts though lol.  Anyone willing to try it out?

     

    [eta] Also note that SMBUp is basically a front-end to do exactly the same install as the MacPorts version, without having to dl Xcode etc.

  • pepa_u Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 1:33 PM (in response to Stryckie)

    The search works again! I've put together a new file server running Ubuntu 13.10 with samba 3.6.18. The client is OS X 10.8.5. No problem to search the Linux shared drive connected using Finder.

     

    An older file server from Synology which uses samba 3.6.2 works too, but it has to be connected via Finder->Go->Connect to Server and then "cifs://server" (somebody was already suggesting that here). It does not work as nicely as the new file server though. Finder shows even a spinning wheel in the corner of its window indicating that it is still searching when connected to the new file server. It does not appear on the older server.

     

    Both servers use SMB2 so I do not know where exactly is the difference, but the bottom line is the new samba server works perfectly fine with Mac's file sharing

     

     

    P.S.: I managed to get going also Timemachine on the new Ubuntu server. Works beautifully and no need of tweaks on the OS X client. One can select even an icon that appears in Finder for that device

  • shortysharp2 Calculating status...
    Currently Being Moderated
    Dec 19, 2013 10:11 PM (in response to LostAccount)

    LostAccount wrote:

     

    For the time being, you may want to try:

    sudo mdutil -i off (the path to your NAS drive)

    You can leave a space after the word 'off ' and then drag and drop the NAS drive icon into the terminal window to complete the path for you.

     

    Then run:

    sudo mdutil -i on (the path to your NAS drive)

     

    I will be happy to help in anyway I can and I hope this helps.

     

    Kind Regards

    This solved my problem. I believe my problem was I installed OS X Server and set up some VPN shared folders.... messed with permissions and index.

  • Mike Kestrel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2014 8:01 PM (in response to Vance Jackson)

    I was able to solve this problem in Mavericks by following this post: http://support.apple.com/kb/ht2409.

  • Stryckie Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2014 1:14 PM (in response to Vance Jackson)

    Neither of these solved my problem.  The network drive (when indexing is force enabled with mdutil) will continually attempt to index, but never complete. I let it try for a couple of weeks straight before giving up.  I have tried the add and remove from spotlight version as well, to no avail.

     

    It used to work perfectly on 10.4 :/ My workflow is completely messed up now and I have to resort to going outside of the program I'm using to a third party search program (easyfind) instead of searching within the dialog boxes for open/place/etc. 

     

    The new SMB protocol just isn't working properly.

  • Domnosil Calculating status...
    Currently Being Moderated
    Mar 11, 2014 2:52 PM (in response to Vance Jackson)

    I found something which has dramaticaly speeded up my network and helped with spotlight search as well. It's not a solution for all, but it maybe helps. Try to get rid off IPv6 on all sides, especially if your shares run under Windows. I switched it off in the ethernet adapter preferencies. It boosted up all shares under Finder and helped me to search files more fluently. Tested on Maverics, disks shared from Windows 7 through CIFS.

  • BeckieBea Calculating status...
    Currently Being Moderated
    Apr 1, 2014 11:33 AM (in response to Mike Kestrel)

    At any given point, there's probably 50-70 people using the drives I would need to re-index. This does not work for me. I finally gave up and installed Easy Find. It's not ideal, but at least it's giving me results.

  • DrNicolaus Calculating status...
    Currently Being Moderated
    Apr 7, 2014 3:20 AM (in response to Vance Jackson)

    I have Mac os versions 10.9.2 and external NAS - WD MyCloud.

    I face a similar problem, namely:

    1. NAS it is constantly disconnected from system, it is necessary to remount a necessary external folder manually

    2. Spotlight does not look for data on NAS. Forced start of indexation on NAS does not help.

    Whether there is what that decision of the specified problem?

    In my local network, also there is a computer on Windows 7, at it what or problems with connection and work on the files placed on NAS do not arise.

1 ... 29 30 31 32 33 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (25)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.