Previous 1 2 3 Next 38 Replies Latest reply: Nov 16, 2015 8:52 AM by turingtest2
patfromkingston Level 1 (0 points)

Updated iTunes yesterday ... when ok.  Today, when turning on computer got an alert window about iTunes that says "the procedure entry point sqlite3_wal_checkpoint could not be located in the dynamoic library SQLite3.dll".  How do I fix this?  iTunes does start up ok, but don't know what the alert window is telling me and when I clicked on 'check for updates' in the iTunes pull down I'm told iTunes is up to date (iTunes 10.4.0.80)


iTunes program updates, Windows 7
  • 7uck123 Level 1 (0 points)

    Having same problem....I'm pretty sure it's just a glitch and might be fixed soon

  • JWB@CMA Level 1 (0 points)

    Yes - I just updated itunes and have the same problem.  Should be fixed in tomorrows update. : )

  • gavindickson Level 1 (0 points)

    I'm having the same problem as well. Running Windows 7 and just updated Safari and iTunes and getting the same error. Searched the internet at it seems to be common issue.  Hopefully there will be a fix or someone can share with us the fix soon.

  • Code3inLA Level 1 (5 points)

    I have the same exact problem after updating last night too!  I'm running Windows 7 - 32 bit.  But my iTunes won't even start.

  • TorbenCJ Level 1 (0 points)

    I updated right now. And got the same ERR msg about the checkpoint. So the bug seems not to be fixed by apple. Very annoying. I can run iTunes tho.

  • Code3inLA Level 1 (5 points)

    FINALLY GOT AN ANSWER!

     

    After spending 30 minutes on the phone with Apple Support, we got it fixed.  Here is how to fix this issue:

     

    1. Temporarily shut down anti-virus and firewall software
    2. Open Control Panel, Programs and Features (or Add and Remove Programs), and go to the uninstall section
    3. Remove all Apple products in this order - iTunes, Quicktime, Apple Software Update, Apple Mobile Device Support, Bonjour, Apple Application Support.  You do not need to remove Safari
    4. Restart computer
    5. Go to Apple.com and download newest version of iTunes
    6. Re-install

     

    That did it for me!  No more error messages and everythine appears to be working again.  Hope this helps everyone!

  • gavindickson Level 1 (0 points)

    YOU ARE AMAZING Code3inLA!!!  Thank you for taking time to call iTunes...I did not have time but the solution worked like a charm... NO MORE ERROR!!!

     

    Thank you!!

  • patfromkingston Level 1 (0 points)

    I posted the original question ... followed the recommended fix ... worked wonderfully!  Thanks team! Hope everyone can recover as well!  Happy iTunes listening!  //Pat & Carl ... Kingston, WA/

  • Code3inLA Level 1 (5 points)

    Glad I could help!  It was driving me crazy just like I'm sure it was doing to all of you!  I'm just relieved that it all is up and running again.  Take care guys!

  • TorbenCJ Level 1 (0 points)

    YAY!! Thanks Code for your help

  • ryjguy7 Level 1 (0 points)

    . . . I followed Code3inLA's uninstall how to, but this did not fix the issue for me on Windows 7.  Still get the error ;

     

    The procedure entry point sqlite3_wal_checkpoint could not be located in the dynamic link library

    SQLite3.dll

     

    . . . help?

  • webnme Level 1 (0 points)

    Had the same error.  Running Win 7 - 64 Bit.  Downloaded iTunes installer and did a repair install (when you run it over an existing install, you get the options to repair or uninstall - pick repair).  Fixed the problem for me.  iPhone sync worked and iTunes worked after that.  Did not need to uninstall anything.

  • thescubadude Level 1 (0 points)

    So not sure how you guys fixed this even following instructions above.

     

    The latest auto update is 10.4.0.80. The download from the website for windows 7 64bit is 10.3 so when I try run the installer to do a repair it won't install because it is an older version. If I uninstall the existing version and install the 10.3 then surely the auto update is going to cause the same problem? I don't really have the time for this and quite honestly I don't really use itunes but this pop up every time I restart is annoying.

     

    Is it just me but I can find the 10.4.0.80 everywhere but on the apple site. Not really that keen to download it from somewhere else.

  • webnme Level 1 (0 points)

    You can download Version 10.4 for Windows 7 - 64 Bit at http://support.apple.com/kb/DL1427 - the file is dated July 20 and is 78.58 MB. 

Previous 1 2 3 Next