Skip navigation

Lion Clients Won't Mount Network Home?

9537 Views 15 Replies Latest reply: Apr 15, 2013 8:05 AM by VinceHunter RSS
1 2 Previous Next
scrogers Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 21, 2011 9:13 AM

Hey all,

      So, we've had a SL Server setup with a whole bunch of managed macs running pretty smoothly for year. Yesterday decided to start experimenting with Lion as we want to update clients asap if possible. Amazingly, I was able to bind the Lion Mac to AD easily/no issues, then added/joined our OD server (this 10.6 server).

     Normally, we can then log in with a AD network user (configured through OD groups in WGM) and we get the Network Home (set in the user's AD network home path) in the dock. This works seamlessly in 10.6.

     When I login with Lion, after pressing enter at the login screen, I instantly get "Select the volumes you want to mount on "servername"" where servername is the correct server where the network homes are, but of course all of the volumes shown are not relevant because we hide the folders and they are individual shares. If I click ok on any volume it either says there isn't permission (because the user doesn't have permission) or it just ignores it all together and moves to the desktop where the Network Home in the dock is just a question mark. Even weirder, if I try to manually connect from connect to server in the finder the share mounts, but the user now doesn't have permissions to write to the network home folder? Again, ALL of this works fine from any SL/10.6 client.

 

     So, is this because I'm not running Lion Server (yet)? It this just going to be a lost cause to try and integrate the Lion machines to SL server? It's too bad because the 10.6 stuff works so nicely, but these Network Homes are just completely failing under Lion. Any ideas, places to look, or help would be amazing. Thanks!

 

~S

  • stuka Calculating status...
    Currently Being Moderated
    Sep 9, 2011 7:00 AM (in response to scrogers)

    I've got the exact same problem, 10.6 server doing OD, something doing my AD and an smb server doing the actual home shares. 10.6 clients have worked fine, now ever 10.7 client pops up the "select the share to mount" and flat out then frankly doesn't work.

  • stuka Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2011 8:19 AM (in response to scrogers)

    Hmm, bad news indeed. It happens with ever lion client I've got. Only thing new in my environment is 10.7, so I clearly point the finger at it, but if they can't reproduce it sounds like it is not magically going to get fixed in 10.7.2

     

    I've been looking around for info for weeks on it & yours was the fisrt post I saw matching my problem.

     

    I don't control the AD in my environment, but I think we are 2008 R2 of some sort, not sure on its details at this time, We ran 2003 for the longest time & might still have it at that level

  • neoseele Calculating status...
    Currently Being Moderated
    Sep 27, 2011 1:25 AM (in response to scrogers)

    Same issue here.

     

    We have the same sort of configuration:

     

    * AD (2008R2) + OD (SL Server) triangle

    * Clients provisioned via Deploystudio

    * home folders are individually shared with the "$" sign at the back

    * SL clients works perfectly ok

    * Lion clients got the popup "Select the volumes you want to mount" thing every time the domain user logs in. (**** those new Macbook Airs, they can only runs on Lion !)

     

    If the home folder shares are not hidden, the "select volumn" window still popup, but since the share is visible now, user can pick it from the list and mount it. then, the question mark on the dock replaced by the mounted home folder, as it should in the first place.

  • neoseele Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2011 7:38 PM (in response to scrogers)

    Agree, my friend. Its a nasty bug for sure !

     

    I've tried the workaround you mentioned, but can't quite achieve the same result. The "select volume" thing still pops at login. Maybe our configuration is slightly different?

     

    I've got the impretion the anonying popup comes from AD. If you go to WGM on the SL Server, switch the directory to "/Active Directory/All Domains", pick any user, go to preferences >> login >> items, the "add network home share point" option is ticked, which puts the 'Network Home Share Point' volume in the list. Unfortunately I can't change anything here since our AD's schema can't handle Macs.

     

    So I switch to "/LDAPv3/***", add the dummy AD user to a test group, go to the test group's preferences and add the smb share of the parent folder (where all the user's home folders physically located) to the login items. (I notice that the smb share can only be added as kind: "URL" instead of "Volume", but it seems to be mounted correctly when I test it.)  Then try login as dummy user on a Lion, "select a volume blah blah blah", no luck.

     

    I just wondering how did you mount the smb share via WGM, are we doing things differently? Since the "add network home share point" cannot be unticked under "/Active Directory/All Domain", did you guys found a way to override it or some sort?

     

    Cheers

  • neoseele Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 28, 2011 6:11 PM (in response to scrogers)

    Let me clarify. Changing user's preferences directly in "AD/All Domains" directory is impossible unless the required attributes are added into the AD's schema, which we didn't do. WGM, by default, at lease in our case, "thinks" some preferences for the AD's user are managed by "AD/All Domains".

     

    Pick any AD user in the AD/All Domains directory, click "Preferences", in the "Overview" tab, 3 preferences are appeared to be "Managed":

     

    * Dock (add network home to the dock)

    * Login (add network home share)

    * Mobility (require confirmation before creating mobile account)

     

    All of these are "managed" by default and cannot be "unmanaged"...

     

    However, these managed preferences do match the default behaviour when a AD user log into a Mac that joined to the AD: mount the home drive and place it in the dock.

     

    I have no idea why you guys can't see anything in the "AD/All Domains", maybe its the 2008R2 thing, after all this is the biggest difference between yours and ours.

     

    Cheers

    Nil

  • golderm Calculating status...
    Currently Being Moderated
    Jan 13, 2012 8:37 AM (in response to scrogers)

    Hi,

     

    Great discussion, did you get anywhere with this issue? I'm running Server 2003 AD with home directories pointing to a samba share for each user, which is hidden from the other users and am continually getting the "select the volumes you want to mount" at login and also during sync which is pretty annoying as if you select the wrong share on the latter it breaks the sync.

     

    Snow Leopard clients working perfectly fine.

  • Mandrappa Calculating status...
    Currently Being Moderated
    Jan 20, 2012 9:36 AM (in response to scrogers)

    The problem, as far as I can see, it the way this new implementation of samba mounts volumes.

    If the home directory is under //server/someplace/homedirs/$username$ and your share happens to be //server/someplace/ then the client is unble to mount the subdir as a separate volume, hence the homedir mapping fails. According to Apple while the mount of a smb/cifs resource is now working this way using "Connect to server" it still work the olr way using mount_smbfs from Terminal. However the login process with AD seems to prefer this new way and I haven't figured out yet a way to automate the homedir mount using mount_smbfs.

  • Kirk Rheinlander Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 23, 2012 9:02 AM (in response to Mandrappa)

    Read this on MacWindows: The issue incompatibility arises from Apple dropping support for most authentication types, including the widely used DHX (DHCAST128) and clear text. Lion now uses only DHX2 authentication. Apple's workaround is to use the command line in Terminal to turn on other authentication methods. (More specifically, to remove the older authentication methods from a disabled list.)

     

    I've not found this successful as yet, but others seem to. It affects both SMB and AFP.

  • golderm Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 2, 2012 1:45 AM (in response to Kirk Rheinlander)

    Do you mean this Kirk?

    http://support.apple.com/kb/HT4700

    It seems to only apply to AFP shares, unless you can repalce all AFP references with SMB?

     

     

     

    On another note I seem to have resovled my problems, I'll try to summarize my scenario and resoloution below for anyone still looknig for help.

     

    Scenario: Fedora server running Samba, (not sure ver, but same problem with latest ver on a test box), Snow Leopard Mac's able to work fine. Lion Mac's refuse to mount correctly when AD user accounts are configured as thus-

    Profile path = \\servername\usersshare\profile

    mount home directory to Z:\ = \\servername\usersshare

     

    Resoloution: This seems so stupidly easy, change the 'mount home directory' path to a subfolder of the share e.g. \\servername\usersshare\newfolder

  • Dave Collins Calculating status...
    Currently Being Moderated
    Oct 30, 2012 9:14 AM (in response to scrogers)

    Hi Guys,

     

    Like to confirm this is the case in 10.8.2 as well. Looking at it they, Apple, have changed the way network home works too. This now mounts the /home folder as a hidden share and maps the users home into this area, which seems to hide as part of the parent folder.

     

    We have two sites where this is happening one is a 2003 AD server with  Mountain Lion OD server for management, and one is a 2008 R2 AD server with a Mountain Lion OD server for management. The issue occurs in both locations, except for when you enamle mobile home then it will map the share correclty but point all folders to the local created folder.

     

    Kind Reards,

    Dave

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.