Previous 1 2 3 4 5 6 Next 132 Replies Latest reply: Apr 17, 2014 9:49 PM by Wout Mertens Go to original post Branched to a new discussion.
  • garymansell Level 1 Level 1 (0 points)

    Me too... For the sake of helping Apple see how many people are suffering from this problem I thought I would post too. I have contacted Apple Care about this also and they said that they were working with some router manufacturers to try and resolve this - but not fast enough as far as I am concerned.

     

    It is probably worthwhile documenting as much information about this issue as possible in the hope that we can isolate exactly what causes it and in what circumstances it happens, so here goes:

     

    When my  Macbook Air 2011 with Lion 10.7.3 wakes from sleep, about 50% of the time it will not reconnect to my home wireless network which is a Netgear WDNR3700v2 Dual Band Router. I get a dialog box pop up saying that it cannot connect to my preferred wireless network and I have to stop and start the WIFI several times before it will finally connect.

     

    This problem seems to be specifically related to Wireless N Networks, as when I have my machine set for the wireless G network, it reconects every time when waking from sleep. It also seems to not be a problem for all wireless N networks, as it connects every time when waking from sleep to the Wireless N network in the Apple Store. I suspect that this is an Apple Airport Extreme but this is only a guess.

     

    Specifically, I notice that there seems to be a delay in my machine seeing my Wireless N network when it awakens from sleep. When the dialog box pops up saying that it cannot connect to the network, neither of my two Wireless N networks are listed there, but my two wireless B/G networks are. If I wait a while for it to rescan a couple of times until they appear and then turn the WIFI on and off, it connects. So for some reason the machine has a delay finding the wireless N networks rather than the B/G networks.

     

    I have a Windows 7 Laptop that connects to my wireless N network first time every time and it has no delay in seeing the Wireless N network when waking from sleep. I have tried all of the following things to fix this issue but to no avail:

     

    • Delete all preferred networks
    • Create a home network profile
    • Delete all WIFI keys from the keychain and re-enter only the one for my Wireless N network
    • Delete the network setting folder, and reboot to recreate it
    • Changed the IPv6 settings to local link only from automatic
    • Reset the Netgear router
    • Disconnected and turned off all wired and wireless network devices from my environment and restarted my router and then connected Macbook as the first and only device (it still had troubles connecting when waking from sleep)
    • Turned off the B/G network
    • Turned off both of the B/G and N Guests networks
    • Tried all the different channels and signal strengths for my wireless N network
    • Ensured that there is no microwave or bluetooth interference
    • Reset the SMC

     

    I think that is about it, I live in a flat so there are about 15 wireless networks around me, but as I said previously I only have this issue with my Macbook.

     

    Also, when the wireless is connected, I get no issues with wireless performance. I don't get any disconnects as others on other threads have been reporting and I get about 170Mbps copying files around my network which is pretty fantastic performance as far as I am concered. It is just the waking from sleep which is the problem and it is driving me nuts !!!!

     

    Here is the output from /var/log/system.log for a successful wake from sleep:

     

    Feb  5 08:07:17 macbook UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - PreProbe

    Feb  5 08:07:17 localhost configd[14]: setting hostname to "localhost"

    Feb  5 08:07:17 localhost configd[14]: network configuration changed.

    Feb  5 08:07:17 localhost applepushserviced[75]: <APSCourier: 0x7faed951b5e0>: Stream error occurred for <APSTCPStream: 0x7faedb920ad0>: The operation couldn’t be completed. Socket is not connected

    Feb  5 08:07:17 localhost com.apple.usbmuxd[49]: _SendDetachNotification (thread 0x7fff7530a960): sending detach for device cc:08:e0:42:df:6b@fe80::ce08:e0ff:fe42:df6b._apple-mobdev._tcp.local.: _BrowseReplyReceivedCallback got bonjour removal.

    Feb  5 08:07:17 localhost applepushserviced[75]: <APSCourier: 0x7faed951b5e0>: Stream error occurred for <APSTCPStream: 0x10e920180>: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)

    Feb  5 08:07:23 localhost configd[14]: network configuration changed.

    Feb  5 08:07:23 macbook configd[14]: setting hostname to "macbook"

    Feb  5 08:07:23 macbook UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - Probe

    Feb  5 08:07:23 macbook UserEventAgent[11]: CaptiveNetworkSupport:copy_settings_plist:285 Could not read Settings file

    Feb  5 08:07:23 macbook UserEventAgent[11]: CaptiveNetworkSupport:CaptiveStartDetect:2343 Bypassing probe on GlossyNet-N because it is protected and not on the exception list

    Feb  5 08:07:23 macbook UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - Unknown

    Feb  5 08:07:23 macbook configd[14]: network configuration changed.

    Feb  5 08:07:23 macbook airportd[1529]: _doAutoJoin: Already associated to “GlossyNet-N”. Bailing on auto-join.

    Feb  5 08:07:25 macbook [0x0-0x105105].backupd-helper[1534]: Not starting Time Machine backup after wake - less than 60 minutes since last backup completed.

    Feb  5 08:07:27 macbook com.apple.usbmuxd[49]: _SendAttachNotification (thread 0x7fff7530a960): sending attach for device cc:08:e0:42:df:6b@fe80::ce08:e0ff:fe42:df6b._apple-mobdev._tcp.local.: _GetAddrInfoReplyReceivedCallback matched.

    Feb  5 08:07:28 macbook usbmuxd[49]: _AMDeviceConnectByAddressAndPort (thread 0x100781000): IPv4

     

    Here is the output from a not successful join to the network on waking from sleep:

     

    Feb  5 08:09:21 macbook UserEventAgent[11]: CaptiveNetworkSupport:CaptivePublishState:1211 en0 - PreProbe

    Feb  5 08:09:21 localhost configd[14]: setting hostname to "localhost"

    Feb  5 08:09:21 localhost configd[14]: network configuration changed.

    Feb  5 08:09:21 localhost applepushserviced[75]: <APSCourier: 0x7faed951b5e0>: Stream error occurred for <APSTCPStream: 0x7faedb941c00>: The operation couldn’t be completed. Socket is not connected

    Feb  5 08:09:21 localhost com.apple.usbmuxd[49]: _SendDetachNotification (thread 0x7fff7530a960): sending detach for device cc:08:e0:42:df:6b@fe80::ce08:e0ff:fe42:df6b._apple-mobdev._tcp.local.: _BrowseReplyReceivedCallback got bonjour removal.

    Feb  5 08:09:21 localhost applepushserviced[75]: <APSCourier: 0x7faed951b5e0>: Stream error occurred for <APSTCPStream: 0x10e9231e0>: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)

    Feb  5 08:09:26 localhost applepushserviced[75]: <APSCourier: 0x7faed951b5e0>: Stream error occurred for <APSTCPStream: 0x7faed9620600>: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)

    Feb  5 08:09:28 localhost [0x0-0x107107].backupd-helper[1545]: Not starting Time Machine backup after wake - less than 60 minutes since last backup completed.

    Feb  5 08:09:29 localhost applepushserviced[75]: <APSCourier: 0x7faed951b5e0>: Stream error occurred for <APSTCPStream: 0x7faedb920900>: The operation couldn’t be completed. (kCFErrorDomainCFNetwork error 2.)

    Feb  5 08:09:30 localhost rpcsvchost[1548]: sandbox_init: com.apple.msrpc.netlogon.sb succeeded

     

     

    Oh well, that is about all I think that I can add, please feel free to agree or disagree with any of my findings to see if we can isolate exactly what is causing this issue and look for the common pattern in this problem as this is the most likely way that this problem will get resolved.

     

    Best Regards

     

    Gary

  • garymansell Level 1 Level 1 (0 points)

    In fact I did put have it quite correct in my previous post: I have noticed that when my macbook does not not re-connect after waking from sleep, that neither of my wireless N networks (Guests and Personal) appear in the wireless list dialog pop up - but my B/G networks both show up. Even when the list refreshes several times, the wireless N networks do not show up - I have to turn the wireless off and on a couple of times using the icon and then it connects and they appear in the wireless network list at this time.

  • wifiguru Level 2 Level 2 (230 points)

    Do you pair your laptop to any Bluetooth devices ? Try turning off Bluetooth and check if autojoin works with the 11n network ? Also which channel is your network on ? If on 5 Ghz, try using channels 36,48,44.

  • etiennedouaze Level 1 Level 1 (0 points)

    I was recently introduced to disconnecting WiFi problems after upgrading to Mac OS 10.7.3 on my iMac. WiFi would disconnect every 10 minutes or as soon as I would let my computer idle. I never had this problem before.

     

    I visited this forum and UNSUCCESSFULLY applied the following fixes described in the thread:

     

    1. Turning off WiFi and then back on again would bring my internet connection back to life. But I had to do this every 10 minutes or so. Not a long term option.

    2. Changed my network location and created a new network location. I was already using WPA2 - Personal...

    3. Deleted the ‘com.apple.airport.preferences.plist’ file.

    4. Ran Onyx and performing a thorough cleanup.

    5. Deleted all access passwords from the keychain.

    6. Removed all my preferred network, including the Home network.

    7. Reset my Netgear router, tried different signal channels and settings, checked for Bluetooth interference.

    8. Turned off my firewall.

     

    Finally, I started paying attention to what anders102 explained and realized that having FT.com active in a Safari window would trigger the WiFi crash. Changing my homepage to Google.com immediately fixed the problem. How weird if that?

     

    I guess the auto-update code on the website did trigger the WiFi disconnect. Thanks, anders102.

     

    Etienne.

  • Heliman55 Level 1 Level 1 (0 points)

    I have exactly te same issue with imac and a netgear router. I have just changed my location in preferences as suggested. time will tell if this fixes it for me. I never had a problem with snow leopard. My ipad and iphone work with no problems on ios5.

  • TonyK58 Level 1 Level 1 (0 points)

    A suggestion on another forum is to wake from sleep mode by pressing the power button (instead of hitting a key or the mouse). It works on my iMac and the wifi re-starts correctly. Don't ask me why, I have no idea why there is any difference in how the computer wakes up.

     

    One problem is that Time Machine wakes the iMac to do backups and that wake-up does NOT lead to a successful wifi connection, so no backups are being performed.

     

    This is happening with an iMac mid-2010, Lion 10.7.3, connecting by wifi to an  Apple Time Capsule, which has an Apple wifi router.

     

    It would really help if someone in Apple acknowledged this very common problem, and said that they are working on it, so that we don't feel like we have to solve this on our own.

  • MistyWeather Level 1 Level 1 (0 points)

    I am having the same problem with my WiFi after the recent Lion update on my iMac (21" mid 2011)  My other iMac with Leopard doesn't have this problem.

     

    I tried it using the suggestion with pressing the power button and it works for me also?

     

    My router is not an Apple.

  • Integ Level 1 Level 1 (30 points)

    Thought I'd add my name to this long list of folks having this issue. If I use the bluetooth keyboard to wake from sleep, my wifi will often not automatically reconnect. I have disabled wake using bluetooth devices and used only the power button to wake from sleep, and the issue never occurs. I am using an Airport Extreme router.

  • Aismaiil Level 1 Level 1 (0 points)

    Honestly, the solution I suggested in my first post worked for me and several friends, I just deleted the old location in the internet system preferences and deleted my wifi's settings, and then created a new one and readded my wifi. It worked for me all this time until last week, it started disconnecting again. But, I've noticed that if I try to browse the internet it will give me that there's no internet connection and it takes safari 10 to 15 seconds tops for it to "wake the wifi up" and it just reconnects on its own! I'm fine with waiting 15 seconds I don't know if anyone tried this yet!

  • LegendMaker.com Level 1 Level 1 (115 points)

    Reconnecting my network automatically after sleep mode is a problem I've had for years, across two iMacs, so it is not a Lion problem per se, as I had this problem with Leopard and Snow Leopard, and probably earlier than those. I think it has more to do with upgrades than with the specific version you are using. Incidentally I used Airports years ago, then Airport Extreme, and currently a Time Capsule. Also this problem ONLY happens with my iMacs (I've had two since 2005, my most recent being a 3.4 Ghz Intel Core i7 (27-inch 2011) with OS 10.7.3.)

     

    I NEVER had this problem on my MacBook Pro using the same operating systems. After sleep it always logged back into the wireless network (or else it never logged off).

     

    My new iMac worked fine for the first couple of months, but now once again it's returning to the habit of not logging back into my preferred network after waking from sleep. If I restart it, no problem.

     

    I shall try the plist deletion procedure. Maybe something gets corrupted during an upgrade.

  • Tgara Level 4 Level 4 (3,540 points)

    LegendMaker.com wrote:

     

    Reconnecting my network automatically after sleep mode is a problem I've had for years, across two iMacs, so it is not a Lion problem per se, as I had this problem with Leopard and Snow Leopard, and probably earlier than those. I think it has more to do with upgrades than with the specific version you are using. Incidentally I used Airports years ago, then Airport Extreme, and currently a Time Capsule. Also this problem ONLY happens with my iMacs (I've had two since 2005, my most recent being a 3.4 Ghz Intel Core i7 (27-inch 2011) with OS 10.7.3.)

     

    I NEVER had this problem on my MacBook Pro using the same operating systems. After sleep it always logged back into the wireless network (or else it never logged off).

     

    My new iMac worked fine for the first couple of months, but now once again it's returning to the habit of not logging back into my preferred network after waking from sleep. If I restart it, no problem.

     

     

    Same here, the issue seems to be associated with my iMac, but not with our MacBook Pro, MacBook Air, or any of our iPads or iPhones.

     

    My fix was simple:  I went back to using an Ethernet cable and turned the Wifi off.  My iMac sits on my desk near my AirPort Extreme, so using an Ethernet cable is easy and convenient for me.  Sure, Wifi is cool, but given the recent problems with it in Lion I'm happy to use the Ethernet until Apple fixes it. 

  • LegendMaker.com Level 1 Level 1 (115 points)

    Tgara - yes that was my solution in the past too, as every room in my house has structured wiring (two ethernet, one for phone + cat5e coax + two fiberoptic). However I use my ethernet for other things too, and would like to free up my ports without adding secondary hub. So if I can solve this Wi-Fi problem I'd be happier.

     

    Incidentally I think it's only when the  drive sleeps that it has this problem. When the screen sleeps I can wake it and the network seems still connected.

  • Tgara Level 4 Level 4 (3,540 points)

    LegendMaker.com wrote:

     

    Tgara - yes that was my solution in the past too, as every room in my house has structured wiring (two ethernet, one for phone + cat5e coax + two fiberoptic). However I use my ethernet for other things too, and would like to free up my ports without adding secondary hub. So if I can solve this Wi-Fi problem I'd be happier.

     

    Incidentally I think it's only when the  drive sleeps that it has this problem. When the screen sleeps I can wake it and the network seems still connected.

     

    Yeah, I hear ya.  I'd much rather have the Wifi working properly too.  Hopefully Apple will get a fix in place soon.

     

    I've observed the same thing about the sleep problem:  Wifi disconnects after the drive wakes from sleep.  If the screen sleeps and then wakes, Wifi is still connected.

  • francek Level 1 Level 1 (0 points)

    Confirming problem.

    After wakeup from sleep I need to manually reconnect to my WIFI network.

    Late 2011 iMac, Lion OS X 10.7.3

     

    I wish there was some kind of file that lets you specify what to execute after wakeing up from sleep. Something like a shell script to reconnect wifi. It would be an ugly hack but I could live with it until they fix the problem. I'm not familiar with inside of OSX yet but this was an easy hack on linux.

     

    Cmon Apple. I believe it's time you fix this.

  • TonyK58 Level 1 Level 1 (0 points)

    If you want to try a shell script, here you go: http://reviews.cnet.com/8301-13727_7-57347274-263/wi-fi-network-not-connecting-a fter-sleep/   I have no idea if it will work or even make things worse for you.

     

    However, it's insane that users might need to resort to that level or programing to fix a wifi problem that seems to have plagued Lion since last summer. What the **** is going on in Apple that this problem still hasn't been solved and a permanent fix issued? For me, the-not-connecting-on-wake-up is a recent problem, quite possibly something that used to work fine until 10.7.3 came along, which ironically, was supposed to fix a problem I didn't have until recently.

     

    We pay a premium to buy Apple computer systems that we expect to work flawlessly, without any of this crap. My iPod Touch does a better job of wifi stability than my iMac. And still not a word about this from Apple, even to acknowledge a problem exists. I'm very very frustated by this. This is not what Steve Jobs would have tolerated.

Previous 1 2 3 4 5 6 Next