Previous 1 2 Next 23 Replies Latest reply: Jul 4, 2013 11:40 AM by exMacEmp
gerald273 Level 1 (15 points)

None of my widgets now work since lion instal

iMac, Mac OS X (10.7)
  • JB in WI Level 1 (25 points)

    Can you be more specific?  Are the widgets not appearing, are they malfunctioning, etc etc.  Note that by default, the dashboard moves to its own desktop space to the left of the main desktop. You can restore the Snow Leopard behavior of Dashboard in the Mission Control system preferences pane.

  • Mr. Louis Level 1 (40 points)

    Can you elaborate what you mean by "restore the Snow Leopard behavior of Dashboard"?  Do you mean that I can assign it to a hot corner and have it come up over my wallpaper and not an ugly grey Lego background on a "side desktop"?  If not, then no, it cant be restored to its Snow Leopard behavior.  Im at work and cant try right now...

  • JB in WI Level 1 (25 points)

    Yes, you can.  In Mission Control System Prefs, deselect "Show dashboard as a space", then click "hot corners" and assign dashboard to a hot corner.

  • Mr. Louis Level 1 (40 points)

    That works and is exactly what I needed, thank you.  It just looks so much better this way in my opinion.  Now that I've seen both worlds, however, it would be nice if I could keep it the way I have it now, where it comes up on top of my wallpaper and also shows up in Mission Control for another way to access it quickly.  The way it stands now, it comes up via hot corner, but doesnt show up in Mission Control.

  • Alan Goodall Level 1 (130 points)

    I have just tried this with myiMac - and it does not work.  All four hot corners on my MacBook Pro work fine.  But, on my iMac only the two right hot corners work - neither of the two left ones will work with any of the choices


    Any ideas?

  • Mr. Louis Level 1 (40 points)

    Same thing here, but with a twist.  Mission Control crashes on my 2010 Mac Mini (8GB RAM) when waking up from sleep.  In my case, the left hand side hot corners work, but the right hand side corners dont, and Mission Control cant be accessed via dock or hot corner.  Until they fix this, I have to laucnh terminal and type:killall Dock to reset things back to normal.

  • JB in WI Level 1 (25 points)

    Well,The first thing I would suggest is creating a second user in System Preferences > accounts, logging out of your current user and into the new one, and seeing if the behavior is reproduced.  That will at least let us know if it's a user level problem or a system level problem.  Get back to me.



    Also, Mr. Louis, understand that this problem may not be Apple's to fix.  It may be yours. Lots of people aren't having any issues with Mission Control or hot corners, but there may be something specific to your system causing the issue.

  • JB in WI Level 1 (25 points)

    If I were going to shoot in the dark, I'd trash my dock plist, logout/login and try again.

  • Alan Goodall Level 1 (130 points)

    Hi Thanks, only just seen this because of the time difference here in Europe!


    OK tried that - exactly the same problem in new user account!  Seems very strange that it all four hot corners works fine on my MacBook Pro.  Incidentally, MBP is having problems re wake up from sleep - but no problem with that on my iMac!


    Very strange.  Installed Lion on both as soon as it was available.  Now, two different problems on two machines - and both work fine on the other!


    Thanks for your help!

  • JudieR Level 1 (0 points)

    I upgraded to Lion a week or so ago.


    I just went to Dashboard and it does not work. I click on it on the dock and it doesn't do anything. It's in the apps folder and says it's an application, but it won't open.


    I did a search in spotlight for Dashboard and only the app came up - there is no plist or any other file associated with the program. Just the one that says it's an app.


    I tried the hot corner thing and it doesn't work there either. I did put DESKTOP in a corner and it does open so I think the hot corners work.



  • David Armstrong (SE) Level 2 (305 points)

    JudieR: If you want to find the dashboard .plist go to  Apps/Dashboard/ now right click to reveal this:

    Screen Shot 2011-07-31 at 13.30.29.png

    Here you will find the .plist for the app itself.


    However if you want to get to the cache files or any .plist files for the Dashboard or Dock or any other app you have to access your Library folder, unfortunately apple have now hidden this from us in OSX Lion and this is a way to get it back in to view. (Temporarily, you will need Terminal for a more permanent fix)


    1. From the Finder, hold down the Option key on your keyboard and click the Go menu. You should see that the menu has a “Library” option.
    2. Click the “Library” option, and a new Finder window will appear with your Library folder.


    Go to: library/preferences and you will see a file that is called "" move this file for safety (do not delete!) reasons out to your desktop and re-start your machine and try to launch Dashboard again from the dock. Hopefully a new .plist will be created and it should launch, if not then go to the same location and do the same for the Dashboard app "" . I have done this myself for other apps that get stuck or won't respond as they should and it seems to fix the issue. If all does go well don't forget to let the forum know and to delete the .plist file or files you moved out to your desktop.

    Good Luck

  • David Armstrong (SE) Level 2 (305 points)

    Sorry JudieR, I did forget to add that if things do go a bit weird after your re-start, then you can always drop your original .plists that you have moved out to your desktop back in to their original location and do another re-start. You should be back to square one to then try something else.  

  • JudieR Level 1 (0 points)

    Thank you, David.


    When I moved the dock.plist to the desktop it just made a copy there - it did not remove it from the preferences. So when I rebooted it did not work. So then I deleted from preferences and tried again. No luck. Moved the dashboard.plist to the desktop and it moved out of the library this time. Rebooted and IT WORKED!  Thank you.



  • David Armstrong (SE) Level 2 (305 points)

    Your'e welcome, JudieR.

Previous 1 2 Next