Previous 1 2 3 4 5 Next 66 Replies Latest reply: Apr 21, 2015 2:35 AM by ynaidu Go to original post
  • mikeinbangkok Level 1 Level 1 (0 points)

    Excellent advice. Had same problem - did what you suggested and all working fine again. Thanks.

  • CooperH Level 1 Level 1 (0 points)

    I'm sorry, I'm confused. There seemed to be a portion of responses that claimed that "MikeHammon" new how to fix the issue, but I didn't see any post from him. What was the resolution he provided??

  • j5e1b3h Level 1 Level 1 (0 points)

    His post is on the first page, second from the bottom.

     

    He said:

     

    I solved (sort of) this issue for me today. It seems that if you have an ordinary stereo plug (the one with two dividers in contrast to three on the iphone headphones) you can only choose between external input OR external output.

     

    So to get the external output working, you have to go to "System Settings" -> "Sound" and then at the bottom, set "Use audio port for" to Sound Output.

     

    That did it for me at least...

  • jenadrian Level 1 Level 1 (0 points)

    I am having the same problem. I have opened system preferences and ckicked on sound.

    I have no options for "Use audio port for"....

     

    speakers plugged in and sounds only comes from internal speakers.

    have tried the Audio Midi set up as well...

  • baronegmenex Level 1 Level 1 (0 points)

    I have the same problem on a new (2 weeks) macbook pro 13" with lion.

    The audio setting is already on "Video Output" and working with MIDI configuration hasn't been a solution yet. If anyone has the same problem on a new macbook and solved it, please tell me.

  • kcpenner Level 1 Level 1 (0 points)

    LT, you're a genius.  Who woulda known to do what you described?!  Worked instantly on my mid-2009 MacBook!  Thanks for the tip ...

  • Anita Bombadero Level 1 Level 1 (0 points)

    Thanks for your info. It straight away solved my problem! Yesterday I was repairing permissions with my headphones plugged-in, which I rarely use. Same problem afterwards and yes repairing those permissions again whith the headphones unplugged solved the problem. Internal loudspeakers or headphones work well. Thx.

  • NaturalGold Level 1 Level 1 (0 points)

    You deserve that beer, thanks so much

  • Ari Tjahjawandita Level 1 Level 1 (0 points)

    MikeHammon's solution does not work for my MacBook Pro Mid 2009 (MacBookPro5,5). My MBP have this issue since it had Snow Leopard 10.6.6. There is no red light in the audio port. Now it had Lion installed and the Audio setting is always been set to "Use audio port for: Sound Output". I also have tried changing the MIDI settings and using headphones with regular headphone jack with tow deviders anda iPod touch headphone, but audio that come trough from the headphones are still very low.

  • jc.chong Level 1 Level 1 (0 points)

    I had the same problem, but it started not from the begining I bought my MB Air, it was just working fine.

     

    So I reversed my memory through what I'd done to my MB Air, and I realized I started having trouble after I enabled my root access - and I was not sure if I was plugging headphones in or not like some people say it matters - so I gave it a try.

     

    I re-disabled my root access WITHOUT plugging in my headphones, and ta-da it's back working fine!

     

    I think it's some kinda permission problem with sound hardware control sw.

    (and I am not sure if it could happen to you who never changed root access thing - but if you have, give it a try!)

  • iMilletos Level 1 Level 1 (0 points)

    i have the same mac and the same problem. i found the solution and i made a video on how to fix it: http://www.youtube.com/watch?v=kxRpmKZ885I&feature=youtu.be

  • Ari Tjahjawandita Level 1 Level 1 (0 points)

    I have tried that. Does not work for my MBP. I guess it is a hardware problem. I will take my MBP to the store where I bought it.

  • dieke Level 1 Level 1 (0 points)

    Hi,

    Related but opposite issue with a MacBook Pro late 2010, using Bootcamp 3.3, in Windows 7 all updates current as of 2012-Mar-30.

    In MacOSX 10.6.8 Snow Leopard the MBP's combo (single) headset jack recognizes the (iPhone) combined headphone and microphone, in Windows 7 only the headphone (audio) works.

     

    It is annoying as the internal mic picks up too much ambient noise including keyboard. Skype for example shows the headset option among three AudioOut to choose from, for mic's there is only one option (the internal Cirrus Logic CS4206A (AB13)), no headset mic.

    In Windows Device Manager, (or under Control Panel, Manage Audio Devices, Recording, shows only the default internal mic, with driver version 6.6001.1.26, 8/16/2010 (this was installed with Bootcamp 3.1.3 and 3.2 updates, no further updates to this driver in 3.3).

    So this is what I tried:

     

    • Installed the latest driver from http://www.cirrus.com/en/products/cs4207.html
    • Device manager, driver, update, picked the inf file and it selected the driver for my hardware which seems to be CS4206A (AB13). Driver version is now  6.6001.1.30, 12/15/2010.
    • Unfortunately, sorry : no change, still the combo jack only recognizes the headphone, not the microphone. Bummer.
    • I tested again, headset mic still works under OSX, but not under Windows7.

    More ideas, anybody?? 

  • LizRizDesign Level 1 Level 1 (0 points)

    Last night I plugged in a headset into my MacBook Pro and used it like that for a while. When I unplugged it, there was no sound and the speaker icon was grayed out. I searched for answers on several forums and read where people inserted paper clips, toothpicks and inserting the jack several times. Well, I found what worked for me and i hope it will work for you... I simply got a can of compressed air and sprayed directly into the jack input... I noticed the grayed out mic icon came back on!! So it was now a hardware or software problem. Just dust! I hope this helps

  • ChrisSmith Level 1 Level 1 (0 points)

    I followed this link/solution

    Applications/Utilities/Audio MIDI Setup/Built-In Output/Output and in Format change from the default 2ch-24bit integer to any other format (say, 2ch-32bit float).

     

    BUT

    when I went there I found the MUTE boxes ticked ... I unticked and all was fixed ...