Previous 1 2 3 4 5 Next 74 Replies Latest reply: Mar 30, 2016 10:05 AM by patbenhmida Go to original post
  • cbenjamin1 Level 1 Level 1

    This worked for me. Such a simple fix for something that could have been catastrophic.

  • maggie300 Level 1 Level 1

    Thank you SO much.  Really appreciate your post.  Audio has been causing me to pull my hair out and you have solved it. 



  • Ady46 Level 1 Level 1

    simple fix would be to increase the 2 volume, in all probababilities it might have been at the minimum level. changing the integer level should have no bearing with the left or the right earphone not working..  hope it helps


  • siregabriel Level 1 Level 1

    Thanx ! this helped me. Solved muy problem in Mountain Lion. I am happy.

  • grok12 Level 1 Level 1

    mikehammon, thank you so much!  You solved my problem.  I'm so happy!

  • inothatcat Level 1 Level 1

    Rebooting (restarting) worked for me. I've had my mac for years and it just started happening today, however. Best of luck, all~

  • DJ Jim C Level 1 Level 1

    Thanks to Michael for this solution:


    Go to  Utilities/Audio MIDI Setup, select the Internal Output and uncheck the "Mute" boxes.


    I recently upgraded my iMac to 10.8.3 and that's when the audio stopped working.  Now, when I reboot the audio goes away again.


    Apple, please fix this issue!  Thank you.

  • etarak44 Level 1 Level 1

    This guy gets it! Same thing here, occasionally my MBP won't recognize any headset. This is a pain as sometimes I need to talk via skype for work. It's really annoying to have to restart my computer, but I have recently noticed that putting it to sleep achieves the same fix. So for anyone that doesn't have Headphone Output as an option when the headphones are plugged in, just put it to sleep and wake it up. This IS a software issue and I first noticed it on 10.7 and it's still an issue for me on 10.8.


    I should note this is not a red light issue that needs to be fixed with a toothpick, that is an entirely different issue.

  • Pomppe Level 1 Level 1



    After installing last night "Amarra" advanced hi-end music player and "TechTool Pro 7" Mac technical utility, with which I went through permissions, surface scans, file structure rebuilding and whatnot on my macbook pro 2011 10.8.4, I today to my great shock and despari noticed that the headphone jack didn't work anymore just as I was about to start recording a new dj-mix with Traktor 2.6.2. To note is that I also last night installed a 2 meter extension cable on the headphone output to the 2.1 speaker set connected to them.


    Solution was simply to restart. Headphone jack is working both as a simple output or as a module in my 4-way created aggregate device, needed to have a prelisten output for usb headphones.


    Scary problem with a simple solution to a, for me, pretty complex setup.


    Thanks all. Reboot and give your Mac a breather atleast after several installs and maintenance routines.

  • spuDaisy Level 1 Level 1

    found a solution that worked for me


    Under Sys Pref> Sound > Click on Internal speakers.  Then at the bottom set audio port for "sound output."



  • sergiyfromma Level 1 Level 1

    ok guys so here's the deal.. you can do two things (first one didnt work for me but second one did..)


    number 1:


    go to system prefrences>sound>output  on the bottom there you will see "Use audio port for" change that to SOUND OUTPUT and make sure the mute box next to it is not checked..


    number 2:


    go to Finder>Applications>Utilities>Audio MIDI Setup>Built-In Output in the drop down menu change from the default 2ch-24bit integer to format (say, 2ch-32bit float).



    THESE TWO SHOULD SOLVE IT ALL.. hope it helps)) good luck!!

  • Calen Level 1 Level 1

    I have a slightly different issue with my late 2011 Macbook Pro running 10.7.5. My internal speakers are fine, but my headphone jack seems to be having problems with the R line output. I don't have any speakers I can test at the moment, but I do have a pair of headphones which work normally in other computers and my iPod shuffle.


    When I first plug them into the jack, R is very quiet (at least half the volume of L, probably less). If I try to change the volume at all with the F11 or F12 keys, I lose R altogether, while L continues to function normally. I have tried canned air and cleaning the jack with another 1/8" headphone plug to no avail. I have not tried any software fixes because this seems very much like a hardware problem I see with professional audio equipment and 1.4" speaker plugs sometimes, but in this case I could be wrong.


    Any suggestions?

  • Peter Stolle Level 1 Level 1

    Encountered this problem on my iMac a year ago and finally decided to look into it further.


    I followed the advice of LT30000 above but to no avail. But just as I was about to give up, I per chance noticed the three MUTE boxes on the right of the window were all checked off. By simply unchecking the MUTE boxes, my external speakers came alive again



    Screen Shot 2011-07-25 at 10.47.32 AM.png

  • Frank Lowney Level 1 Level 1

    Running MacOS X 10.9 here and finding my headphones not working after upgrading from an early 2008 MP to an early 2009 MP.  Apparent failure to recognize the headphones, the same ones that came and work fine with my 5g iPod touch. FWIW, none of these software solutions worked for me.  The slightly newer MacPro works correctly with an old headphone but not with the newer one even though the connectors appear to be exactly alike.

    A microscopic difference in these two plugs is the cause of it not appearing in the Sound  prefs pane when inserted. What I discovered was that if I held the plug and pushed it fully into the headphone jack, "headphones" would appear in Sound. Releasing it resulted in its disappearance.  In my case, it's a hardware problem that using another set of headphones works around.  Perhaps with further use, it will loosen up to the point where any proper headphone will work.

  • katybarthedoor Level 1 Level 1

    Oh my gosh, this happened to me tonight when I got home, turned on my Itunes Radio, and the sound slowly went away.  I found your conversation, performed the change you explained under applications and it worked.  You are awesome.  Thank you for posting help on here, without it I might have done something really stupid like buy another Logitech speaker set!