Previous 1 2 3 4 Next 79 Replies Latest reply: Sep 12, 2015 4:12 AM by abavetta Go to original post
  • iVmichael Level 6 (13,725 points)

    Something buggy for sure, mine worked for a few days and then at the next reboot my ~/.Trash vanished again and I was back to square one. Repeated the steps in my post above and all's working again ...


  • ckujau Level 1 (0 points)

    @LexSchellings If the ACLs set prohibit deleting of files, no other application would be able to magically delete them. If it did, this would be a (security) bug. I doubt this is the case here.


    @simontaylorjones What dou you mean by "backup file"? Have you checked the permissions of the files you want to delete? (use "ls -le" or "Get Info" in "Finder")

  • Piccolib Level 1 (0 points)

    Guys, I have the same problem!


    Its becomning extremely annoying


    Anyone already solved it?

  • haggibbor Level 1 (10 points)

    I had the same problem with trash very suddenly in Lion (never had it before), and iVmichael's solution fixed it.


    As usual, any .0 version of OS X is essentially a beta.


    Thanks for the fix.

  • Piccolib Level 1 (0 points)

    I've tried his solution without sucess

  • LexSchellings Level 6 (8,747 points)

    ckujau, did you try it? or is this theory?

  • ckujau Level 1 (0 points)

    I sure did & it helped. And why wouldn't it? There's no magic involved here: when one is unable to (re)move files, it's either a permission problem (standard unix permissions or ACLs) or the filesystem is corrupt. Ruling out the latter, setting the correct permissions will help.


    It *is* however weird why those permissions were set in the first place (I had: "group:everyone deny delete", denying everyone, including me, to (re)move files) and that may indeed be some bug in an application or even the OS. Who knows.


    Not sure if I'm allowed to post external URLs, but when I came across the issue on my box, I felt the need to write about it :-)

  • Soap McTavish Level 1 (0 points)

    Guys I've been having the exact same problem - Lion asking for p/w to delete files, unable to delete files from inside iMovie etc..but I solved the problem (for myself at least) - the solution was quick and simple and the only one that worked for me - I won't go into an over-long techinical explanation - suffice to say:


    Clean install of Lion = problem

    Upgrade from Snow Leopard (and presumably Leopard) to Lion = problem solved


    I really hope it's that simple for the rest of you!! Fingers crossed it'll work for ya coz it sure has for me!

  • Soap McTavish Level 1 (0 points)

    and I have no idea.... I guess maybe upgrading preserves your permission settings...

  • elsauz Level 1 (0 points)

    Hi, This is my first time on this forum so I hope I'm doing this right.  I was having the same issues with Lion.  Anytime I made any kind of change to a file regardless of the folder, Lion asked for a password.  Discussed it with a more learned friend and he suggested it was a permissions problem.  This is his solution:

    1. Reboot into Lion Recovery Partition by holding down Command and "R" keys immediately upon hearing the      startup chime.

    2. You'll see a grayish background.  This tells you are in the recovery partition.  You'll see a menu with several tasks you can perform.  Highlight Disk Utility and click continue.  Once you launch Disk Utility, highlight your Harddrive and first do a permissions verification and then repair permissions.  Restart your computer.  That's what worked for me.  Hope it works for you.

  • mbcruz Level 1 (0 points)

    I tried changing the permissions but it didnt work, and neiher did the sudo chown username .Trash command for terminal people told me to do. I did however go to System Preferences > System > Users & Groups > clicked the current user and UNCHECKED the box that said "Allow user to administer this computer", it then prompted me to restart my computer and I did. After the restart I went back and checked it again to make it the Admin account, restarted it again and now the problem I had with the trash is gone! Try it out, it worked for me.

  • JoaoPepe Level 1 (0 points)

    Try going to Disk Utility -> "select HD" -> First Aid -> Verify/Repair disk Permissions

  • MSiLight Level 1 (0 points)

    I Found a Solution,

    Open your Home folder,

    then get info,

    in the bottom click on the lock bottun and enter your password, click on + and select your name,

    then in the privilege select read/write,

    then click on the perefrence icon beside +, apply all enclosed folder.....

    it's work for me. all privilage in mine.


  • cegh Level 1 (0 points)

    That didnt solved my problem.


    I found a solution and worked


    1. You need to view hidden files in Finder. To do that, open the console and type:


    defaults write AppleShowAllFiles YES


    in time: press return  in keyboard, of course..


    2. Launch Finder and if you dont see hidden files and folder do this:


    hold ‘alt’ on the keyboard and right click on the Finder icon and click "relaunch"


    3. Go to your home folder and find the hidden Trash folder: ".trash"  .... if you look carefully you will see a red sign/flag on it.


    4. Right click on .trash folder and select "Get info".


    5. On botton of info pane, you need to add your user with read and write permissions.


    6. Open Console again and type:


    defaults write AppleShowAllFiles NO


    With that you will no longer see hidden files again. "status a quo" returns.




    Somehow, trash folder lost the user/permission settings. Dont ask me how that happened.




    Message was edited by: cegh

  • rodfromcoquitlam Level 1 (0 points)

    I got this proceedure from macbook air question on an IT site, but it solved the trash/password problem on my macbook pro with lion in a minute!


    1. Restart your MacBook Pro, and before you hear the chime, hold down the Command and R keys.


    2. You’ll be at the Repair Utilities screen. Click the Utilities item in the Menu Bar, then click Terminal.


    3. In the Terminal window, type resetpassword and hit Return.


    4. The password reset utility window launches, but you’re not going to reset the password. Instead, click on icon for your Mac’s hard drive at the top. From the dropdown below it, select the user account where you’re having issues.


    5. At the bottom of the window, you’ll see an area labeled Reset Home Directory Permissions and ACLs. Click the Reset button there.


    The reset process takes just a couple of minutes. When it’s done, exit the programs you’ve opened and restart your Mac.


    It will be back to normal.

Previous 1 2 3 4 Next