Previous 1 2 3 4 5 6 Next 78 Replies Latest reply: Jan 18, 2014 11:36 PM by chowkaying Go to original post
  • LexSchellings Level 5 Level 5 (6,625 points)

    very good. But even "taking candy from a kid" is too difficult sometimes: to avoid Terminal completely, you better install a simple widget called "hiddenfiles.wdg" to be able to choose see hidden files or not.

  • Mimo28 Level 1 Level 1 (35 points)

    I have had this problem too since installing Lion.

    I did do a re-install and it didn't cure it.

    Tried few suggestion given here at the forum with no luck.

    Yes it is becoming quite an annoying problem.

    I had to set up a folder in the desktop where I place all the stuff I want to delete and trash it (with password) at the end of the day.

    Come on apple sort it for us.

  • Rodes01 Level 1 Level 1 (0 points)

    Thank you!!! that worked for me.

  • mtrepanier Level 1 Level 1 (0 points)

    It works!

  • peacemaster Level 1 Level 1 (0 points)

    I have had a similar issue and I resolved it in this way (in my case it was not the .Trash issue) - I was asked to enter the administrator's credentials when I have tried to move, rename or delete files:

     

    1. create a new folder with this user-account

    2. move all files to this folder - now you will be asked for username and password of the administrator, enter this

    3. get the info of this folder and scoll down to the permission field

    4. open up the "lock" in the right bottom corner (needs also admin credentials)

    5. change the permissions of this user to read only

    6. click on the gear wheel and select apply to enclosed items and click on ok

    7. now change it back to read and write and apply to enclosed items

    now you should be able to move all your files back to the original location and you will not be asked for administrator un and pw

     

    perhaps that resolves your issue as well

  • sZc Level 1 Level 1 (0 points)

    Quote by mbcruz:

     

    "Lion asking for password to delete trash or overwrite files  Aug 19, 2011 11:59 PM (in response to Lightwavemunk) I tried changing the permissions but it didnt work, and neiher did the sudo chown username .Trash command for terminal people told me to do. I did however go to System Preferences > System > Users & Groups > clicked the current user and UNCHECKED the box that said "Allow user to administer this computer", it then prompted me to restart my computer and I did. After the restart I went back and checked it again to make it the Admin account, restarted it again and now the problem I had with the trash is gone! Try it out, it worked for me."

     

     

    You my friend, are Genius! I've tryed every single thing suggested in this thread, and nothing worked.

     

    I did what you suggested and instantly after the second reboot (two reboots needed when doing this procedure), everything went back to normal.

     

    Thank you so much!!!

  • Gemini Enfield Level 1 Level 1 (0 points)

    Many thanks Michael, sudo chown your_user_name ~/.Trash is what fixed it for me. Been a real nuisance and was stopping me from upgrading some software, as it couldn't place the old version in the trash.  Thanks again

  • changpeeee Level 1 Level 1 (0 points)

    if the .trash is not the problem, try to "get info" for the "Macintosh HD" (this is located in Finder, on the sidebar, under "Devices"

     

     

    Under "Sharing & Permissions:"

    1. check to see if your account/user name is there, "User name (Me)" and
    2. if the priviliege is set to "Read & Write"

     

    If your User name is not shown or the privilege is not set to Read & Write:

    1. on the bottom right corner, click the lock to unlock, enter User name and Password when prompted
    2. if User name is shown, skip to (#3), if not, then click the "+" on the bottom left and add the User name/account
    3. next to the User Name, change privilege to "Read & Write"
    4. if you see two(2) "everyone" user names, one with the privilege "Custom", this may also cause problems, try to delete one of them
    5. click the gear icon, then click "Apply to enclosing items..."

     

    Another window will pop up stating that the changes are being applied. This may take a few minutes. When the window is finished, the problem should be solved.

  • ankhank Level 1 Level 1 (0 points)

    > User name is not shown ... privilege is not set to Read & Write:

     

    I do that list when I really have to move a file, and it works -- but I've always (since  I got Lion, with this Mac) had to unlock the 'padlock' icon in between each step  (lock then unlock/give password again, between each of your numbered steps).

     

    If I don't do that, I can't make a change stick.  (Sometimes have to click the sideways triangle to collapse the list then again expand that before I can see a change has been made.

     

    I'd guess behind the GUI  it's doing 'su' instead of 'sudo' -- I have never found a log file showing these steps happening so don't know.

  • andreaomasic Level 1 Level 1 (0 points)

    Had the problem and solved it. Download DEMO or buy application Mac Pilot. Under tools menu, go to General - Files and Folders, find option "Wipe ALC Data" and choose your home folder. Afterwards, deleting and moving files working without entering password...

  • sZc Level 1 Level 1 (0 points)

    There is no need to spend money on Mac Pilot just for that. OS X Lion has this built in, it's just not many people know about it. See here:

     

    Repairing User Permissions in OS X Lion

    You’ll need to reboot to perform this, and then use the same resetpassword utility that is used to change passwords in Lion, but instead choosing a hidden option.

    When you use the Disk Utility app and Repair Permissions — it doesn’t actually repair the permission settings on folders and files in your Home folder where your documents and personal applications reside.

    In Lion, there is an additional Repair Permissions application utility hidden away. This tool is located inside boot Repair Utilities. Here’s how to access it.

    1. Restart Lion and hold down the Command and R keys.
    2. You will boot into the Repair Utilities screen. On top, in the Menu Bar click the Utilities item then select Terminal.
    3. In the Terminal window, type resetpassword and hit Return.
    4. The Password reset utility launches, but you’re not going to reset the password. Instead, click on the icon for your Mac’s hard drive at the top. From the drop-down below it, select the user account where you are having issues.
    5. At the bottom of the window, you’ll see an area labeled ‘Reset Home Directory Permissions and ACLs’. Click the Reset button there.

     

  • andreaomasic Level 1 Level 1 (0 points)

    Tried, bud didn't help!

  • benjikan Level 1 Level 1 (0 points)

    This worked for me.

     

    Open Terminal from the Utilities Folder

    enter the following:

     

    sudo rm -rf ~/.Trash

     

    Press Enter

     

    Enter your Password

     

    Press Enter

     

    Log out and re-log in or re-start your computer and Voila, it works!

  • in8chiro Level 1 Level 1 (0 points)

    Was having the same problem.  Searched the forums and found this.  It works.

     

     

     

    Run Utilities/Terminal and use the command

     

    sudo chown your_user_name ~/.Trash

  • Arm10 Level 1 Level 1 (0 points)

    3