Previous 1 2 3 Next 39 Replies Latest reply: Aug 4, 2012 7:24 PM by pbmax
pinchvalve Level 1 Level 1

My screen saver keeps trying to activate, even while I am typing.  At whatever interval I set for the screensaver, it starts to activate regardless of whether I am typing or scrolling.  How do I force the screensaver to activate only AFTER a period of inactivity?


iPhone 4, iOS 4, MacBookPro
  • TankPlay Level 1 Level 1

    Not just me then.

    I'm getting exactly the same problem. Hoping this annoying problem will get fixed soon with the next mini update.

  • aanon4 Level 1 Level 1

    Me too - driving me up the wall - had to eventually turn it off (which is not the solution I want).

  • RJS78 Level 1 Level 1

    me too

  • phutch3 Level 1 Level 1

    Same problem. I'm so happy I'm not the only one. It's driving me wild.

  • mosoliman Level 1 Level 1

    I'm having the same problem as well. I guess I don't need to do a reinstall if this is a common issue.

  • mosoliman Level 1 Level 1

    Seems like this problem is limited to Mid-2010 MBP's with i5/i7. Very unfortunate since this model line has had many problems interacting with Apple software (kernel panics, etc.)

     

    Only way to solve this issue for now is to set the Start Screen Saver setting in preferences to "Never". If you are leaving your system unattended and want to lock it, then just Apple Menu --> Sleep.

     

    Wouldn't be surprised if Apple never resolves this issue for us given that they did nothing about the hordes of Mid-2010 owners complaining of kernel panics and it never got a single fix.

  • mosoliman Level 1 Level 1

    See above.

  • iGwen Level 1 Level 1

    I have exactly the same problem since i installed Lion on my MBP.

    It happens every half hour.

  • Crozlo Level 1 Level 1

    I also am having the bug.

     

    Mid-2010 15" MBP 2.66 i7

     

    Not only does the screensaver activate randomly during regular usage, but it also activates Flurry screensaver (which isn't even the screensaver which I had selected before turning it off!) immediately upon startup every time - this happens over the user login screen, as I have auto-login disabled.

     

    Additionally, since installing lion, I have had 2 complete system freezes - has never happened on this MBP since I purchased it in 2010.

  • JoeMeg Level 1 Level 1

    I just solved it for my 2010 MacBook Pro.  I was researching an unrelated problem with 1Password locking all the time.  And it turns out to be related. 

     

    AgileBits, makers of 1Password reports: "The general class of application that provides any kind of video drivers for screen sharing, supports remote devices or computers as “monitors”, etc. has been identified as needing to either be updated for Lion, or temporarily removed from your system if the software vendor hasn’t yet gotten a compatible update ready."

     

    It appears to be the result of specific apps, including AirDisplay, LaunchBar, and DisplayPad.  I was using AirDisplay. 

     

    I just uninstalled AirDisplay (via the uninstall script) and rebooted and the screensaver problem has completely been fixed.  Thank goodness.

  • aanon4 Level 1 Level 1

    AirDisplay for me to - uninstalled and everything is good.  Thanks so much!

  • loloasis Level 1 Level 1

    Thanks.

  • pinchvalve Level 1 Level 1

    I have AirDisplay as well, which I use a lot, so I guess I am turning the screensaver off for now.  Thanks for the awesome response!

  • Sommertimes Level 1 Level 1

    AirDisplay did it for me too - all is fine now. Thanks a lot JoeMeg!

Previous 1 2 3 Next