Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't connect via SMB

Prior to installing Lion, I would connect to our shared drives at work via SMB. Today, after installing Lion, I can't connect to my shared drives. The one SMB connection that works is to an FTP server. I connect via SMB to map the drive in my Finder rather than using an FTP program. This still works fine.


However, I can't connect to the shared drive for file sharing. In the Connect to Server box, I have "smb://PathToFiles" . Is smb:// the correct prefix to use now that Lion is funky with SMB support?


I'm sorry...I really don't know much about SMB connections, what kind of server it is that I'm trying to connect to, or much else. I know we run Windows Exchange, but I'm not sure if that's the server that hosts these shared drives...I just need to connect to get back to work. Any help would be AWESOME.

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I (or I should say, my IT guy) finally fixed my problem! I outline the solution in as much detail as I can on my blog: http://fatwalr.us/2011/08/solution-to-my-smb-connection-problem-in-lion/ .


Basically, all I need to do is go into my Terminal and manually mount the drive. I have no idea why this works though Terminal and not through the Connect to Server panel, but it does. Since it's so simple, I'm expecting a Software Update from Apple soon to fix the problem for good.


I hope this helps any of you who are in the same position as I have been (frustrated out of your mind).

Posted on

Question marked as Helpful

Aug 1, 2011 1:59 PM in response to upeace In response to upeace

For those of you trying to access SMB shares, I found a free and easy solution.


Since a lot of people report they are able to access their NAS using apps other than the Finder itself, I decided to look for a free Lion-compatible File Manager to use instead of Finder.


I have found muCommander ( http://www.mucommander.com/ ) and indeed it works fine. All I did was click on the button highlighted bellow, go to "bonjour services" and select my NAS. It prompted me for my username and password and voilá, it works fine.


User uploaded file


I keep Finder for everyday use and just load muCommander when I want to access the NAS. At least now I don't have to start my WinXP VM anymore just to access it.


Hope it helps you all.

Question marked as Helpful

Aug 2, 2011 7:13 AM in response to upeace In response to upeace

I have posted this problem on my blog along with a more complete review of Lion. Hopefully it will attract some more attention to the issue, and maybe someone will leave a solution in the comment section there. If so, I'll be sure to update this forum with the info.

There’s more to the conversation

Read all replies

Page content loaded

Jul 22, 2011 8:59 AM in response to upeace In response to upeace

Okay, so here's some follow up info after talking with my IT department.


The server that I'm trying to connect to is 2008 Windows File Server. We employ Active Directory for permissions and validation.


My IT guy thinks that the reason that I can connect to the FTP side of things via SMB is because, in that case, I have root-level access to the content. In all the other directories that I'm trying to access, I do not have root level access. Something with the way Lion is connecting is not properly working with Active Directory and denying me access to the folder. He said that this same problem existed on OSX 10.4, but had gotten significantly better in 10.5 and 10.6. In his opinion 10.7 is a major step backwards. I would have to agree.


Obviously, the solution to this problem is not to have IT give me root level access...that defeats the purpose of permissions. I also cannot expect my IT department to recalibrate settings on our server to help me fix a problem that Apple caused.


I'm leaning towards reverting back to 10.6 Snow Leopard to solve this problem. I'm definitely kicking myself for jumping on Lion so early...I just wish that I had known about this problem before installing.

Jul 22, 2011 8:59 AM

Reply Helpful

Jul 22, 2011 9:12 AM in response to upeace In response to upeace

Hi,


I'm a Network Manager/Engineer, in an AD Domain, and SMB works fine for everyone that needs to be able to access their shared drives. "Root Level, or not". I've not had a single complaint about Lion, with mapping drives, dropping WiFi connections, etc - so far it all works as advertised.


You might want to rejoin the domain, and see if that helps. We didn't have to do anything here, and it all works fine, in Lion.


Cheers,

M.

*****

Jul 22, 2011 9:12 AM

Reply Helpful (1)

Jul 22, 2011 11:55 AM in response to Monty1945 In response to Monty1945

Hi Monty, thanks for chiming in.


What if my machine is not on the domain? I ask that question because...it isn't.


We are a very PC-centric organization, so Macs have always been more "tolerated" than anything. If we can get them to work on our network, that's usually good enough. For that reason, none of the Macs in our building are actually on the domain.


As Rob asked, have you tried any machines that are non-domain?

Jul 22, 2011 11:55 AM

Reply Helpful

Jul 22, 2011 12:06 PM in response to upeace In response to upeace

Hi, I've got a similiar problem after I set up Lion...


I've got a PC, running Windows NT (I know, it's old, but I can't change/update it) and with Lion I can't access to its SMB sharings... No problems with Snow, no problems with Windows XP, and no problems with Windows 7 Pro (but I had to change this settings in Admin Tools http://technet.microsoft.com/en-us/library/cc738867(WS.10).aspx)


There is a way to enable access to old sharings?

Or a way to "downgrade" to Snow Leopard's Samba?


Thanks, have a nice day...

Jul 22, 2011 12:06 PM

Reply Helpful

Jul 25, 2011 6:42 AM in response to upeace In response to upeace

I have something to add:


connecting with Lion to a "Windows Server 2008 R2 SMB Share" without a Domain works just fine in our local network.


We have several locations we are connected with through a VPN tunnel. When trying to connect to a "Windows Server 2008 R2 Share" with or without domain in a remote network, that does not work.


In our VPN here there is nothing blocked, all ports are going through. But since there is no difference between a 2008 R2 IN a Domain or NOT in a Domain I would blame the VPN and not the Domain.


But since every port is open I can't pinpoint where it comes from.


So, any help apreciated, and hopefully my information helps getting answers for other as well!


Have a nice day

Jul 25, 2011 6:42 AM

Reply Helpful

Jul 25, 2011 8:53 AM in response to upeace In response to upeace

Having the same problem here. Was able to connect to my office via VPN -> SMB before Lion using Snow Leopard and aft the Lion upgrade...nada. Can connect to the VPN (Cisco) but that is as far as it gets. May have to go back to Snow Leopard was well.


I really wish the first rule of upgradeing was "do no harm..."


Any help would be appreciated. Everything else in Lion worked fine, however, this is huge.

Jul 25, 2011 8:53 AM

Reply Helpful

Jul 26, 2011 6:33 AM in response to upeace In response to upeace

Ok, so here's an interesting update. I took some screenshots to help communicate what I'm trying to say.


There are two key folders that I'm trying to connect to via SMB. One is a public folder, which is accessible to anyone on our domain, and the other is a departmental drive.


Screenshot:

User uploaded file


Now, when I push "Connect," I get the folder that indicates that I do not have permissions to view the contents.


Screenshot:

User uploaded file


However, when I toggle the folder view, I can actually get into the folder. In other words, simply changing the view to thumbnail view instead of column view, the folder contents appear.


Screenshot:

User uploaded file


This little "hack" however, does not work when trying to access the departmental folder. I would have to guess that this is because my departmental content is two folder levels above "nyfiles" while the public content is only one level...?


Does this help any of you see what the problem might be? I'm really getting tired of having a PC sitting next to me all the time to move files back and forth that my Mac can't connect to. However, I'm scared to downgrade to Snow Leopard and potentially lose data. So, if anybody (maybe someone from Apple...hint, hint) can give some advice to resolve this, that would be amazing.

Jul 26, 2011 6:33 AM

Reply Helpful

Jul 27, 2011 6:40 AM in response to upeace In response to upeace

I am having a similar issue since upgrading to Lion...


Our departmental shared files are on a Windows server (2003?), two levels past the root, and managed by active directory. When I use "go to server" and the same SMB line I've used succesfully prior to the upgrade, it asks for my login credentials, then dumps me in the root directory. From which I can't do anything, because I don't have root access.


I was wondering if the syntax for the connection has somehow changed under Lion? I can't find anything to resolve this yet... Any help would be immensely appreciated - ALL my files are on that shared drive!! :-/


-A

Jul 27, 2011 6:40 AM

Reply Helpful
User profile for user: upeace

Question: Can't connect via SMB