Previous 1 2 Next 19 Replies Latest reply: May 20, 2015 12:30 PM by FbxFbx
octafish Level 1 Level 1 (25 points)

I have an external 1TB Maxtor drive that I have used to clone my system drive to on a nightly basis using SuperDuper. Yesterday I upgraded to Lion and awoke to a SuperDuper error message indicating that the clone did not occur. I tried running disk utility and repairing the disk, but I got an error message that it could not unmount the disk. I tried rebooting and when I ran disk utility again, the "custom name" of the drive wasn't showing, instead it just showed the generic 1TB Maxtor. I figured I'd just start over from scratch and format the drive and do a complete new clone, but when I try to format the drive with Disk Utility, I get the following error:


Disk Erase Failed with the error:


Unable to write to the last block of the device



Is my drive hosed? What can I do?

  • Dead Parrot 42 Level 1 Level 1 (0 points)

    The same thing just happened to me, also with a SuperDuper nightly backup.  If anyone gets any information, please let me know.  It now looks like disk is dead.

  • rhearob Level 1 Level 1 (5 points)

    Ditto.  I was using time machine encrypted backups and the backups began failing.  I looked in the logs on console and saw that there was a generic error writing to the disk, tried to repair and couldn't.


    It seems as if in my case the disk has become completely hosed.  It wont mount because it doesnt ever recognize the encryption key.


    I cant even do anything with it from terminal.

  • donkatron Level 1 Level 1 (5 points)

    I've got the same problem. 10.7.1 didn't fix this.

  • bmastel Level 1 Level 1 (0 points)

    The workaround I used successfully was to use my MacBook Pro running 10.7.1 hooked via FW 800.  I started my iMac over the FW using my MBP as an external source.  I was able to read and recover data from the iMac before erasing and I am currently reloading the system.


  • donkatron Level 1 Level 1 (5 points)

    Bruce, thanks. Looks like this worked. I was able to encrypt the drive with it plugged in via Firewire and then switch back to USB once the initial backup was complete.

  • flogik Level 1 Level 1 (0 points)

    I continue having this problem. The 'workaround' isn't really one in my eyes as it requires you to own at least two Macs and being able to establish a FW800 connection.


    I have a iomega 1TB external drive with USB only; that's the drive I'm experiencing the issue with. I haven't done anything unusual with it; I used it to make a TimeMachine Backup with it in Snow Leopard and then to restore my Lion system with said backup, everything worked fine even when I started using TimeMachine with it in Lion.

    TimeMachine eventually complained and the disk couldn't be read anymore, which caused me to erase and partition it, using GPT with MacJournaled (HFS+) for the main partition (I was planning to use for my TimeMachine volume) and NTFS (I'm using Paragon since Lion cancelled 3G and MacFuse, thanks to Apple for that btw) for another partition I planned to use for music etc.. Once again after a week of successful work with this configuration, the NTFS partition couldn't be read anymore and can't to this day while the TimeMachine volume shows, but can't be accessed.


    As you can probably read between the lines, I'm not very happy with this situation. I never experienced any problems concerning file systems in Snow Leopard and I'm a little disappointed this has changed and even more disappointed it hasn't been fixed yet. Just as a sidenote in case anyone at Apple actually reads this.


    If anyone has any clue on how to get rid of the "Unable to write to the last block of the device" message, no matter how, and reformat the ******* thing, I'd be quite thankful.


    Before you ask - safely erase didn't work, although this was indicated by a similar thread somewhere, I'm not sure where anymore. It doesn't say "Unable to write to last block" but it still fails to erase.

  • littlerob Level 1 Level 1 (0 points)

    Hi, has anyone found a sensible answer to this?  I am having the same problem with a usb hard drive and I only have one macbook!  I can connect it to a pc and it works fine, the only problem being I want to format the drive as mac os.


    There seems to be lots of work arounds on forums for this, but all involve more than one mac or a linux box and I have neither?  It seems a little weird to me that I have a perfectly good hard drive that I just cant use now that I have lion.


    Please help!!!

  • softwater Level 5 Level 5 (5,370 points)

    You could try DiskWarrior, which has a pretty good reputation for repairing and recovering lost disks (including salvaging data of disks that are kaput), but it will cost you, unfortunately.


    EDIT: BTW, I'm assuming you've already tried Applications > Utilities > Disk right?

  • littlerob Level 1 Level 1 (0 points)

    Yes, it is in disk utility that I am trying to format the drive.  The problem is not that the drive is lost or needs repairing (as far as I can see) as it will format fine on a pc, its only on my mac through disk utility that it won't format, giving me the error.


    Oh, well.  I'll just use my pc for that stuff I guess, rather than doing away with windows completely!



  • softwater Level 5 Level 5 (5,370 points)

    Yes, I understand that, but it sounds like the problem is that Lion is misreading the disk and thinks there's an extra physical segment which doesn't really exist (hence, it can't 'access' it).


    DiskWarrior rebuilds the index file that Mac OS uses to navigate the disk by matching the logical structure to the physical one and rewriting the index file.


    I'm no expert and can't say that's what the problem is for sure, or that this will certainly work, but it's what I'd try if it were me.

  • littlerob Level 1 Level 1 (0 points)

    I see,  thank you.  I guess I just a bit dissapointed that since I upgraded my macbook to Lion some stuff doesn't work!


    I'll have a look into disk warrior and may give that a go but it would actually be cheaper for me to buy a new drive!


    Thanks again.

  • softwater Level 5 Level 5 (5,370 points)

    Yes it would, and there's no guarantee that it will solve your problem. On the other hand, there's no guarantee that you won't get the same problem on a new drive .


    I'm not trying to sell you on Disk Warrior; I agree that the price is prohibitive, but it does other things too and is a handy tool to have so give it some thought. Search around the net for some reviews and see what you think.

  • jarfanboy Level 1 Level 1 (0 points)

    Have there been any other solutions found for this problem?  I am having it as well.

  • KILLMeDJ Level 1 Level 1 (0 points)

    Hey there,

    I'm sure you've solved this by now.

    But I had the same issue with a 500GB WD external drive.

    I was using USB at forst but then tried with a FW 800-FW400 cable and Viola'!!

    It worked!

    All the best

Previous 1 2 Next