Previous 1 15 16 17 18 19 Next 278 Replies Latest reply: Dec 2, 2012 11:44 PM by 2yb Go to original post Branched to a new discussion.
  • Nathan Jackson Level 1 (5 points)

    Mine is a 2008, no I don't get the No Hardware thing, weird.

  • deadshift Level 1 (15 points)

    MBP 15" late 2008 unibody, 2.4 GHz core 2 duo.

    Some boots leave me with Wifi off, and won't turn back on.  powerdown and SMC reset seems to fix it.  Only happens on reboot, not sleep.  Does not seem to be a problem with 10.6 snow leapoard.  Does not seem to be a problem if I boot in safe mode.

     

    This wasn't a problem for me until recently.  I don't have a good reason why.  I don't reboot often, so perhaps it just didn't show up until now.

     

    On a no-wifi boot, I get a console message of "WirelessAirPortDeviceNameCopy(): no BSD interface name found for object 13571"

  • Kristjansson Level 1 (0 points)

    I freaking love you. Fix worked perfectly

  • Nathan Jackson Level 1 (5 points)

    Ok today I wiped my MBP, did a clean install of Lion and then a combo update to 10.7.3. Restored from Time Machine but didn't restore settings. Wifi has been working fine all day. Will eventually update to 10.7.4 and see if that changes anything.

  • essorkm Level 1 (0 points)

    errrr - don't have his baby - he'll leave you in a week heartbroke and WIFI-less

  • CMC92 Level 1 (0 points)

    Any chance you could explain how to do this?

  • Nathan Jackson Level 1 (5 points)

    Ok so you want to make sure you back up to Time Machine first - I'm assuming you know how to do that, if not search google. Or if you don't care about your data then don't bother.

    Then read this:

    http://www.macworld.com/article/1161837/restore_lion.html

     

    It should be fairly easy to follow the steps to restore from a Time Machine backup after that. I deselected settings because I think there might be a setting that is causing the WiFi problem.

     

    That should leave you on Lion 10.7.0, and you can then download this: http://support.apple.com/kb/DL1484

     

    I am on 10.7.3 at the moment and have no problems at all. It may be 10.7.4 that causes the problem, it may not, but for the moment I'm happy like this.

  • wasteofspace Level 1 (0 points)

    I have had this problem and the only bit of my 2008 machine left that is original is the chassis and the top pad on case. EVERYTHING else has been replaced as it has failed at one time or another, I have had mulitiple reinstals and this problem goes away for a bit and then comes back.

     

    Seven times I have had to reboot today because Wifi won't turn on. Seven.

     

    I really thought replacing the logic board would help, but it doesn't. WiFi is just a disaster that Apple can't fix for some of us

     

    Paul

  • zachstronaut Level 1 (0 points)

    I have a late-2008 unibody MacBook. (It was purchased as a refirb, and I have not had any problems until this.)

     

    After my upgrade to 10.7.4 my wifi is off when I reboot my machine, and wifi will not turn on.

     

    If I reboot with a PRAM reset, and/or if I delete the network related files from /Library/Preferences/SystemConfiguration, and/or if I apply jibguy's fix... my wifi works on that reboot.  However, any subsequent normal reboot and my wifi goes back to being off and I can't turn it on.

     

    I essentially get the same result from jibguy's fix without the SMC reset... I can just delete wifi, and then reboot, and then add wifi... and then I can turn it on successfully.  But I have to do this with every reboot.

     

    Super lame.

  • Gorazd Level 1 (10 points)

    Worked for me too!

    (15-inch, Late 2008)

  • Scott Handley1 Level 1 (0 points)

    Updating to Mountain Lion seems to have fixed the problem.

  • Kevin.R Level 1 (0 points)

    I hope they find a fix for this becasue I can't work without the internet being a Graphic/Web designer. Having the same exact problem.

  • Scott Handley1 Level 1 (0 points)

    I spoke too soon. I thought Mountain Lion fixed it.

    It didn't.

    After 5 restarts I can't turn on the wireless again.

  • deadshift Level 1 (15 points)

    late 2008 MBP.  I think 10.7.5 may have fixed my WiFi issue.  Hasn't been a problem since 10.7.5, and 10.8 also has gone through 10 or so reboots and wireless networking has behaved perfectly for me.  No guarantees, as this problem has some intermittent tendencies, but statistically I'm doing much better now than I was on 10.7.4

  • kilauea88 Level 1 (0 points)

    Dio Adi came up with a simple solution that worked perfectly for me, Late 2008 15" MacBook Pro.  :-)

     

    http://dioisme.blogspot.com/2012/05/solving-wifi-wont-turn-on-lion-osx.html

     

    Dio's solution is to go into the network preferences, disable the WiFi Service, create a new WiFi Service with a different name, and reboot.

     

    --AJ