Skip navigation

Wifi won't turn on since upgrade to Lion

74733 Views 278 Replies Latest reply: Dec 2, 2012 11:44 PM by 2yb RSS Branched to a new discussion.
  • deadshift Calculating status...
    Currently Being Moderated
    Aug 16, 2012 5:54 AM (in response to deadshift)

    10.8 still has problems. My solution is still to just do a clean and complete shutdown, and the next reboot may (usually) fix it.  I only have the symptoms change upon boot/reboot.  I never have problems from sleep. 

     

    When 10.8 has this problem, it shows the airport as being off, but at least present.  When I try to turn it on, it never finds any access points.

     

    I am also having trouble burning DVD's now. Perhaps my hardware is slowly dying.  I planned on getting a full 5 years from this macbook pro, I don't know if it's going to make it.  :-(

  • DannyB007 Calculating status...
    Currently Being Moderated
    Aug 17, 2012 6:16 AM (in response to deadshift)

    I have a late 2008 MacBook which I recently updated to OS X ML.  Following the first reboot wifi appeared to be active and searching for networks but could not find my router (or any other).  Strangely, i could not turn wifi off either.  I tried resetting the SMC but this had no effect.

     

    I used the 'Contact Mac Support' service (http://www.apple.com/uk/support/contact/) and, although my Mac is out of warranty, logged it as an exceptional request as it was the newly purchased ML causing the issue.  After some trial and error, it came down to a reinstallation of ML which solved the problem:

     

    Shut down your mac.

    Turn on, holding down Cmd R as it loads

    You should then see the option to re-install ML.

     

    All working fine for me now.

  • jamiesonfromportland Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 24, 2012 8:30 PM (in response to kevinrobers)

    {please read entire post before beginning}


    You (DannyB007) will most likely recur that problem after a few days/weeks as I have reinstalled ML 3 times on my device. If not, show your grace to the Apple Gods as this issue has been a nerve center nightmare to my brain.

     

    I can, however, get to the internet if I log in under the Recovery partititon, but not under the main HD. Hmmm...

    After umpteen hours doing hardware stress tests to no avail, I delineated that it is most-likely NOT a hardware issue but rather a program glitch that is the culprit. But, I would check the hardware just in case.  You goto: http://support.apple.com/kb/HT1509 to do that.

     

    (late 2008 and before only - INTEL MBP only) The ONLY permanent solution I found was to do a complete HD wipe and reinstallation of the original operating system from the Original Disks that came with the computer. Then update to Lion/ML from the Apple Store. DO NOT add any applications (ie. Flash Player, Aperture, Logic, etc.) other than the original Apps that came with the computer (iLife) until you have completed the upgrade to Lion/ML. Some may say this is overkill, but for me it wasn't. Fresh and clean and Im going on 1.5 months with no problems...fingers crossed.

     

    Make sure you back up your hard drive to an external device before doing this.

    1. Back Up your data!

    2. boot from the original installer disc and use Disk Utility to erase the drive, writing zeros once . Here is the link to the user manual: http://manuals.info.apple.com/en_US/MacBook_Pro_15inch_Late2008.pdf

    3. re-install the original OS from the Original disks, then upgrade to Lion/ML from the App Store.

    4. Run Software update just to be sure youre completely up to date.

    5. NOW, install all of your Apps from the App store/Disks/Downloads.

     

    IF YOU DO NOT HAVE THE ORIGINAL DISKS: do the recovery as indicated in previous posts by holding down "Opt - R", going to disk utility and doing a clean install of Lion or ML. However, this method has proven to be a temporary fix and I usually have to change my startup preferences to prolong the temp fix whiuch I will not go into here. Do Not wipe the whole HD unless you have the original disks.

    good luck

  • Neo911 Calculating status...

    Add me to the list.  I just did a clean install of ML on my MB (original unibody).  I did this by installing SL from the original disc and then ML.  All was well and I started installing all other software (Office, iWork), I updated to 10.8.1 yesterday and after a re-boot still all seemed well.  I left it alone overnight and today I added a few other apps (Skype and iLife 09) the latter of which needed a re-boot.  Once I re-booted I was no longer able to turn on wifi. 

     

    System preferences shows wifi status as OFF and pressing the "Turn Wi-Fi on" button next to the status does nothing.

     

    I have tried most of the solutions presented on this thread:

    1. SMC reset

    2. turning on wifi via terminal

    3. deleting the library/preferences/systemConfiguration folder (this only works for the following re-boot - subsequent re-boots render this solution useless)

    4. Deleting WiFi from the network list on the left in System Preferences, re-booting and then adding Wi-Fi again also seems to be a 1 re-boot pony.

    5. I have even reverted back to 10.8 by simply installing ML from my USB over top of 10.8.1.  Although in error I did not try re-booting another time but went ahead and updated the system back to 10.8.1 which rendered the wifi dead again.  So I'm not sure if it was the update to 10.8.1 or if another re-boot would have killed wifi.  In an effort to eliminate one or the other I am again re-installing 10.8 (ML) over 10.8.1 and will re-boot a few times to see if wifi stays on.

     

    Will post back if that does the trick.

     

    Have to agree with jamiesonfromportlandthat this does not appear to be a hardware issue as I have another drive (OWC SSD) running 10.8 that I simply swaped in to the same MB and everything worked fine right away.  No wifi problems!  In fact I have been running the MB on the SSD for over a year and on Lion and ML without any problems.  I am reluctant to update that drive to 10.8.1 just to see if 10.8.1 is the culprit although the SSD is destined to go into my Mac Mini shortly anyway, so I'll see.

     

    The original disc that came with the MB is 10.5 but I think I can only get to ML or Lion from SL if I remember correctly so I don't see the point of going all the way back to 10.5 and working my way up.

  • jamiesonfromportland Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 27, 2012 8:37 PM (in response to Neo911)

    The reason why i stress the need for the original disks is that each of those are specific for that machines hardware and system. I know it sounds redundant but for some reason there is a bug that Apple has yet to figure out and I have been working with several AppleCare Techs who have been unable to fix this issue and keep referring me to Bad Logic Board, Faulty Hardware, 3rd Party Software, etc. etc. (NOT THE PROBLEM!) They have given me every exception to saying that this model shouldnt update to ML which Apple most likely will never do. SO, either revert back to SL, or last working config, or try the original disk install after wipe as I explained earlier then upgrade. My system is still going well with ML and wifi after the tedious process. I think that it has something to do with how the system allocates resources and configs for the newer retina display computers... My Logic: I can use my Wifi when I startup into Recovery HD, and click Get Help Online. That is a mode that does not go into the normal user preferences and external displays are flashy and the system is slower. So why wifi here but not with my usual user preferences? That is a clear bug in my opinion and not a hardware problem, or the logic board, as they tried to tell me. Fact is, AppleCare expired on these models and they're (in my opinion) not really concerned about it. But I am concerned and I will keep clammering on this until I can get this obvious glitch fixed.

  • deadshift Calculating status...

    The unibody wasn't the worst laptop I've owned, but it wasn't the best. I hope my next MBP is more reliable. Eventually we'll see ECC RAM come to all computers, even laptops, and that's when I think reliability will improve. Until then, if your wifi fixes involve magic or nomsense, I recommend the old school powerdown, wait 60 seconds, then start. When you run out of patience, get a new laptop, or a USB wireless dongle ... Or a long ethernet cord. 

  • Neo911 Calculating status...
    Currently Being Moderated
    Aug 28, 2012 5:22 PM (in response to Neo911)

    So reverting back to 10.8 did nothing to fix the wifi problem.  I'm still stumped as the OWC SSD I have is running 10.8 and has been working just fine.  Prior to that it was running 10.7 without any problem and when I first got that drive I did not go back and install the original disc's (10.5), the first OS the drive saw was SL so I'm not quite sold just yet on the solution presented by  jamiesonfromportland.   

     

    I have done another clean install from SL to ML and while on 10.8 wifi stopped working again.  Doh!  Re-booting did nothing but an SMC reset managed to do the trick.  I'll leave it at that for the time being. 

  • jamiesonfromportland Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 28, 2012 6:00 PM (in response to Neo911)

    Applecare just confirmed that this is an ongoing problem with 10.8 and this particular model mac book pro late 2008. But they still offer no solution other than reverting back to 10.7. But did give me an app store credit  of 29 dollars and 99 cents and still allowed me to keep my registered copy of Mountain lion.  So if you got the time  to try to hammer it out with then refer them to this discussion. I would insist that they make an exception to their all sales are final policy.      1 last posting on this from Maine and I'm going to retire my input. Neo 911 is correct about not being sold on the original discs install. It will not matter how many times you reinstall wipe the hard drive and so forth, so I apologize for any 1 like myself does that have spent all these hours trying to do trial and error. The last final technician I spoke with made a very interesting inquiry of the percentage of my battery life while plugged in with an appropriate wall adaptor. if I boot into 10.8 while my computer read anything less than 100 percent I don't have wifi but while plugged into the wall my wifi work my wifi works perfectly. I  I always press the little button on the side to make sure that all the green lights are lit and that my computer, then I boot my computer up beginning Safari. That I un plug the wall unit and can use it first long is the battery life making sur until my batteries recharge to 100 percent. 

  • 2yb Calculating status...
    Currently Being Moderated
    Dec 2, 2012 11:44 PM (in response to kevinrobers)

    I had the same issue where my wi-fi wouldn't turn on, but was detected after upgrading to Lion and ML.

    I have posed a solution at:

    https://discussions.apple.com/thread/4234029?start=0&tstart=0

1 ... 15 16 17 18 19 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.