1 2 Previous Next 28 Replies Latest reply: Apr 4, 2012 9:12 AM by tvr0717
Randall White Level 1 Level 1 (0 points)

I've looked around and it appears that this issue has been coming up in a few different iterations, I've tried some of the Apple Help hardwiring and nothing is working yet.

 

It's this simple. My iPhone and iPods synced up fine with Snow Leopard las week but do not open iTunes or appear when iTunes 10.4 are opened.

 

I've tried reinstalling iTunes and the old procedures under http://support.apple.com/kb/TS3540

 

Nothing working yet.


iMac, Mac OS X (10.6.8), Model 7,1 2GHz / 2G
  • 1. Re: iTunes won't sync after Lion 10.7 install
    DennieM Level 1 Level 1 (5 points)

    I have the same problem with my iPhone4.  I was able to sync my iPad though.

  • 2. Re: iTunes won't sync after Lion 10.7 install
    coocooforcocoapuffs Level 3 Level 3 (845 points)

    interesting, i have a sync problem with an unmentionable app on one unmentionable-state of iPhone...won't sync wirelessly anymore, but with wired, all is well here. But r u syncing podcasts by any chance...as i have seen where a corrupt podcast, or an error during syncing one causes a -50 error. Just deselecting / syncing / reselecting fixes that. Cheers!

  • 3. Re: iTunes won't sync after Lion 10.7 install
    DennieM Level 1 Level 1 (5 points)

    No podcasts.  When I connect my iPhone so I can sync it with iTunes, no device list with appear.

  • 4. Re: iTunes won't sync after Lion 10.7 install
    coocooforcocoapuffs Level 3 Level 3 (845 points)

    I see, that does not sound good. Cable? Another mac or pc? We all need this iCloud thingee badly...how many years have we all suffered through crazy sync problems?

  • 5. Re: iTunes won't sync after Lion 10.7 install
    DennieM Level 1 Level 1 (5 points)

    Cable works okay because I used it to sync my iPad2.  I've had this problem before and was able to fix it using the procedures from here (http://support.apple.com/kb/TS3540).  I've tried it but it doesn't seem to work on Lion.

  • 6. Re: iTunes won't sync after Lion 10.7 install
    Teahermit Level 1 Level 1 (0 points)

    Same problem here, but with iPad or iPhone. Plug into MacBook, device beeps, battery starts charging, but iTunes never seems to recognize it. Nothing appears in device list, no sync - can't even manually force it because iTunes doesn't see the device...

  • 7. Re: iTunes won't sync after Lion 10.7 install
    peter_lindeman Level 1 Level 1 (5 points)

    Same problem here. Tried two different iPhones and different cables. If anybody has a solution I'd like to hear it.

     

    Thanks

  • 8. Re: iTunes won't sync after Lion 10.7 install
    Randall White Level 1 Level 1 (0 points)

    I was a bit lazy last night and overlooked what may have been a relevant tidbit:

     

    In applying the procedures of the Apple recommended fix — http://support.apple.com/kb/TS3540 —  I did not find the file "com.apple.usbmuxd.plist~orig," this might be part of the problem and may help in debugging. I just went on with the rest of the procedures hoping for the best.

     

    Once again, it should be pointed out that the Support fix was from a couple weeks ago and most definitely pre-Lion.

     

    My apologies for the oversight…

  • 9. Re: iTunes won't sync after Lion 10.7 install
    Randall White Level 1 Level 1 (0 points)

    Here's a small update to the issue:

     

    After an espresso I pulled out my MacBook Pro [ Intel T9800 2.93GHz / 8G Model 5,2 ], hooked that up to the network and attached the iPhone.

     

    It started to work properly, meaning that it started up iTunes (and Nikon Transfer) and mounted under "Devices" in the iTunes window for about 30 seconds. Then it disappeared!

     

    In trying to sniff out unresolved issues I went looking for that launch Daemon "com.apple.usbmuxd.plist~orig" …

     

    Whadyaknow? It sill isn't there!

     

    After a few minutes I tried unplugging the iPhone, quitting iTunes and reattaching iPhone to USB cable. Now it does not work as my older iMac. Nikon Transfer doesn't automatically start up as well. The iPhone does not show up in "Devices" when I start up iTunes manually…

     

    Looks like I won't be able to upload the latest King Unique (#20) mix to my iPod for cruising…

  • 10. Re: iTunes won't sync after Lion 10.7 install
    peter_lindeman Level 1 Level 1 (5 points)

    I have it solved on my MacBook Pro now. In the support procedure I did the following

     

    f the issue remains, try these steps:

    1. Disconnect the device and quit iTunes.
    2. In the Finder, locate iTunes in the Applications folder and drag it to the Trash. (This will not remove any of your iTunes media or your iTunes library.)
    3. Choose Go > Go to Folder. Enter the following location into the text field that appears:
      /System/Library/Extensions
    4. Click Go.
    5. Locate the file "AppleMobileDevice.kext" and drag it to the Trash.

    After this I rebooted the Mac and now reinstalled iTunes (without deleting anything of iTunes)

     

    After installation I started iTunes and connected my iPod and it was recognized, now I connected my iPhone as well and was also recognized.

     

    When it was not working I als found the following error in my system log

     

           0        0 AppleUSBCDC: start - initDevice failed

     

    Hope this helps everyone in this thread as well!

     

    Peter

  • 11. Re: iTunes won't sync after Lion 10.7 install
    Randall White Level 1 Level 1 (0 points)

    Are you sure Peter?

     

    I tried moving and dragging the iTunes app to the trash and got error message:

     

    "“iTunes” can’t be modified or deleted because it’s required by Mac OS X"

     

    I did try the rest of these procedures and reinstalled iTunes over the old installation like I noted in the original message.

     

    I'm still stuck

  • 12. Re: iTunes won't sync after Lion 10.7 install
    peter_lindeman Level 1 Level 1 (5 points)

    Yes I'm sure. I did not uninstall it, I just deleted that one file, rebooted the mac, redownloaded iTunes at Apple and installed it.

     

    Do you also get that USB error in your system log (in a terminal type 'sudo dmesg')

     

    Peter

  • 13. Re: iTunes won't sync after Lion 10.7 install
    Randall White Level 1 Level 1 (0 points)

    Peter,

     

    Let me be clear. When you say "I just deleted that one file…" it's a bit grey as to what you're referring to. When I try your first two steps…

     

    1. Disconnect the device and quit iTunes.
    2. In the Finder, locate iTunes in the Applications folder and drag it to the Trash. (This will not remove any of your iTunes media or your iTunes library.)

     

    … I cannot drag iTunes to the trash without getting "iTunes can’t be modified or deleted because it’s required by Mac OS X"

     

    -------------

     

    Now, I cant find any reference to "AppleUSBCDC"

     

    But I did get:

     

    IOSurface: buffer allocation size is zero

    IOSurface: buffer allocation size is zero

    Kext com.apple.driver.AppleMobileDevice not found for unload request.

    Kext com.apple.driver.AppleUSBEthernetHost not found for unload request.

    Resetting IOCatalogue.

     

    and:

     

    en1: Supported channels 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

    USBF:          44638. 70          [0xffffff80130b5000] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 4 of Hub at 0x6000000)

    USBF:          44641. 88          [0xffffff80130b5000] The IOUSBFamily was not able to enumerate a device.

    2.3.11 m168efe17

     

    Both of those seem fairly ominous…

  • 14. Re: iTunes won't sync after Lion 10.7 install
    Randall White Level 1 Level 1 (0 points)

    Warning OFF TOPIC

     

    PS: If it isn't one thing it's another…

     

    In using Terminal I found another little "bug." I have a startup command for Terminal (repeat, this is about Terminal, not iTunes) …

     

    T_bug.jpg

     

    … so that I can shorten the prompt to ""#" instead of all of that other relevant nonsense. That startup command is not working for Terminal. I know this is off topic, per se, but I'm just seying…

1 2 Previous Next