Previous 1 2 3 Next 33 Replies Latest reply: May 2, 2012 1:48 PM by Piterek
ivandsfromamsterdam Level 1 Level 1 (0 points)

I would like to know why the process mtmd is using 180% of the cpu after i installed Lion

And also the mdworker is running at 100%

 

This cant be right. can it?


MacBook Pro, Mac OS X (10.7)
  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    I also already indexed spotlight.

    And this is not my first boot.

     

    stats:

    macbook pro

    2.8 Ghz Intel Core 2 Duo

    4 GB memory

     

    Message was edited by: ivandsfromamsterdam

  • SRINATHSADDA Level 1 Level 1 (120 points)

    What's you h/w config?

  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    I have a macbook pro

    with a 2.8 GHz Intel Core 2 Duo

    and 4 Gb of ram

  • SRINATHSADDA Level 1 Level 1 (120 points)

    Did you enable Time Machine backup? The MTMD process relates to Spotlight indexing service. I think it's tied with Time Machine.

     

    Go to:

    • System Preferences
    • Time Machine
    • Options
        • Deselect Create Local Snapshots
    • Restart Mac
  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    Yes I have enabled Time Machine.

    But I don't have a option "Deselect Create Local Snapshots".

     

    The only options i have are:

    • Exclude items from the backup.
    • Back up while on battery power.
    • Notify after old backups are deleted.
    • Lock documents 2 weeks after last edit.

     

    And now that we are on the subject of Time Machine.

    I cant enter Time Machine anymore.

    Nothing happens if i press the Time Machine dock icon.

  • SRINATHSADDA Level 1 Level 1 (120 points)

    Try This: Disconnect all users from the time capsule To manually disconnect all users from the Time Capsule, open the Airport Utility and choose the Time Capsule device on the list to the left. Then click the "Manual Setup" button and select "Disks" in the resulting window. Then click the "Disconnect All Users..." button, quit the utility, and reattempt the backup.

     

    Also Do This:

    1. go to system preferences

    2. go to time machine

    3. click change disk

    4. select none

    5. turn time machine off

    6. click change disk again

    7. select your external HD

    8. turn it back on

  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    So I tried your solution, but its not working for me.

    For some reason when I turn off time machine.

    And turned it back on. It started to backup 3,5 Gb.

    I'm not sure what thats all about.

    And of course the macbook will ge really hot again.

     

     

    Also the backups take WAY... WAY longer then before.

    It's like Time Machine is stuck on 'preparing for backup'.

    And stuck again at the end.

     

    The only way for me to get some work done right now,

    Is to turn Time Machine off.

     

    Maybe not the most ideal solution.

    But it's the only way.

     

     

    Concussion:

    Apple's beta testing suucks.

    -1 for apple

  • SRINATHSADDA Level 1 Level 1 (120 points)

    If you have external backup other than Time Capsule, you can erase Time Capsule disk to take backup from scratch, However I won't recommend unless you have proper backups on elsewhere!

     

    If possible, try to connect Time Capsule directly to your MacBook using Ethernet cable and do the backup again.

  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    Ye i'm using a 500 euro Time Capsule.

    And its been making backups for the last 2 years.

    So I can't really delete all of the backups because i might need them

    I also don't even know if resetting my time capsule will fix the problems.

    So thats not a option.

     

    And lets say it won't work.

    This means the first backup that I will need to do, will take WAY... to long.

    Doing a backup of 5mb will take like a hour right now.

    And I have 400Gb in use on my macbook.

    Even with a ethernet cable this would take a gazillion years.

     

    There most be a other way.

    Because this way apple is defeating the whole purpose of a Time Capsule.

  • SRINATHSADDA Level 1 Level 1 (120 points)

    Try to Close Finder by using Force Quit.

    Disable All Startup Items or Restart Mac in Safe Mode. Start the Time Machine Again to take backups.

  • Pondini Level 8 Level 8 (38,720 points)

    mtmd is Mobile Time Machine Daemon.  It does have to do with Local Snapshots on portable Macs.

     

    See #30 in  Time Machine - Frequently Asked Questions.

  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    I have looked at your link.

    And it says I can disable local snapshots by using the terminal.

     

    sudo tmutil disablelocal 

     

    But after executing the code, time machine still says it will make local snapshots.

    And if I start time machine it will spawn the mtmd process all over again.

    FAIL...

    So that did not work.

     

    Time Machine is just one big mess right now.

  • Pondini Level 8 Level 8 (38,720 points)

    Did it prompt you for your password, and did you type it and press Return?

     

    If you're not sure, do it again and post a screenshot.

  • ivandsfromamsterdam Level 1 Level 1 (0 points)

    LOL...

    I'm a web/server developer and I need to type commands in the terminal daily.

    I know what I'm doing.

     

    So ye. of course it prompt me for my password.

    And I hit return

     

     

    But I now understand what the problem was.

    As soon as you turn Time Machine back on.

    It will enable local snapshots again.

     

    1. So you need to have Time Machine already on.

    2. Then go into the terminal.

     

    I'll try and get back to you.

    To let you know if my CPU is still going up.

     

    I can already tell you that the speed of the backups are still REALLY really slow.

    When the backup is done.

    Its almost time for the next one.

Previous 1 2 3 Next