Previous 1 2 Next 22 Replies Latest reply: Aug 9, 2012 3:31 PM by cnicholas Go to original post
  • tdawgmd Level 1 Level 1 (5 points)

    BigC--Fixed my problem!  Thanks!

  • Simon Turnill Level 1 Level 1 (15 points)

    The workaround doesn't work for public shared folders. Normally clicking on a server will automatically bring up the publicly available folders - however you still get "connection failed". Clicking "Connect as..." and authenticating works, of course.

     

    Looks like a bug.

  • CAM2202 Level 1 Level 1 (0 points)

    Worked for me too!

  • Vincog Level 1 Level 1 (0 points)

    can some one explain what is home folder??? idont understand......

     

    my mbp 2011 still cant make folder sharing....

     

    can some one help me??

  • benk7 Level 1 Level 1 (0 points)

    Hey everyone,

     

    I'm having simialr issues in 10.7.2 (I've had this problem since 10.6.8 ish) but none of the listed fixes seem to help (unless I'm missing something).

     

    From finder, my Macbook Pro won't connect:

    • to my iMac (via AFP or SMB) which has file sharing on
    • to a media box
    • to a PC file server
    • to anything (as far as I can tell)

     

    It will:

    • Screen Share to/from iMac
    • File Share to iMac
    • Connect to all via FTP
    • From another loggin on the same Macbook Pro it will connect to anything fine :\

     

     

    When I try to connect to anything, within one second it says 'Connection Failed'

    Screen Shot 2011-11-09 at 10.28.37 PM.png


    When I click 'Connect As...' without the usual login/password prompt, it says:
    There was a problem connecting to the server “Benk’s iMac”.
    The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

    Screen Shot 2011-11-09 at 10.34.00 PM.png

     

    What I have tried (none of these worked even after restarting):

    • (On both computers) Turning off AFP and turning on SMB (then both on).
    • On Macbook Pro's system prefs I deleted all shared folders
    • backed up then deleted 'com.apple.AppleFileServer.plist'
    • Downloaded BBedit then opened 'com.apple.AppleFileServer.plist' it already had MaxGuests and MaxConnections set to 10.
    • Replaced 'com.apple.AppleFileServer.plist' with the same file from my other login.

     

    Does anyone have any other ideas?

     

    thanks

  • Tomb Stone Level 1 Level 1 (125 points)

    I had problems with this a few months ago so I took time off to not think about it. Now, I've returned to this and I must have had magic under my fingertips.

     

    For my Lion to Windows XP Pro file sharing, it looks like I found a fix on my end.

     

    1. First, I went into Sharing > File Sharing

    I added my Public folder since I must have removed it some other day.

     

    2. Next, I went into Network and removed my existing Wifi connection and created a new one.

    Then I went into Advanced, TCP/IP > set Using DHCP > Renew DNS Lease and then added my WINS  Workgroup name.

     

    3. I went to Go>Connect to Server>entered my PC's local IP address as smb://###.###.#.###/ and BINGO! I have a connection. It connected to my PC as a Guest even though my Guest login is turned off on my PC.

     

    It didn't ask me for a login info like it used to under Snow Leopard.

    Now, I'll wait and see if my connection disconnects. So far, it's been 15 minutes and still have a connection.

     

    I hope this helps someone else.

  • cnicholas Level 1 Level 1 (0 points)

    Macbook Air (Lion) connection to MacMini (Snow Leopard) used to work over Aircard? Wi-Fi.  After lastest Lion

    upgrade on Macbook Air this connection fails.  Solved it by TURNING OFF airport card and connecting with USB Lan adapter.  What gives?  Is Apple not testing these upgrades?  I saw an old post here that hinted that Airport software might cause this but the post was 2011. 

  • cnicholas Level 1 Level 1 (0 points)

    Another solution to Macbook Air connection failure.  I just stopped by a local Apple reseller (MacExperts) and the lady told me to reset nvram (pram) on the MBA.   I did that and now connections over airport card wifi work as expected.  I am curious how I missed that little piece of "update information".  I haven't had to "reset pram" since my days as a Solaris sysadmin.

Previous 1 2 Next