Previous 1 2 3 Next 41 Replies Latest reply: Apr 5, 2013 11:36 AM by matthewfromdanvers
Yansolo Level 1 Level 1 (0 points)

Hi all,


I've upgraded my Mac OSX 10.6 server to 10.7 server 2 days ago.


My web sites databases are still under MySQL server cause it's still running after the upgrade.


I manage to migrate the databases to PostgreSQL, so i've enabled the wiki from the to launch the PostgreSQL server.


I can see that it's now running through a ps -ef | grep sql and that it's listening on the unix domain socket 5432 with netstat -an | grep SQL in a terminal shell.


The problem is that I'am unable to connect to it.


I tried psql -U postgres, and installed the Navcat for postgreSQL Lite, but they failed to connec to the database server twith the same error :

psql: could not connect to server : Permission Denied

Is the server running locally and accepting connections on Unix domain socket "/var/pgsql_socket/.s.PGSQL.5432"?


It seems that there is a permission problem on the Unix Domain Socket /var/pgsql_socket/.s.PGSQL.5432.

It has a 0770 permission on it, but i don't know if it's relly the problem.


I've compared with MySQL server, which I am able to manage through Navcat for MySQL Lite without any problem, and the socket permission are 0777 on /var/mysql/mysql.sock.


Does somebody able to connect to the embedded PostgreSQL server ?


Or am I doing something wrong ?



Previous 1 2 3 Next