Previous 1 2 3 Next 33 Replies Latest reply: Oct 24, 2012 12:10 AM by MelindaCusa
Andrea D. Level 1 Level 1 (0 points)

This is a screen shot of what I see when I open the privacy tab in safari preferences. Any reasons for this? Help!!!

 

 

Screen shot 2011-07-22 at 3.02.57 PM.png

iMac, Mac OS X (10.6.7)
  • Bluspacecow Level 1 Level 1 (40 points)

    Try disabling Extensions.

  • Andrea D. Level 1 Level 1 (0 points)

    Tried, no luck! Hany other suggestions? Before I was getting a message from shockwave player when I went on the privacy tab about if I wanted to watch a movie i had to start safari in 32bit.

    I uninstalled shockwave but it didn't change.

  • Dr. BobDez Level 1 Level 1 (0 points)

    Same problem.  Reinstalled 5.1 and still get the same results as Andrea.  H-E-L-P

  • Bluspacecow Level 1 Level 1 (40 points)

    As I understand it Lion Recovery is also meant to have Safari avaliable.

     

    This loads off the mounted disc image the recovery mode uses to go into Lion Recovery mode so should be untocuhed by corruption and unfettered due to bad preference files.

     

    Try loading up into Lion Recovery then going into Safari and confirming if the privacy tab appears there as well.

     

    http://support.apple.com/kb/HT4718

  • BruceG Level 1 Level 1 (0 points)

    Just spent an hour at an Apple Store with 2 Genius' and was not able to resolve the issue.  This issue exists on both my Macs.  One is running Lion and the other Snow Leopard.  We checked other systems in store and none of them had problems.  I suspect that this problem came as a result of an OSX / Safari update at some point because I haven't always had this problem.  Safari Preference Pane isn't something that I (and I suspect many) people get into very frequently, so there's probably others with this problem (they just don't know it yet).

     

    I did find that if you're using Lion which will re-open where you left off once you quit, that the following "work around" seems to work consistently.  Open the preference pane that's blank (i.e. Privacy or Extensions).  Next, quit Safari without closing the Preference Pane.  Relaunch Safari and the Preference Pane appears displaying correct content.  The strange thing, at least on my Lion system, is that the Blank Preference Pane flips between Privacy and Extensions.  But, I'm able to correct the Preference Pane I need by going through this procedure.  Again, this does not work for Snow Leopard because it won't re-open where you left off.

     

    I've tried reinstalling Safari and nothing changes.  My (and the Genius Bar's) opinion is that a "Fresh Install" is all that will probably fix this.  Not an option for me at this point, so I'll just get along for now.

     

    Wishing all with this issue the Best and I hope someone eventually comes up with something other than a "Fresh Install Option".

  • Dr. BobDez Level 1 Level 1 (0 points)

    If this is Apple's latest "leading edge" technology I am not sure I want to" Lionize."  I called their no-help line and was told this problem does not exist but, for a fee, they would fix it.  Very frustrating.  Back in the day you would be alerted to a fix or upgrade, you could read what it was and decide to install if you chose to.  Now you get a message that a download is ready to install, nothing about what it is, and a choice to do it or not.  I am getting weary of Apple having more and more control over my machine — ITune Store will be the only way I can get a program installed.  Now on top of that, they can put whatever in space and make no attempt to make sure it works or to provide a fix.  We are compelled to ask each other — the blind leading the blind.  I have been on a Mac since the first one, but their chutzpah is starting to wear on me.

  • Andrea D. Level 1 Level 1 (0 points)

    This is getting out of control. This morning when I reopened safari my privacy tab worked and my extensions tab is now blank! What's going on?

  • Bluspacecow Level 1 Level 1 (40 points)

    Let's try resetting the permissions on the Safari app itself.

     

    Select Safari.app in the Applications folder right click it and go "Show Package Contents"

     

    Select the Contents folder and go Command - I (or Right Click -> Get Info or File ->Get Info)

     

    On the bottom right hand corner is a small golden lock. Click and put in an Admin username and password. It will unlock to denote changes can be made.

     

    Next in the section on the bottom "Sharing & Permissions" make sure all the pop up menus under the Privilege are all set to "Read & Write"

     

    Next go to the control on the bottom left hand side (3rd from the Left). It's got a little icon of a cogwheel. Press it to make a little pop up come up and select "Apply to enclosed items". This will apply the permissions to the files inside.

     

    Just close the Get Info window when done.

     

    Also repeat for the Resources folder in the Contents folder.

  • Bluspacecow Level 1 Level 1 (40 points)

    Also while your in the Safari.app/Contents/Resources folder check you have all the resources there and none of them are of a zero k file length.

  • Andrea D. Level 1 Level 1 (0 points)

    I tried and no luck, then I found another post where they said to try to delet com.apple.Safari.plist and after I did it now the extension tab is back but the privacy tab is blank again. Who knows?

  • Roger Fraumann Level 1 Level 1 (0 points)

    Running Safari Version 5.1 (6534.50) on MacBook Pro Intel Core 2 Duo 4GB with Mac OS-X Version 10.6.8.

     

    Symptom is Privacy Tab is blank.

     

    I have tried "Reset Safari", cleared the User/Library/Preferences/Safari, reinstalled a fresh copy of Safari, and changed permissions to RWX for everyone (which I am really uncomfortable with)...

     

    No change, Privacy tab remains blank.

     

    Other suggestions?

  • Roger Fraumann Level 1 Level 1 (0 points)

    Running Safari Version 5.1 (6534.50) on MacBook Pro Intel Core 2 Duo 4GB with Mac OS-X Version 10.6.8.

     

    Symptom is Privacy Tab is blank.

     

    I have tried "Reset Safari", cleared the User/Library/Preferences/Safari, reinstalled a fresh copy of Safari, and changed permissions to RWX for everyone (which I am really uncomfortable with)...

     

    No change, Privacy tab remains blank.

     

    Other suggestions?

  • Dr. BobDez Level 1 Level 1 (0 points)

    Well . . .I finally found one workaround.  Select the extensions window in the preferences tab before closing it.  When you reopen preferences this window will be blank, but if you go to the privacy window it will show the contents.  (of course now the extensions window will be blank so to restore it do just the opposite).  After finally getting to this point, I was really disappointed that I can no longer view a cookies list and be able to "cherry pick" it.  Who designed this thing?  Microsoft?

  • Drakhul Level 1 Level 1 (0 points)

    That's friggin funny...

     

    Anyway, this workaround worked for me... My issue was the extensions tab (Still running SL here at work) was blank, and I could not install any extensions.  I went to the privacy tab and quit Safari, then relaunched and went to the extensions tab.  I was then able to uninstall all the extentions I had installed (most of which I never used anyway) and then I was able to reinstall the 1Passowrd extension (the only one I ever did use...)

     

    Thanks Dr. Bob!

     

     

Previous 1 2 3 Next