Previous 1 2 3 4 Next 47 Replies Latest reply: Aug 21, 2015 12:14 PM by momentum_man
zyps Level 1 (0 points)

For some reason, since I updated my brand new 13 inch MBP to Lion, Safari runs slow as a dog. All my other internet based applications including Chrome run at normal speed. I also verifed this by pinging Google.com on this Mac and on a different one.

 

I tried clearing the cache and resetting Safari. I also do not have any 3rd party antivirus/firewalls installed. Is anyone else experiencing this?

 

Thanks.

 

 

SOLUTION: Hopefully this helps someone else out.

 

Close Safari, then open Terminal. Type:

 

chflags nohidden ~/Library/

 

You will then be able to see ~/Library in the Finder. Goto ~/Library/Caches/com.apple.safari/. Delete the Cache.db file. Restart Safari and you should be all set. For some reason the "Reset Safari" and "Empty Cache..." don't seem to be working...


MacBook Pro, Mac OS X (10.7)
  • MerchantMilan Level 1 (0 points)

    Worked like a charm!  Thanks!

  • Antinomous Level 1 (0 points)

    Man that helped! You are the best!

  • budgetzero Level 1 (0 points)

    What is Terminal?

  • Grafit Level 1 (0 points)

    Yep - all working much faster with me after this tip.

    Many thanks - I had been thinking of reverting to Snow Leopard.

     

    Great Advice.

  • Grafit Level 1 (0 points)

    Terminal is an application that you can find in
    APPLICATIONS / UTILITIES

     

    It allows control over many facets of the Apple OS that cannot be done via the icon type interface - it's a bit like a being able to open the bonnet on the car and being able to get to grips with the engine!

  • NightFox Level 1 (30 points)

    You don't actually need to use Terminal - you can access ~/Library by clicking on 'Go' at the top of the screen in Finder and then holding down the Option key, which should make Library visible in the list as long as you hold the key down for.

  • budgetzero Level 1 (0 points)

    That might help if I actually understood the car analogy.  What the **** is a bonnet on a car and grips to the engine?

  • Grafit Level 1 (0 points)

     

  • fins1up Level 1 (0 points)

    Who knew about the Cache.db file for Safari.  Deleted it as suggested above and Safari is back to it's good ole'

    self.  Thanks for sharing the info!

  • MR AV Level 1 (0 points)

    And that is the beauty of Apple Support Communites.

     

    Thanks awfully for this, worked an absolute treat. Safari was running so unbeliebaly slow would have changed to Chrome if it were not for the fact that gestures now are uncompatible with it!

     

    Also, to save from opening terminal, if you go to finder/go and then hold down alt, the library tab appears. Pretty handy and saves one from having to open terminal!

     

    Thanks again! Hopefully Apple take note of this and release an update to solve the problem noumerous people undoubtebly have!

  • Darthmoon Level 1 (0 points)

    I have this problem since the update, firefox is working fine, but can't find ~/Library/Caches/com.apple.safari/ to delete that catche.db

     

    anyone knows why

  • Grafit Level 1 (0 points)

    Easy way is:

    1) In FINDER select GO from the top menu.

    2) While the drop down list is displayed, press teh ALT / OPTION key

    3) You should notice a new item in the drop down menu called LIBRARY

    4) Select LIBRARY

    5) A new window in teh FINDER will open

    6) Scroll down to find the folder called CACHES

    7) Open CACHES

    8) Inside CACHES there should be a folder named COM.APPLE.SAFARI

    9) Open the COM.APPLE.SAFARI folder

    10) You should now be able to see a file called CACHE.DB

    11) This is the file you should delete

    12) Once CACHE.DB file is deleted, reopen SAFARI and it should be a good deal quicker.

  • Darthmoon Level 1 (0 points)

    Thanks for the easy way, to the cache.db,

    deleted it but still loads like a turtle.

    don't know what's wrong with it.

  • MiFiGuy Level 1 (0 points)

    Here's a possible reason why the cache in Safari can't be deleted in the first place.

    There's something wrong with your Disk Permissions. When I noticed I had a slow Safari,

    I ran Disk Utilty --> Verify DIsk Permissions. There was a problem with the /Library file where the cache resides.

     

    Verifying permissions for “Macintosh HD”

    Group differs on “Library”; should be 0; group is 80.

    Permissions differ on “Library”; should be drwxr-xr-x ; they are drwxrwxr-t .

    Permissions differ on “Library/Application Support”; should be drwxr-xr-x ; they are drwxrwxr-x .

     

    Repair the Disk permissions and you should be fine.

Previous 1 2 3 4 Next