Previous 1 2 3 Next 89 Replies Latest reply: Aug 30, 2015 5:29 PM by trudyfromcordova
tinoberlin Level 1 (10 points)

"Remove attachments" in Mail (Lion) is disabled and I cant remove the files from the emails I have sent. it worked fine before I switched to Lion and kept my Mail folder in Libary small. Anybody else having this problem?

MacBook Pro, Mac OS X (10.7)
  • tinoberlin Level 1 (10 points)

    Hm ... I just removed two Word files whereas Pages files and PDFs cannot be removed. Maybe these files are not actually sitting in the mail folder but are linked with the original files as aliases and therefore cannot be removed/it is not necessary to remove them?

  • Jamooche Level 1 (0 points)

    I'm new to the Mac as of Lion and find it very difficult to manage the attachments in Mail.  PDFs are displayed inline in the email message and the only way I can figure out how to save them is to right click on the PDF.  I am having the same problem with photos too.  I can also double click them and they open in Preview. 


    When you click the "Remove Attachments" in the drop down, where do they go?


    It also took me forever to figure out how to add the address book icon to the New Message window! 

  • FabeRox Level 1 (0 points)

    Same problem here as the original poster. Removing attachments for emails in the inbox works fine so far, but attachments from mails in the sent folder cannot be removed. Yet, for somer older sent emails (sent before installing lion) removing attachments works, for all lately sent mails (since lion) remove attachments is grayed out. What's going on here?

  • FabeRox Level 1 (0 points)

    Just tried it out a little bit more: The problem is related only to mails sent from 5.0 in Lion. Mails sent through the mobile me web interface for example behave normally after being synced back to Attachments can be removed from those mails within


    Another thing I noticed: The mails that do have the problem do not show the paper-clip symbol in the list of mails on the left side. The paper-clip should appear next to the addressee's name. The mail preview on the right, however, correctly shows that the mail has an attachment and it can be opnened by clicking. I also created a smart mailbox to show only mails that do have an attachment and are in the sent folder: Only the mails sent before installing lion are listed (attachements can be removed) – all lately sent mails are nout found: Obviously something makes "forget" that there is an attachment when sending mails in Lion, thus graying out the command to remove the attachment from the specific mail.


    Regarding file types of the unremovable attachments there doesn't seem to be a pattern. I have the problem with both word documents and PDF files. The number of attachments neither seems to make a difference.


    Temporary solution: Do not send mails with attachments you want to potentially remove later on from within in Lion at the moment. Instead, use an iOS device or your mail provider's web interface for sending those mails. Apple, please fix it!


    Message was edited by: FabeRox

  • tinoberlin Level 1 (10 points)

    Alright, it seems that indeed the files that are indeed included in the mail file can be deleted whereas the ones that are just link from elsewhere in the mail can only be deleted if the orginal files are trashed.

  • rb-421 Level 1 (0 points)

    My issue is that I am UNABLE to remove the ENTIRE Mail App from IOS Lion.

    It would deny the request! Any suggestions? Thank you in advance!

  • zeichensprecher Level 1 (55 points)

    Thanks for pointing this out!

    I can second that only attachments in mails in the Sent folder are affected and cannot be removed


    Thus there is an easy workaround until the issue is fixed: just move the mail from the Sent folder into another mailbox and then you can remove the attachment.

  • Ernie Stamper Level 8 (37,545 points)

    I have confirmed that the command to Remove Attachments is gray, and not active when in the Sent mailbox -- this whether IMAP or POP.  I am trying to investigate further.



  • Tonden Level 1 (70 points)

    Moving to another folder doesn't work for me. Still no paper-clip symbol, Remove Attachments is gray.



  • FabeRox Level 1 (0 points)

    I can confirm Tonden's experience: I tried moving to another folder as well, but it doesn't make a difference.

  • Ernie Stamper Level 8 (37,545 points)

    Move what to another folder, from where?


    Where are you expecting to see the paper clip, that you are not seeing?



  • FabeRox Level 1 (0 points)

    We are referring to moving an email message (that was sent from within in Lion) from the sent folder it was placed in when sending it to any other folder, for example the trash folder or a created archive folder or even across mail accounts, for example from your mobile me account to a microsoft exchange account. The idea here is that potentially this would enable the command to delete the attachments again. However, remove attachements – at least for me – is still grayed out.


    With regards to the missing paper clip symbol, please refer to my longer post earlier:

    Quote: "The mails that do have the problem do not show the paper-clip symbol in the list of mails on the left side. The paper-clip should appear next to the addressee's name. The mail preview on the right, however, correctly shows that the mail has an attachment and it can be opnened by clicking."




  • zeichensprecher Level 1 (55 points)

    Okay, this is what I do with in Lion (latest public version 10.7.0)

    - I compose a message, attach a file by drag & drop at the end of the mail (e.g. a screenshot.png)

    - I send it with in Lion

    - If I change the view to the sent box and select the just sent E-Mail, the menu item "E-Mail > Remove Attachments"* is greyed out and there is no way to remove the attachment.

    - However, when I move the sent E-Mail from the sent folder to another folder of my IMAP-Account (e.g. INBOX), the menu item becomes available and I can remove the attachment.


    I'm running the latest public Lion and only have IMAP accounts. To me, it was really helpful to learn that only the Sent folder seems to be affected.


    Hope this helps.


    * I have a german menu, so the name might be slightly different.

  • Ernie Stamper Level 8 (37,545 points)

    Thanks for the clarifications.  I am not challenging anything you said, but simply being exacting so I can replicate.  I just tried Copy To using an On My Mac mailbox, and likewise found the Remove Attachment command unavailable.



Previous 1 2 3 Next