Previous 1 2 3 Next 109 Replies Latest reply: Jul 20, 2013 11:26 PM by Alan Levine
KaptainKopter Level 1 (0 points)

I use a Western Digital Studio II as my Time Machine back-up drive on my Macbook Pro. I've always had this device connected via the Firewire 400 port and it has worked flawlessly for the 2 years or so that I've had it.


Just upgraded to Lion. Now, the WD drive doesn't mount. No sign of it.


I know the drive's OK because if I connect via USB, all is well (but of course, it's slow).


I've checked WD's support site in case there's a driver update but there's nothing newer than what I already have.


Research via Google reveals a number of alleged issues with firewire drivers for other devices but I can't help wondering is there's an inherent flaw in the way Lion is handling all firewire devices.


Any thoughts? Anyone?

MacBook Pro, Mac OS X (10.7)
  • AllyUK Level 1 (0 points)

    Yeah... I have the same issue and pretty pee'd off about it.


    Apart from the multitude of faults & OS Blunders & freezes, now i have found that OSX Lion has broke my Firewire.. In fact none of my devices that attached with no issue via Firewire in Snow Leopard work anymore.


    There is definately an inherant flaw with the OS... as USB works ok


    Im beginning to think they should rename this  Mac OSX Turkey instead of Lion

  • aaronw1986 Level 1 (0 points)

    I noticed the same issue as well.

  • davidh977 Level 1 (0 points)

    I too am having issues with my firewire input on my MacBook Pro 15" after installing OS Lion.  I thought it was my external hard drives, but find that my drives work on my other iMac 27" running Snow Lepoard.  Whats wierd is that some times the firewire works, and then other times it stops. I know it is not the drive because when connected via USB, they work fine. 


    The drives worked fine right before I installed Lion.  I called Apple Care, but they have no solution and claim it may be the computer.  I know it's not, but something has to give.  HELP!

  • KaptainKopter Level 1 (0 points)

    You called Apple Care. So I assume you have a machine that's in warranty. Either that, or you paid for this useless piece of information.


    So here's an interesting point...


    I have purchased Lion. But I get NO support for it. NO warranty. I will argue that the age of my machine (or the existence of an Apple Care contract) is irrelevant. I have purchased a product and I want support / warranty for that product - nothing else.


    If I buy a new refrigerator, I get a warranty for that. It's got nothing to do with any support contract I have on the house that I'm going to install it in.


    Why should a piece of software such as Lion be immune from implied fitness for purpose? That's probably a rhetorical question.


    So here's what I've done (only applies in the UK).


    I have written to Apple and have told them that OS X Lion is not "fit for purpose" in the context of the Sale of Goods Act 1979 and have also told them I exercise my Statutory Rights in English Law and have demanded a full refund.


    I strongly recommend that others take the same stance. It may only be for the sake of £21 and a LOT of wasted time but I'm going to stand firm on this and I WILL take legal action if necessary.

  • KaptainKopter Level 1 (0 points)



    Just spoke to someone at Apple. It may be that this "fix" is only appropriate for a MacBook Pro but it did work for me.


    1. Shut down the computer

    2. Remove all device connections

    3. Remove the battery

    4. Press and hold the power button for 10 seconds

    5. Insert battery

    6. Connect devices

    7. Power up


    I was told that this firewire problem may be due to a problem in the System Management Controller (SMC) and that it needs to be reset.


    The sequence above is what the technician told me to do. It is also explained here in a slightly different way

  • smithjw Level 1 (0 points)

    Hey guys. I'm having a similar problem with a Firewire 800 drive caddy for portable HD's used in capturing video. They've just stopped working in Lion. The caddy works fine over USB but obviously I would prefer to use FW800 when transfereing 500GB of data haha. And it did work fine in Snow Leopard.


    Have tried both zapping the PRAM and resetting the SMC to no avail.


    This is happening on a MacBook Pro6,1 & a Mac Pro3,1.

  • doozy Level 1 (10 points)

    Same Firewire issue here with Mac Pro3,1 also.


    I connect my DV Camcorder and it does see the camera but when I run iMovie to capture from camers, it misses load of frames, so it captures a jerky mess.


    Would like a fix before next week as I am filming a wedding this weekend. Looks like I may have to revery to Snow Leopard if I can't get the footage on my Mac.

  • jojoleb Level 1 (5 points)

    I have an Iomega Minimax drive that will no longer work on firewire 400.  If I hook it up via USB it works well (but, of course, has a hobbled transfer rate).  I tried disconnecting all peripherals and shutting down and then restarting with and then without the device attached.  No go.


    I guess this is one of those 'new OS' glitches that will be ironed out with the inevitable patch coming in a few weeks to an iMac near you.  Apple pretty much invented Firewire, so I truly hope that they'll be invested enough to make it work.  I'm glad that the drive will work via USB, but I do miss the higher transfer rates.


    Oddly, I can boot up the iMac in Snow Leopard using my Carbon Copy Cloner partition when the Iomega drive is hooked up via Firewire so it is definitely a Lion-specific problem.


    Other than that, I'm happy with the upgrade.  There's lots to like in Lion and (so far at least) the rest of my software and hardware seems to be behaving after the transition....

  • Tabasca40 Level 1 (0 points)

    I am experiencing the same problem. After Lion upgrade, all my dvices connected to firewire are not recognized. Hope for a solution soon.

  • ramysamir23 Level 1 (0 points)

    Amazingly after installing lion I can't use any of my firewire devices !!!! USB IS FASTER THAN FIREWIRE 800 ONLY IN LION !!!!

  • maxc202 Level 1 (0 points)

    Hey, I have a question too. Go to your Show System Report and under Hardware, click Firewire. Tell me what it says.

  • doozy Level 1 (10 points)

    System Report > Firewire:


    FireWire Bus

         Built-in Hub


    Maximum Speed: Up to 800 Mb/sec

    Connection Speed: Up to 800 MB/sec

  • jojoleb Level 1 (5 points)

    Looks like there are some other loose ends that Apple has to tie up:

    1. Firewire doesn't work

    2. Airport is glitchy: it intermittantly disconnects from the router... You can get it to work by simply turning it on and off manually, but it is a bit of an annoyance.  As memory serves, this happened in Snow Leopard for a while, until they came up with a patch that fixed it...

    3. I tried out photobooth just for kicks and it crashed any time I used the background feature

    4. Oh, and the full screen Safari mode is great and all, but opening a new tab seems to ablate the google search window.... 

    5. After installing the recent update to iPhoto whilst in Lion, all my thumbnails were snuffed.  I still have to fool with it a bit, but my guess is if I reload them it'll all come back nicely


    Things that make you go hmmm.....


    My guess is that this is the price we pay for being early adopters.  In a couple of weeks Apple usually makes good and fixes the problems.


    I may use my CCC partition of Snow Leopard on my external drive for the next couple of weeks while Apple squashes the bugs...

  • William Kucharski Level 6 (14,985 points)

    "FireWire doesn't work" - that would be a surprise since I have two machines running Lion with a LaCie Quadra attached via FW800.


    In fact, my MBP was booted from the FW800 drive as a boot drive for a while as a test before I decided to update the copy of Snow Leopard on the internal drive.

Previous 1 2 3 Next