Previous 1 3 4 5 6 7 8 Next 112 Replies Latest reply: Jul 20, 2013 11:26 PM by Alan Levine Go to original post
  • Giön Level 1 Level 1 (0 points)

    I have a late 2008 macbook and suffered the same problem with the firewire 400 concetion to my iomega 2 tb  after upgrading to os x lion. Reseting the smc over the powerbotton worked fine for my problem, even if I had to try two times. I don't know yet if the solution works just for now or solved it forever. Thank's anyway!

     

    --------

     

    Update: The trick only works as long as the external hard drive is conected. Unplug and the problem revolves.

  • amoppert Level 1 Level 1 (0 points)

    I don't know what a Drobo is, but two of my G-tech external drives had refused to mount on my iMac, but would mount with a USB cable substituted Firewire 800.  iMac runs Lion. Cure was to reset SMC. I have had to reset SMC twice now to keep the drives operating.  I think it is a Lion problem.

  • csteelooper Level 1 Level 1 (10 points)

    @Amoppert: For your specific problem, I can confirm that it is NOT a Lion problem. Why? I also own a G-Technologies drive (the G-Drive 2TB, to be precise) and I run Snow Leopard. I have had the exact same issue you described. In actual fact, the only firewire device my iMac has never had any real issues with was the iOmega UltraMax 1TB hard drive. I now cannot use that one any more as it broke down in quite a definitive way (burnt circuit board).

    I have another iOmega drive (the eGo 500GB Mac Edition) which is daisy chained to my G-Drive. After having reset the SMC (though I only had to do it once) both the G-Drive and the iOmega appear on the Desktop.

     

    A sideline to what I described above is the strange occurence that I encountered three times now: whilst working on my iMac (again, running Snow Leopard), the G-Drive would unmount abruptly, resulting in the usual error displayed when such a thing happens. If I unmount the drive consciously and (thus) safely, the drive spins down after having unmounted. In the cases meant above, it did not. The strange thing is, the G-Drive would unmount - I call this a 'loss of communication' - but the iOmega daisy chained to it would remain mounted and operable. To get all three drives back, I then have to consciously unmount the iOmega so as to turn the G-Drive off completely, then wait a couple of seconds (I usually check System Profiler to see the drives have disappeared from there, because that doesn't seem to happen instantly on my Mac) and then turn the G-Drive back on. Voilà, all drives are back up and running. The last time this occured is (luckily) some time ago now, let's keep it to some 2 months.

     

    Taking what I wrote, I can confirm, again, that it is not a Lion related issue after all. And, to be honest, after the iOmega failed on me, the G-Drive is 'behaving' rather well. So well in fact that I am thinking of getting myself an additional one of those. Whilst waiting for my first G-Drive to be delivered, I resorted to a Western Digital WD My Passport 250GB for data storage, and had to go without a Time Machine Backup for some time (the drive wasn't large enough). But the WD Drive had extreme difficulty to even mount on my desktop using FireWire (800 or 400 didn't matter) and when it did mount, it would become unresponsive and freeze down Finder after writing some 2GB of data to it in one go. Reading data off it never caused any freezes... Anyway, I had to connect that drive through USB to be able to do anything of sorts with it. This complaint is well known for these drives and, again, is not Lion related. So, all in all, the G-Drive still is a more than welcome companion in my home. It runs my TM backups and keeps other data, and has done so greatly. Despite aforementioned hiccups at the start.

     

    Again, I cannot stress enough that I experience these problems running Snow Leopard, not Lion. In fact, this issue is one of the things keeping me off an update to Lion, as I hear so many people having problems related to FireWire. Then again, I think I shall take the jump after 10.7.3 is released, because I think upgrading to Lion will not change my situation regarding FireWire in the slightest. I would have LOVED to see how Leopard (i.e. 10.5) would have handled the G-Drive, but I see little use in doing a downgrade to Leopard just for that little experiment. I feel, however, that Apple may have updated the FireWire HDD Class drivers in Snow Leopard. Seeing as loads of you are experiencing similar issues to mine whilst running Lion, I think they did not do so in Lion (i.e. I think they still use the very same FireWire HDD Class drivers in Lion as they did in Snow Leopard.

    Having taken this conclusion for myself, I think that much of what is described in this thread is not Lion specific after all, but is, in fact, dating back to Snow Leopard. Come to think of it, back when Snow Leopard was released, loads of people were complaining about similar issues. I wonder what Apple has done to Firewire...?

  • amoppert Level 1 Level 1 (0 points)

    Sounds like you are right. But the problem does appear related to the OS, whether it is Lion or Snow Leopard.

     

    My iMac is a summer 2007 (first aluminum 24") and the apple care policy has lapsed.

     

    When I called Apple basically just to ask if they knew what the problem might be, because it appeared to me that it might be something that needed resetting.  Would not even discuss it with me without  paying a $49. fee to talk to one of their experts.  I did finally get some help from my local store.  After I thanked him and told him about how I was treated by Apple, he said that I still had 15 days phone support.

     

    I think that Apple should communicate with customers when the base problem is due to a fault in the operting system.  I upgraded because I assumbed that the product was "fit to purpose" i.e. met the requirements of an operating system.  Out putting via firewire, an Apple developed standard, is a base requirement of the OS.  The treatment really gauls me.

     

    Thanks for the explanation and the opportunity to vent.

  • William Kucharski Level 6 Level 6 (14,890 points)

    amoppert wrote:

     

    I think that Apple should communicate with customers when the base problem is due to a fault in the operting system.  I upgraded because I assumbed that the product was "fit to purpose" i.e. met the requirements of an operating system.  Out putting via firewire, an Apple developed standard, is a base requirement of the OS.  The treatment really gauls me.

     

    Aside from those for whom resetting the SMC has had some effect, the long term fixes have been driver and/or firmware updates provided by manufacturers.

     

    That indicates the actual bug is indeed in firmware for the drives or their drivers; Drobo, WD and others wouldn't provide "fixes" for issues that were actually Mac OS X bugs because they know Apple can, should and likely would fix them, and fixing them in their drivers or firmware would require yet another patch when Apple applied their fixes.

  • Olaf Seegelken Level 1 Level 1 (15 points)

    I recently bought two G-Drive mini 750 in the Apple Store because i wanted a fast externel FW800 drive.

     

    I thought they were broken because i had mounting and other stability and performance problems (tested only FW800). I send them back.

     

    I´m on 10.7.2 on a iMac 24" (summer 2007)

     

     

    With the previous OS versions (10.4/10.5/10.6) i had no problems with an old LaCie 320GB FW800 disk (other than that it was a little bit loud for my taste)

  • amoppert Level 1 Level 1 (0 points)

    Sounds exactly like my experience, same computer, no problem with previous operating systems.

     

    My beef is that Apple wouldn't even discuss it with me as my coverage had run out.  They no doubt know that this is happening as a result of the OS upgrade and that resetting the SMC may provide a short term fix. As the problem is related to the OS or lack of compatibility between the OS and the drivers, not the computer; they should provide some guidance.

  • dysmike Level 1 Level 1 (0 points)

    I'd buy this if I didn't experience identical results on a hitachi g-drive mini (no firmware to update). 

     

    So, here's the quick issue:

     

    Repartitioned in Lion to 2 partitions, one HFS+ one MSDOS (Fat32).

    Formated them in Disk Utility

     

    the HFS+ slice mounts fine on FW800/USB

    The FAT32 slice?  Mounts great on USB, mounts great on FW on another mbp running 10.6.8, mounts fine on linux and windows.  Try to mount it in Lion and I get

     

    diskarbitrationd: unable to probe /dev/diskXsX (status code 0xFFFFFFFC).

     

    I'm not buying the firmware bit.  This smells more like a driver issue.

  • Khadgar Level 1 Level 1 (0 points)

    Nice. After installing that update I haven't had a second's trouble with it. Looks to me as if Apple's changed the way the driver behaves in Lion, so all of these companies needed firmware updates. Hope it continues to work well.

  • Khadgar Level 1 Level 1 (0 points)

    Spoke too soon. Still screws up. Meh. Hope Apple does something about this crap soon.

  • csteelooper Level 1 Level 1 (10 points)

    What kind of driver are you on about? 10.7.2 didn't contain any new FireWire Class Components, let alone full driver sets for it. What's more, as I've pointed out before, I don't necessarilly think the problem lies with Lion in particular. I'm experiencing exactly the same issues under Snow Leopard...

  • dysmike Level 1 Level 1 (0 points)

    It's possible that this really slips back to 10.6.  In my case, I can't state that for sure.  I say this because my 10.7 box only has fw800 and I realized last night that I tested using a fw400 cable on the 10.6 box, because the Winx and Linux boxes also only had fw400.

     

    Now that said, I reformatted the offending slice to exFAT and it mounts very happily.

  • Khadgar Level 1 Level 1 (0 points)

    Lion seems to have done something for many people here. You wouldn't have a 5 page forum thread filled with people having trouble with firewire devices otherwise. I thought originally it was a firmware issue due to Apple's changing something in their driver. I'm not experiencing one iota of an issue under Snow Leopard, and many of these other people here probably haven't either considering they're posting with varying degrees of shock where their firewire devices have crapped out after upgrading to Lion, not Snow Leopard. Throughout this thread there are many different kinds of firewire devices that are causing trouble for people, not just one. Mine and Dudley's (to whom I was replying to that's not instantly obvious thanks to the way Apple designed these forums) device is a Drobo. He mentioned on here of a firmware update that Drobo released that solved the problem for him. I initially thought it did the trick for me as well because I had a few days of no trouble until last night when Finder started hanging again due to the same firewire driver related issue.

     

    The errors sent to the console are driver-related errors. Finder's hanging waiting on a response from a Firewire 800 drive that's not coming is a driver error. The Drobo itself isn't reporting any erratic behavior. It's just sitting there waiting for instructions from the computer. It's the driver that can't find the device that's still plugged into the computer. If Apple didn't change anything about the firewire driver in the system between Snow Leopard and Lion then it's something else causing the driver to mess up, but regardless the driver is what's screwing up.

  • Csound1 Level 8 Level 8 (40,275 points)

    KaptainKopter wrote:

     

    I use a Western Digital Studio II as my Time Machine back-up drive on my Macbook Pro. I've always had this device connected via the Firewire 400 port and it has worked flawlessly for the 2 years or so that I've had it.

     

    Just upgraded to Lion. Now, the WD drive doesn't mount. No sign of it.

     

    I know the drive's OK because if I connect via USB, all is well (but of course, it's slow).

     

    Any thoughts? Anyone?

    USB 2.0 is faster than FW400 (480Mbps USB, 400Mbps FW), your result is not normal, there have been numerous reports of WD problems on Snow Leopard and Lion, search this forum, start with "More Like This" on the right hand side of this page

  • csteelooper Level 1 Level 1 (10 points)

    @CSound1: Your statement about USB2 being faster than FireWire 400 (FW400) is not entirely true. USB2 has a maximum transfer rate of 480Mbps, but can rarely achieve such speeds continuously. In contrast, FW400 can achieve 400Mbps continuously. Therefore, if you do large transfers over FW400 and compare those to similar transfers committed over USB2, you'll find that, on average, the FW400 speeds typically ARE faster than those attained over USB2.

    There is, however, a caveat. Some FW400 controllers have problems in keeping going at the maximum FW400 bus speed. This is one of the causes for problems people may have when using WD drives with FW400 under Snow Leopard. My own My Passport 500GB for example, would first suffer from a lot of data transfer errors, and then freeze up completely. I have recently had contact with WD in the Netherlands and they recognised the problem lay with their FW400 controller being unable to process large amounts of data. They said they couldn't fix this with a firmware update, but at the same time ruled out that it was an issue with Apple's Firewire drivers.

     

    I must say that this was indeed the first time that I'd heard of anything like this whatsoever! On the other hand, I have to say that my WD drive even acted up when used on FW400 on Windows machines(!) so this couldn't have anything to do with the drivers apple shipped with Snow Leopard...

Previous 1 3 4 5 6 7 8 Next