Previous 1 2 3 Next 41 Replies Latest reply: Nov 28, 2013 2:59 AM by GiedriusT
IowaBoy Level 1 (105 points)

So, I am not able to read the Wiki settings in the Server application.  I notice that in the system log, I'm getting the following error:


FATAL:  role "collab" does not exist


How do I go about adding the collab role?

  • Level 1 (0 points)

    Ditto for me!  Any ideas, where/how are the roles defined?  Or even what is the role?  This affects my new "test" server on my macbool pro as well as my upgraded main server on a mac mini server.


    I think that when I've got this sorted I've got the upgrade sorted!  Certainly not a simple upgrade!

    1. server app access vanished (servermgrd listener disabled after upgrade)

    2. invalid path in one of the configuration files

    3. invalid permissions on one of the log directories

    4. collab role does not exist

    5. remote server admin does not work (but local does), not a "show stopper", but frustrating!

  • The Teknologist Level 1 (15 points)

    It's a postgresl error.


    The postgresql role 'collab' used byt the collaboration services is missing.


    You might have a database corruption.


    You can try to restore from a backup the database:


    Either the /var/pgsql directory (Postgres being stopped when you do this)


    or a postgresql dump made with pg_dump or pg_dumpall



    do a ls /var to see if you have any backups


    Most of the problems could be realted to the db being broken


    As a last resort you can try reinitializing the deviceManager postgresql DB with this command


    sudo /usr/share/devicemgr/backend/


    I suspect though you would loose all you Profiles in profileManager


    You'd go back to factory defaults but at least it could fix you missing role...


    Just a guess...Hope this helps!

  • Level 1 (0 points)

    So, Snow Leopard used MySQL (or did it use postgresql as well), Lion uses postgresql, it was an automated migration by Apple and the database is corrupt?  Did the role change between Snow Leopard and Lion and fail to be migrated?

  • Level 1 (0 points)

    I'll have to dig into this further, but what is the Profile Manager used for?  I thought it was general user management, but when I look at the syslog, several of the server app screens cause a role does not exist error! 


    Is there a script anywhere that will build the roles that Lion Server needs?

  • Doug Whitmore Level 2 (235 points)

    Look at



    That will build the roles and set up the database for use with wiki.

  • Level 1 (0 points)

    I had to run all the scripts in that directory!  Now everything seems to be working as it should.

    Thanks for the help.

  • IowaBoy Level 1 (105 points)

    I marked Doug's answer as correct since someone else used it and it worked.  I was impatient and ended up re-installing Lion and Lion Server.  Doug, thanks for posting the solution!

  • RoadGlide03 Level 1 (0 points)

    This worked it was driving me crazy since I had removed Lion Server I was still getting this.  Thanks a bunch!

  • Scott=) Level 1 (0 points)

    You're ingeious...this solution solved my problem perfectly

  • Moises_Ruiz Level 1 (0 points)

    Can someone please give more details for this resolution?


    I get an error message when trying to run the script:

    could not connect to server: Permission denied

              Is the server running locally and accepting

              connections on Unix domain socket "/var/pgsql_socket/.s.PGSQL.5432"?


    Even though I tried running it with sudo.

  • perry9956 Level 1 (0 points)

    First, assure the postgres database service is running:


    $ sudo serveradmin start postgres


    It should respond:


    postgres:state = "RUNNING"


    Now check that postgres is functioning trying to connect, e.g.:


    $ sudo psql -U _postgres -d postgres


    where _postgres is the superuser and postgres is a database to connect to.


    Then, try again running the script, which I assume you run with:


    sudo ./

  • perry9956 Level 1 (0 points)

    In order to have PostgreSQL functioning on your Mac OS X Lion Server please read:



    Also download and install PGAdmin (ax excellent graphical front-end to PostgreSQL instead of the command line approach):


  • Jager2247 Level 1 (0 points)

    I'm sorry, I'm not really that familiar with server or the command line interface. I bought my new mac mini server in part to mess around with it and try to teach myself more about both topics.  So could you explain how to run the scripts you are referencing in your post? I'm sure this is a stupid comment, but I tried to find the folder referenced above (/System/Library/ServerSetup/CommonExtras/PostgreSQLExtras/CoreCollaborationPos tg), and could not find it in the Library. Thanks in advance...

  • perry9956 Level 1 (0 points)

    This seems very strange. What is the first subdirectory you don't have? Surely you have /System/Library/ServerSetup, otherwise you haven't Lion Server! If, for some strange reason, you lost subdirectories CommonExtras or PostGreSQLExtras I think you should try to re-install the server part of Lion. Otherwise, if you miss the only script, let me know and I'll send you it.

Previous 1 2 3 Next