10 Replies Latest reply: May 30, 2013 7:59 PM by Gautam
dianafromapo Level 1 (0 points)

Need some help, please.....Had a WD Studio Ed II 4 TB HDD (2x2TB HDD) and it worked wonders. Decided to upgrade, using the same external case, with two 3TB HDDs. The 4TB HDD showed up with all 4TBs available for writing to. With the newer 3TBs installed, I only get 2.2TB total - when I should have 6TB total.

I've tried reformating the two 3TBs in the enclosure with Disk Utility/Erase/Security erase. After 13 hours, still 2.2TB..... I thought OS X 10.6 and up supported larger external HDDs.


can anyone help?



WD Studio Edition II 4TB external HDD (2x2TB drives)

32MB cache


trying to upgrade (in the same enclosure):

WD 3TB HDs (2x3TB drives)

64MB cache


tried: firewire connection, USB connection, erase with DU, security erase with DU


my set up:

iMac, MAC OS X 10.6.8, 2.93GHz Intel Core 2 Duo, 8GB Ram


Thanks for any help!!!

iMac, Mac OS X (10.6.8)
  • X423424X Level 6 (14,215 points)
    trying to upgrade (in the same enclosure):


    It's almost certain that that enclosure doesn't support 3TB drives.  Not all older enclosures do since 3TB's have been on the marker a relatively short time.


    Update: After a little searching I found this WD page for what I believe is your enclosure.  If you click the specifications and look at the second bullet item it does indeed confirm the enclosure does not support drives about 2TB.



  • paulalive Level 1 (0 points)

    I realize that i'm replying to a year and a half old thread, but for what it's worth it still shows up in the top 5 of a Google search.


    anyway, I had a similar problem - recently tried to upgrade an aging (probably circa 2009 or 2010) MyBook Studio II 2TB (2x1tb) to 6TB (2x3tb). knew enough to get the WD Green drives, popped them in, and I was stuck at 2.2TB. reformatted, repartitioned, nothing seemed to help.


    however I took some advice I found and did the following:

    1) went to WD's website and got the installer for their Drive Manager (you need it to uninstall the old version).

    2) uninstalled the old copy of drive manager (even if you don't think you have it, better to check with the uninstall program anyway)

    3) downloaded the Firmware Updater (again from WD's website)

    4) connected the drive via USB and updated the firware (it didn't see the drive while connected via FireWire)

    5) restarted computer; power cycled drive

    6) installed latest version of Drive Manager

    7) opened Drive Manager and changed RAID type (in my case it was from 0 to 1)


    the drive FINALLY showed up as 6TB (well, 3TB, but in RAID). when I flipped it back to RAID 0 it showed up as a happy 6TB in the Finder and Disk Utility, etc.


    note: before changing the RAID type, it still showed up as a discouraging 2.2TB. it was only after I had Drive Manager have its way with it that it showed the correct size. I also still have Drive Manager installed and running as I'm a bit paranoid to remove it - most likely unfounded worries - just playing it safe since it took me the better part of an hor to get it working correctly.



  • Gautam Level 1 (105 points)

    I plan to do the same with my old 2x1TB. Was looking for someone who had actually done it. Your guiding note is very helpful. Now to order the two WD Caviar Green 3TB drives.


  • Gautam Level 1 (105 points)

    After I wrote my previous comment, called technical support of Western Digital. The support staff told me that the drive was only user serviceable and not user upgradable. He said the design of the enclosure (meaning the hardware card inside) was specific to the drive size. But since you succeeded in doing the upgrade, I guess WD just wants to dissuade users from upgrading the drives on their own.

  • wileatu Level 1 (0 points)

    I just upgrade my 2x1TB Studio II (2009) to 2xWD Green 3TB sucessfully.

  • Gautam Level 1 (105 points)

    That is indeed good news. I see there are a number of different part nos for the WD green 3TB drives like WD30EZRX, WD30EZRSDTL, WDBAAY0030HNC-ERSN. Which one did you install.


  • wileatu Level 1 (0 points)

    SATA3 3TB 64M 30EZRX Caviar Green

  • Gautam Level 1 (105 points)

    Thanks. I have now ordered them and hope to receive them in a day or two.

  • Gautam Level 1 (105 points)

    Yesterday, I upgraded the My Book Studio II 2x11TB  drive to 2 x 3TB drive without any problem. After having upgraded the firmware, I simply replaced the 1TB drives with a set of 3TB drives. The new setup was immediately recognised in DiskUtility as a 6TB drive.