Previous 1 2 3 Next 31 Replies Latest reply: May 15, 2012 8:51 PM by Trevor Cole Go to original post
  • smith78 Level 1 Level 1

    Same issue on Mac Mini.  Trying to use Bomgar Jump Client (Similar to VNC and Team Viewer).  If the display is asleep I can't connect.  If I tap the keyboard to wake it up I can connect fine.  (The machine is a test subject sitting on my desk...)

  • asbness Level 1 Level 1

    adrianjoheni: I have the same issue, have been trying to access my home desktop with Teamviewer from work, but after connecting there is nothing. So it is connected, but no screen.

  • Tony T1 Level 6 Level 6
    Mac OS X

    adrianjoheni wrote:


    ... the only crazy work around is to turn Display Sleep mode OFF, thankfully ScreenSaver does work properly.


    Display Sleep should turn your display off, but not affect your machine, as hard drive is active.


    Have you considered sending a WOL?


  • odony Level 1 Level 1

    Seems it was a bug, and is fixed in 10.7.1 now. At least moving the mouse seems to wake up from sleep again now - much better, I basically never press down the touchpad on my MBP.

    I haven't tested any VNC/remote connections to see if that issue is fixed, though.

  • igmackenzie Level 4 Level 4

    Are you sure you are waking from sleep, and not just the display turning off?

    It is supposed to be designed as requiring a click or tap.  I'm on a iMac, and it may be different to the MBP, but I'd be surprised if it was a bug.

    Anyone else get their MBP to wake with a swipe of the trackpad or a mouse movement after a hard disk shutdown sleep?

  • odony Level 1 Level 1

    Correction, it doesn't work to wake up from sleep indeed, sorry. I guess I experienced a few cases where I came back to the keyboard right after the display turned off, and since it was just after upgrading to 10.7.1 I jumped to the conclusion that it was fixed. Still requires a click when it went to sleep indeed.

    I can understand how it would be a desired feature for mouse users, but on an MBP that's on the power adapter with no mouse, having to click the touchpad (something that you might never need otherwise) feels slightly annoying. I don't suppose there's a workaround for that, except of course disabling the sleep mode.

  • adrianjoheni Level 1 Level 1

    I had to disable Sleep display as a workaround which is insane. I am not sure what is happening at Apple, first they disable features like "Browse Backup" in iPhoto 9.2 so you can't restore a single photo, but only the entire Library, absurd, and this bug that it affects the basic functionally of the machine and still waiting for a fix. I already submitted a bug report and still nothing, I guess our only hope is that some big shot at apple experiences this issue for themseft and then they will have someone to have a look.

  • igmackenzie Level 4 Level 4

    adrianjoheni wrote:


    I had to disable Sleep display as a workaround which is insane.

    A workaround for what exactly?

  • John Cipolletti Level 1 Level 1

    Did you try and set the Energy Saver option in the Preferences? Under the settings for Power Adapter there is an option to wake for netwrok access. By default it is off, and it is unavailable for when you're on battery power.

  • adrianjoheni Level 1 Level 1

    I disabled Sleep display under Energy Saver in Preferences, this way the Screen Saver will take over doing the trick but again, it is just a workaround so the works after your display is in screen saver mode

  • joelw135 Level 1 Level 1

    I found my wireless mouse went to sleep but if I tapped my spacebar on  the keyboard I can then wake the iMac. To me it isn't a big deal to hit the spacebar.

  • igmackenzie Level 4 Level 4

    I ask again, a workaround for what?

  • adrianjoheni Level 1 Level 1

    With Lion OS the machine display goes to sleep and the moving the mouse won't wake it up, while the "display is sleeping" you might think the machine is still up and running, but if you try to access the machine from the network  or access it using something like VNC or TeamViewer it won't let you as the machine seems to be sleeping, before you could do this normally. Note: I have tried in different machines and even tried to install LION OS fresh and Nope, it does not work. my so called "workaround" is only to keep things running while the display is not "active", even though it is still. Im just using screen saver for the moment, not the display sleep from the energy saver otherwise you may not be able to access you machine remotly.

  • igmackenzie Level 4 Level 4

    OK, I see.  That is a totally different issue than the one being discussed in this thread.

    Stating the obvious, and as John asked above, have you checked the 'Wake for network access' box in Energy Saver before you try going to sleep?

  • Battlehawk Level 1 Level 1

    Haven't upgraded to Lion yet, Running 10.6.6 on a MBP. I am also experiencing this problem.  I have tried setting the monitor and energy savings to never sleep and the after the screensaver runs for about 10 minutes, the monitors go black and then the computer is completely unresponsive to the keyboad or the mouse. I also run a remote access called Tonido and I have the same issue.  If the machine has gone into this Sleeping Beauty mode, I cannot gain access from the Tonido server. It says the machine is unavailable. Ugh. Frustrated.