Previous 1 2 Next 24 Replies Latest reply: Sep 20, 2013 12:15 AM by acalord
Code3inLA Level 1 Level 1 (0 points)

I updated iTunes last night through the regular Apple Software Update and it appeared to update iTunes, Quicktime and Safari normally.  I am running Windows 7 Home Premium - 32 bit.  After the update it said I needed to restart Windows, so I did.  Since then I get the following errors:

 

As Windows is booting up, the following errors appear:

 

AppleSyncNotifier.exe  Entry Point Not Found

The procedure entry point sqlite3_wal_checkpoint could not be located in the dynamic link library SCLite3.dll

 

iTunesHelper.exe  Entry Point Not Found

The procedure entry point sqlite3_wal_checkpoint could not be located in the dynamic link library SCLite3.dll

 

If I try to start iTunes, I get the same error followed by:

iTunes was not installed correctly.  Please reinstall iTunes

Error 7 (Windows error 127)

 

I have reinstalled iTunes but the errors continue.  I tried replacing sqlite3.dll but that did not help.

 

Any help or suggestions?  I'm pretty tech savy but I'm at a loss.


Dell XPS 420, Windows 7
  • Lois Marcasciano Level 1 Level 1 (0 points)

    I have the exact same problem. I updated this morning and that message shows up everytime I turn on my computer. Windows XP Dell 6510.

  • process_server Level 1 Level 1 (5 points)

    I'm getting almost exact same messages - have not been able to open iTunes since attempting install of new iTunes update this morning.  I'm running Windows Vista 32 Bit on HP laptop, and my error messages center on a missing ALS.dll file and "iTunes was not installed correctly. Please reinstall iTunes. Error 7 (Windows error 126)".  Have tried repairing and tried manual uninstall and reinstall with no success. 

  • abbasfromdubai Level 1 Level 1 (0 points)

    I received a note to do the regular Apple Software Update for iTunes, Quicktime and Safari, then I faced a big problem from that exact same messages, I could not sleep, and I could not go to work and I cannot make any phone calls.

    I did not imagine that one day I'll see this intransigence and irony Carried out by Apple with humans, this makes us lose confidence in their products. Because they are interested in selling their products only and do not provide any service to their clients. And to help us solve problems that result from the method of maximum protection of their software. But I think that there is no any point in calling them and asked for their help and support. Where they do not show any initiative to help resolve the problemsThis indicates that they intend to do that, Believe it or not this problem has caused great damage and loss to me, Since I had 4 iPhones, And all my friends advised me to get rid of them and sell and never buy this products again, even if selling them at a loss because the Apple company abandon its responsibility to serve and assist their customers by support   

  • Code3inLA Level 1 Level 1 (0 points)

    FINALLY GOT AN ANSWER!

     

    After spending 30 minutes on the phone with Apple Support, we got it fixed.  Here is how to fix this issue:

     

    1. Temporarily shut down anti-virus and firewall software
    2. Open Control Panel, Programs and Features (or Add and Remove Programs), and go to the uninstall section
    3. Remove all Apple products in this order - iTunes, Quicktime, Apple Software Update, Apple Mobile Device Support, Bonjour, Apple Application Support.  You do not need to remove Safari
    4. Restart computer
    5. Go to Apple.com and download newest version of iTunes
    6. Re-install

     

    That did it for me!  No more error messages and everythine appears to be working again.  Hope this helps everyone!

  • abbasfromdubai Level 1 Level 1 (0 points)

    You don't have to download anything, the problem is caused by the Version 10 iTunes installer, which places the file in the wrong location...

    Just copy the file SQLite3.dll from the C:\Program Files\Common Files\Apple\Apple Application Support folder to the C:\Program Files\Common Files\Apple\Mobile Device Support folder.

    Problem solved.

    Downloading another version of sqlite3.dll may not solve the problem at all. You may find as many as 12 different versions of this file on your PC depending on what software you have installed. Only one version of the file will work, and that is the correct one for the Apple software.

  • Code3inLA Level 1 Level 1 (0 points)

    abbasfromdubai,

     

    Your answer did not work for most of us.  I had already tried copying SQLite3.dll to the Mobile Device Support folder and that did not solve anything.  It was not that simple.

  • iPhoneGiirl Level 1 Level 1 (0 points)

    Thank you, Code3!!  Worked perfectly!  100% perfect post.

     

    (And abbasfromdubai, your suggestion was 100% useless).

  • bradleyfromamherst Level 1 Level 1 (0 points)

    I followed your post suggestion and it worked for me.

    Alot quicker than having to delete all those programs.

    Thanks

    Brad

  • becmer Level 1 Level 1 (0 points)

    I tried the other suggestions from the other people (abbasfrom dubai) which didn't work. Your suggestion worked BRAVO!!!

  • PoseyWozy Level 1 Level 1 (0 points)

    I have tried abbasfromdubai and Code 3 suggestions and this crap is still not working. I have windows 7. I am really frustrated now. This is why I don't like updating.  Why does Apple basically make you upgrade with a program that has not be thoroughly ****** testing it?

  • bradleyfromamherst Level 1 Level 1 (0 points)

    Are you still having problems

    Brad

  • PoseyWozy Level 1 Level 1 (0 points)

    No, I'm sad to say

  • bradleyfromamherst Level 1 Level 1 (0 points)

    Hi again:

    so its fixed?

    if not did you go to the commons folder in the programs files x86)

    click on commons files

    click on apple

    click on Apple Application Support

    find the sqlite3.dll file

    right click on that on pick copy

    go back and open the mobile Application folder

    right click and paste

    the sqlite3.dll file should now be in that mobile Application folder.

    close

    that should do it

    not trying to be insultive if this is what you did and it did not work

    it worked for me.

    hope I helped

    Brad

  • becmer Level 1 Level 1 (0 points)

    I'm not having any more problems cuz I used the fix that code3inla suggested it worked for me. the other fix didn't work

Previous 1 2 Next