13 Replies Latest reply: Dec 20, 2012 8:14 PM by GarethH1
nkt00 Level 1 Level 1 (0 points)

I upgraded my iMac from Snow Leopard to Lion and now Spotlight doesn't return any results. The menu only lists web search and wikipedia search when i type anything into the search field. I tried running "sudo mdutil -E /" from the Terminal. That gave the following message:


Indexing and searching disabled.


Any ideas?

27" iMac (i5), Mac OS X (10.6.5)
  • Colin Robinson Level 6 Level 6 (8,305 points)

    Have a look in Sys Prefs > Spotlight > Privacy to see if your disk is in there, meaning it won't get indexed?

  • Michael Sidoric Level 2 Level 2 (365 points)

    The initial indexing of a 'new' upgraded disk can take hours.


    Colin's suggestion is solid, but may I also add if your drive is not currently listed in the Privacy list to not index for Spotlight – that you ADD your boot drive to Privacy and then close System Preferences, then log out. Then log in again, go to the same Spotlight > Privacy settings and REMOVE your boot disk.


    This will trigger a re-indexing of your drive for Spotlight. It is a long process but after it completes your Spotlight should again be happy.


    Hope this helps.

  • nkt00 Level 1 Level 1 (0 points)

    I figured it out. In the man page for "mdutil" (type: "man mdutil" at the terminal shell prompt), it describes the option "-i", which turns indexing on or off for the specified volume. I just typed:


    sudo mdutil -i on /


    and away it went. Still a mystery how indexing got turned off in the first place, though.

  • GlennW Level 3 Level 3 (625 points)

    Since you're already using the mdutil command, what does "mdutil -sv /" show?  What happens if you try "mdutil -i on /"?

  • GlennW Level 3 Level 3 (625 points)

    Beat me to it

  • bamancabroad Level 1 Level 1 (0 points)

    Hi guys,


    I have a new MacBook Pro running Lion. Spotlight will not do the initial indexing of the drive. I have tried all of the above suggestion, and nothing seems to work. Apple Care says it may be a bad hard drive and I should exchange the machine. However it was a special order, and it is a 6 week turnaround for a new machine. I use it for work, so that is a big issue.


    Any other thoughts?


    Thanks a lot.

  • bamancabroad Level 1 Level 1 (0 points)

    Here's what Spotless returns after I disabled Spotlight/rebooted/attempted to enable.

    Screen shot 2011-11-16 at 9.07.17 PM.png

  • BigRedNZ Level 1 Level 1 (10 points)

    Eurika I've found it


    The deleting the cache worked for me


    Spotlight won’t work? Fix a broken Spotlight menu with these troubleshooting tips

  • eorton Level 1 Level 1 (0 points)

    Brilliant!  Solution #1: Kill SystemUIServer worked for me.  Thanks!

  • alhandyman Level 1 Level 1 (0 points)

    I can confirm that this worked for me.


    Many thanks

  • Doug Weiss Level 2 Level 2 (355 points)

    I have tried all the above cures and none seem to work for me.


    If I click on the spotlight icon I only get the availablity of Web Searches.


    I cannot do any searches from a finder window


    I have a new iMac running 10.8.2 I get the "spotlight server disabled" when I run sudo mdutil -E /


    In spotlight preferences>privacy when I try to prevent spotlight from searching these locations in order to rebuild the index, I get error: Privacy List Error - "The item couldn't be added or removed because of an unknown error"


    I have deleted cache files and preferences


    I have reinstalled OS 10.8.2


    fixed permissions


    verified volume -ok


    ran Tech Tools Pro volume rebuild


    still no spotlight or finder search

  • Doug Weiss Level 2 Level 2 (355 points)

    Finally a post from Thomas Reed, thanks Tom, worked. After trying all the above and stumping even Applecare phone support this did the trick.


    The guaranteed way to reenable Spotlight is to reload it into launchd using launchctl:

    sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist


    Now finally back in business.

  • GarethH1 Level 1 Level 1 (0 points)

    I just had a similar issue. Spoghtlight just stopped showing any results other than search web/wikipedia for...

    I tried checking in system preferences/spoghtlight/privacy, nothing.

    I tried unchecking/rechecking all the areas for spoghtlight to search, nothing.

    I considered running a series of lines in terminal, then got the novel idea of just trying a simple warm boot, and vwala, IT WORKED! Spoghtlight started indexing the Internal HD, then continued functioning normally again!

    Often times, the simplest fix, is the best.

    - MBP 15 (pre USB 3.0), OSX 10.7.5, HD screen upgrade