Previous 1 2 3 Next 93 Replies Latest reply: Sep 24, 2015 2:07 PM by MikeyMike7
alan169 Level 1 (0 points)

After I updated itune and quicktime on my computer, such statement pops up every time when I start the computer 

AppleSyncNotifier.exe - Entry Point Not Found

" The procedure entry point sqlite3_wal_checkpoint could not be located in the dynamic link library SQLite3.dll"

Anyone know how to fix it?

iPhone 4, Windows 7, 64-bit
  • kruelaid Level 1 (0 points)

    Count me as #2. Same system.

  • abbasfromdubai Level 1 (0 points)

    I received a note to do the regular Apple Software Update for iTunes, Quicktime and Safari, then I faced a big problem from that exact same messages, I could not sleep, and I could not go to work and I cannot make any phone calls.

    I did not imagine that one day I'll see this intransigence and irony Carried out by Apple with humans, this makes us lose confidence in their products. Because they are interested in selling their products only and do not provide any service to their clients. And to help us solve problems that result from the method of maximum protection of their software. But I think that there is no any point in calling them and asked for their help and support. Where they do not show any initiative to help resolve the problemsThis indicates that they intend to do that, Believe it or not this problem has caused great damage and loss to me, Since I had 4 iPhones, And all my friends advised me to get rid of them and sell and never buy this products again, even if selling them at a loss because the Apple company abandon its responsibility to serve and assist their customers by support

  • abbasfromdubai Level 1 (0 points)

    You don't have to download anything, the problem is caused by the Version 10 iTunes installer, which places the file in the wrong location...

    Just copy the file SQLite3.dll from the C:\Program Files\Common Files\Apple\Apple Application Support folder to the C:\Program Files\Common Files\Apple\Mobile Device Support folder.

    Problem solved.

    Downloading another version of sqlite3.dll may not solve the problem at all. You may find as many as 12 different versions of this file on your PC depending on what software you have installed. Only one version of the file will work, and that is the correct one for the Apple software.

  • Glassperlenspieller Level 1 (0 points)

    It worked. Thanks.

  • grahamfromluton Level 1 (0 points)

    I Have the same problem as previously stated, tried your recommended fix but I still get the same message on start up.

    This only stated after updating software to 10.4 0.80 on Friday 22/7/2011.

    'AppleSyncNotifier.exe - Entry Point Not Found' followed by 'The procedure entry point xmlTextReaderConstName could not be located in the dynamic link library libxml2.dll.'


    I rechecked to make sure the file was pasted in the correct folder as advised & it was

    Is there anything else I can try?

    For my info, what affect on not having this file have?

    I appreciate your help, if you can




  • Midnight_Voice Level 1 (10 points)

    I had the exact issue listed with SQLite3.dll, on Win 7 64-bit after the iTunes update, and solved it as described by abbasfromdubai above (in the constructive posting, not the rant), though I actually got the fix via:-



    which is dated April 2010.


    Like me, you might be disappointed that Apple haven't got this right yet, even after more than a year.


    However, I note that your similar issue, @grahamfromluton, is with libxml2.dll, not SQLite3.dll


    libmxl2.dll is in my C:\Program Files (x86)\Common Files\Apple\Apple Application Support folder, but not in my C:\Program Files (x86)\Common Files\Apple\Mobile Device Support folder; but I don't have your issue with this file, so I can't tell what good, if any, copying it over will do.


    (NB: use Program Files (x86) on 64-bit WinOSes, but just Program Files on 32-bit ones)


    However, for the avoidance of doubt, can you confirm it was libxml2.dll you copied over? And if not, try copying that file over, and seeing if it fixes things.

  • grahamfromluton Level 1 (0 points)

    Thanks, copied as advised & everything 'seem' to be OK. Message gone (thank heavens) & a cursory look thro' my iTunes appears all in order


    Very grateful for your help 10/10



  • Janet C Level 1 (0 points)

    I'm getting this error message too, but how am I supposed to move SQLite3.dll when it is nowhere on my computer?

  • Midnight_Voice Level 1 (10 points)

    It ought to be in C:\Program Files\Common Files\Apple\Apple Application Support (on a 32-bit WinOS - XP, or 32-bit Vista or 32-bit Win7) or in C:\Program Files (x86)\Common Files\Apple\Apple Application Support on a 64-bit OS (usually only Win 7 generally for home users, though there was 64-bit Vista, and maybe even a 64-bit XP, but you are unlikely to have these).


    Have another look in that specific location. The Windows Search doesn't look everywhere you perhaps think it ought to.


    If you do find it, copy it to the corresponding folder C:\Program Files\Common Files\Apple\Mobile Device Support (or C:\Program Files (x86)\Common Files\Apple\Mobile Device Support on a 64-bit machine), reboot, and see if the problem goes away.


    If you really don't have the file, try a Repair install of iTunes at Start Button, Control Panel, Programs and Features (which I think is called Add Applications, or some similar name in XP). Choose iTunes, press Repair.


    That should stash an SQLIte3.dll back into Apple Application Support.


    If still not, try a full reinstall of iTunes, and see how that goes.

  • kruelaid Level 1 (0 points)

    Hi Janet, I can't find it in the folders posted above so I ran a search on my whole C drive.


    I found it using this method and put it in the folder suggested by abbas, but that didn't help.


    [rant]I don't expect any help from Apple on this because they want me to buy a Mac. AFAIC that kind of attitude is yet another reason NOT to buy one (hey it's my wife's phone)--that reason in addtion to the fact that Apple can't run the Microsoft apps I need for business.[/rant]

  • kruelaid Level 1 (0 points)

    Tried copying the file as per abbas's description, although it wasn't where he said it would be.


    Didn't work.


    Tried "repairing" iTunes.


    Didn't work.

  • Janet C Level 1 (0 points)

    Oh, good grief!  Why doesn't Apple just release another update to fix this?  And it would be very nice if they tested it for this kind of screw-up before they send it and other upddates to millions of people all over the world.  I can't even begin to comprehend the number of hours wasted for so many people.

  • kruelaid Level 1 (0 points)

    I tried to reinstall itunes. Didn't work.


    In fact there are five or six bloating programs installed with iTunes and the program doing this is NOT itunes.


    Now I have uninstalled all Apple programs and moved my wife's itunes to another computer. It's running ok for now. The computer that has had all Apple software uninstalled now runs much faster overall.


    Thanks Apple. My wife enjoys your phone, but until you stop cranking out this trash she's the only one in our family who will be using it.


    (I'm going to pass ranting on all the problem I had with my mac in 2001, which made me get rid of it. Or the iPhone I bought this spring that didn't work and i got a refund... just... whatever.)


    Good luck Janet.

  • Midnight_Voice Level 1 (10 points)

    As I said above, I originally found the fix for this problem in a posting from April 2010, so it looks like Apple have let it run for a very long time :-(


    But having said that, I never experienced it until this latest iTunes update. And last night, my Vista machine threw the exact same error on bootup, and I fixed it in the exact same way - copied the file SQLite3.dll from C:\Program Files\Common Files\Apple\Apple Application Support folder to C:\Program Files\Common Files\Apple\Mobile Device Support (which did not previously contain this file).


    Just plain 'Program Files' this time, as it's 32-bit Vista.


    On this morning's bootup, problem gone.


    Did you look in C:\Program Files\Common Files\Apple\Apple Application Support for SQLite3.dll?

    Or if you are on a 64-bit OS, C:\Program Files (x86)\Common Files\Apple\Apple Application Support?

Previous 1 2 3 Next