Skip navigation

Just installed Lion, but have no sound on my external speakers need help?!?!

682 Views 6 Replies Latest reply: Feb 12, 2013 3:50 PM by J Craig1 RSS
benjaminfromphoenix Calculating status...
Currently Being Moderated
Jul 22, 2011 8:33 PM

any help would be great i am going crazy!

iMac, Mac OS X (10.7)
  • WrongCoaster Calculating status...

    Try going into system prefs choose sound then highlight what you want to use for your sound output device.

  • taleboulin Calculating status...

    Believe it or not : plug earphones and the sound is back... Completely annoying but it seems to solve the problem...

     

    Good luck

  • Hotel Joe Calculating status...

    I just got off the phone with apple support.   I had the same issue and now I'm fine.   Some have suggested PRAM.   He also had me to one other thing.

     

    Shut down

    After shut down, hold dont shitt, control and option at the same time while pushing the on/off button.    The computer SHOULD NOT turn on.

     

    Then do another shut down.

    Hold down alt, command, and the P and R at the same time and hit the power on/off button.   Hold them all until you hear the chime TWICE.

     

    I hope that helps.  

  • James Farrell Calculating status...

    Hi everyone,

     

    I had the same problem and I've just got off the phone with apple support. Some info first:

    - I have a MB Pro 13' (mid 2010).

    - I had the sound problem after upgrading to Lion from Leopard, but the safe mode fixed it (while reinstalling it without formating didn't).

    - Because I'm stupid (and had too much stuff installed), I decided to install Lion from scratch and the problem came up again. This time, the safe mode didn't do the trick, neither did most of the advice given here.

    - I have a French version of Lion, so I may mistranslate some terms...

     

    Here is what the nice lady asked me to do. Note that the internal speakers still worked, but I couldn't control them (e.g. volume up or down). And I could gain control again by plugging in earphones and unplugging them, but I could let myself live this way until a fix was released.

     

    1) cf. previous post by JH. Hold down "shift, control (ctrl) and option (alt)" at the same time and presson the on/off button. Do it once. The computer doesn't do anything and it's normal. Wait for 5 seconds, then start Lion normally. I don't remember what it does but it didn't fix the problem.

    2) cf. previous post. Hold down "alt, command, P, R" at the same time and turn on the laptop. It starts once, you shuts down, and starts again. I didn't hear the first chime, but I did hear the second. I think I released the keys just after it restarted (i.e. before the second chime). It didn't help as I still couldn't control the volume.

    3) Start in safe mode (mentioned here too). Hold shift and turn the laptop on. Keep holding until you see a progression bar. Then release shift and wait because it takes some time. Once you're in your session, check whether the problem is fixed. It didn't work for me. Shut down (it takes some time too) and start normally (I'm not sure whether it's important to shut down first, but that's how it happened). Still no control over the sound system.

    4) Permission repair (with the apple tool, because I did try with Iceclean, but it didn't work). Press down "command, R" and start. A menu appears. Select a language (preferably one you understand). Another menu with 4 options appears. Choose the last one: utility disk (it's the same as the one you can access in the utility folder in Lion). Select your mac hard drive (Macintosh HD) and go to S.O.S. First check permissions (I had a warning about one file, but it seems it's normal), and then repair permissions. I restarted and then the problem was solved. I restarted a couple of times (just to be sure), and the problem seems not to appear again.

     

    I have no idea whether these stages and the order matter, but it worked: I can now control the volume.

  • guyfromcollingwood Calculating status...

    Same problem here on my iMac, installed Lion and when I started Face Time the sound went funny and I lost all sound output to my external speakers. I cannot get them to work again, the internal seakers are working ok.

  • J Craig1 Calculating status...

    Did you ever resolve this? Your question has quite a lot of views, which tells me that others have this same problem. My JBL Creature speakers attached to my iMac (2007) stopped working after OSX 10.7.5 install, and they have not worked since then. Headphones don't work either out of that jack. I've tried every solution listed on this post and others, no results. I also use Facetime. No issues whatsoever with volume control, just a jack that no longer functions after an OSX upgrade. too weird. Any help?  

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.