5 Replies Latest reply: Jul 26, 2011 6:21 PM by SamanthaLT
SamanthaLT Level 1 Level 1 (0 points)

April 2011 got the new iPhone 4, plugged into my macbook and downloaded the update and my phone went into recovery mode. Took phone back to store got a black box model, brought it home, this time a little paranoid to hook up to macbook, so updated on home computer. Everything is fine, and can sync with macbook after and use normally. However cannot update phone... then issues start up with the camera, so I place a call to apple and first thing to troubleshoot is to hook up to Itunes and update... well can't, phone doesn't go into recovery mode thankfully, but a message comes up saying this phone is not eligible for update. Continue to troubleshoot, can't solve problem, never even get to the camera issue. It's decided that I need a new phone. So speaking with a higher up, we go into terminal and look up the IP address and it's determined that computer has the wrong address for iTunes... we look for the host file and it's blank, nothing there, no host file. I do a thing to gather data and send it to Apple so the "engineers" can look at it because from what we can see I am going to continue to have issues hooking my new iPhone once it arrives, up to my macbook.

 

I'm just wondering if anyone knows what's going on here with my macbook, or itune or what. Been a few days and apple has not followed up to advise. Anyone have any ideas? I'm not overly computer savvy so  can't say that it was anything I did intentionally, or even unintentionally, but I'd really like to get it sorted out!

 

Thanks in advance!


iPhone 4, Mac OS X (10.7)
  • modular747 Level 6 Level 6 (16,995 points)
    this phone is not eligible for update.

    This device is not eligible for the requested build: Also sometimes displayed as an error 3194. If you receive this error, update to the latest version of iTunes. If you do have the latest version of iTunes, this can occur when you attempt to restore using an older .ipsw file. Try restoring in a new user to ensure that iTunes downloads a new IPSW. 3rd party security software or router security settings can also cause this issue, to resolve please follow Troubleshooting security software issues. Downgrading to a previous version of iOS is not supported. If you have installed software to perform unauthorized modifications to your iOS device, that software may have redirected connections to the update server (gs.apple.com) within the Hosts file. For steps to edit the Hosts file and allow iTunes to communicate with the update server, see  iTunes: Troubleshooting iTunes Store on your computer, iPhone, iPad, or iPod; follow steps under the heading Blocked by configuration (Mac OS X / Windows) > Rebuild network information > The hosts file may also be blocking the iTunes Store.

    http://support.apple.com/kb/TS3694

    we look for the host file and it's blank, nothing there, no host file.

    it's determined that computer has the wrong address for iTunes...


    This makes no sense.  Computers don't store IP addresses for anything (they're supplied by the DNS  your ISP provides or set up in your network settings) unless they DO have a Hosts file.  You probably aren't looking in the right place:

     

    • Open the Terminal utility located in Applications > Utilities.
    • When Terminal opens, open the hosts file by typing entering the following command and pressing Enter:
      sudo nano /private/etc/hosts
    • Edit the hosts file:
      The hosts file contains some comments (lines starting with the # symbol), as well as some default hostname mappings (e.g. 127.0.0.1 – localhost).
      You can navigate the file using the arrow keys.
    • If an entry is found containing apple.com, add # and a space to the beginning of that line.
      Note: If this is a work system, the hosts file may be used to redirect to local resources, such as software updates. Consult your support resources.
      An example hosts file in Terminal
    • Save the hosts file.
      • When done editing the hosts file, press Control-o to save the file.
      • Press Enter on the filename prompt, and Control-x to exit the editor.
  • SamanthaLT Level 1 Level 1 (0 points)

    Thank you this article has so far solved the problem. I had to trash my network interfaces and create a new one, then when I searched for the host file, information showed up, I edited the lines with apple in them by adding a space to one and a # space to the last line. I hooked up my iPhone to iTunes and hit update and no messages are popping up and everything "looks" okay, hoping by the time I am done posting that update will be complete, and it is... so one problem is solved!! Thank you very much modular747. Issue is resolved. I'm impressed!

     

    Now, to figure out why my camera freezes! However seems that is in fact a hardware issue, so I will patiently await my new iPhone.

     

    Thanks again

  • SamanthaLT Level 1 Level 1 (0 points)

    Is there a way to edit from "Helpful answer" to "correct answer"? Thank-you

  • modular747 Level 6 Level 6 (16,995 points)

    You're welcome. 

     

    The fact that your Hosts file had been altered and required editing to update indicates that you had hacked or attempted to hack your phone in the past.  This might account for the problem with the camera.

  • SamanthaLT Level 1 Level 1 (0 points)

    I have an old iPod Touch that was having battery issues after an upgrade over a year ago. I had to jailbreak it and restore to previous iOS to get my performance back. That came back to haunt me with my new iPhone, and as such I guess would not allow me to upgrade due to the modifications I previously made to host files. Hopefully I don't have issues with the touch next time I sync it. However it has been handed down to my daughter!