Skip navigation

Lion Permissions Problem

23218 Views 49 Replies Latest reply: Mar 11, 2013 6:00 PM by _green_ RSS
1 2 3 4 Previous Next
niccas Calculating status...
Currently Being Moderated
Jul 22, 2011 11:17 PM

I'm struggling with what I think is a permissions problem on Lion..

 

I purchased a new MBAir 11" and restored my files by copying them manually from a backup of my home folder - this is always how I have done it. I did have to change the Library folder flag to unhidden as found somewhere else on this forum.

 

The first issue I encountered was that every time I logged out and logged back in, the machine was 'reset' to the state it was in hours earlier. I couldn't change any settings, they would reset themselves. (e.g. changing trackpad settings would reset when I exited system preferences). Also if I used Safari to browse a bunch of sites, none of the history was saved. The history would show everything up to a certain point and wouldn't save anything past that.

 

I created a new user account and that account was obviously fine. So I copied all of my files from the old user account to the new user account. The problem I am having now is that any time I try to change a file in my home folder (e.g. rename) i am prompted for my password. I tried to reset permissions but that doesn't help.

 

Would appreciate any suggestions. TIA.

MacBook Air, Mac OS X (10.7)
  • tripm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 24, 2011 11:35 AM (in response to niccas)

    I am having the exact same issues. I tried repairing permissins as well as resetting the ACLs from the snow leopard installer, all to no avail - many apps will not allow me to change preferences and everything reverts upon restart - even files that have been deleted return to their previous spots. Please Help!

  • TheEpicGeek Calculating status...
    Currently Being Moderated
    Jul 27, 2011 10:11 PM (in response to niccas)

    It does seem to be a permissions issue.

     

    I'm currently trying to recreate my user accounts with the root user, but I can't seem to edit the root password, even from the reset password utility. From the utility is says that I do not have sufficient privileges to do that. I think I may need to boot to a mounted known good operating system (probably Snow Leopard) in order to actually make the needed changes. I'm also going to try a reinstall...

     

    Here's hopin'!

  • +RA Calculating status...
    Currently Being Moderated
    Jul 30, 2011 4:41 AM (in response to niccas)

    Yup just laboriously reinstalled because was having the dissapearing finder window issue & now I have "custom access" on everything, even if it says Read I (Me) have "Read & Write" and desipite Applying folder level "Read & Write" to enclosed items & using Disk Utlitiy to fix file premissions globally. SO now every file move or deletion needs to be validated. How on earth was this not picked up in beta? Would love to keep Lion but it's looking increasingly like a reinstall to Snow Leopard as having to validate basic file actions is really not going to be acceptable. Just as well I didn't install Lion on any of my other Macs....

  • rudeb0y Calculating status...
    Currently Being Moderated
    Jul 30, 2011 10:40 PM (in response to +RA)

    Similar issues... can't restore "Library" folder from Time Machine backup and after a reboot for instance dock settings are back to default.

  • quissac Calculating status...
    Currently Being Moderated
    Aug 1, 2011 5:57 PM (in response to niccas)

    I am having the exact same problem, and tried all solutions discussed here, to no avail.  However, in my case the admin account does work, the other accounts don't. I am going to try to recreate the other accounts and see what I can get, but I am really irritated with Lion.  The only feature it has that I like is the mission control, every other change has been for the worse.

  • cgDesign Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 4, 2011 12:00 PM (in response to niccas)

    Same issue, many other bugs with Lion that are annoying me as well but this one is by far the worse of them.

     

    Late 2008 MBP

  • rudeboy Calculating status...
    Currently Being Moderated
    Aug 4, 2011 12:02 PM (in response to cgDesign)

    deciided to restore all except the Library folder... so far, so good (been 5 days now)

  • cgDesign Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 5, 2011 5:40 PM (in response to cgDesign)

    I may have some good news but I need some brave souls to test it out. I have run these commands and haven't had a single problem since!

     

    The first command removes all ACLs from files in the home directory:

    chmod -R -N ~

     

    This command puts the necessary ACLs back where they belong:

    chmod +a "everyone deny delete" ~/ ~/Desktop ~/Documents ~/Downloads ~/Library ~/Movies ~/Music ~/Pictures ~/Public

     

    That's it. My problems disappeared. If this doesn't work or you are afraid of Terminal, I also ran across this in all my searching: http://www.fixkb.com/2011/08/reset-home-folder-permissions.html

     

    Let me know if this works for you as well and if so, spread the good word!

  • tripm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 5, 2011 7:51 PM (in response to cgDesign)

    Brave? i've tried everything else to no avail. THANK YOU! Finally my mac is acting normal again. the first command returned an invalid argument message, but after the 2nd one everything started to work again. Praise you!

  • BallisticJack Calculating status...
    Currently Being Moderated
    Aug 6, 2011 3:16 AM (in response to niccas)

    This sounds similar to the problem I'm having.... http://discussions.apple.com/message/15734265#15734265

     

    Will try cgDesign's solution at somepoint and report back.

  • quissac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 7, 2011 11:22 PM (in response to cgDesign)

    This is excellent, it worked for me! Unfortunately I had already created a new account to repair the problem, but at least I know how to solve it of anotehr account has this problem.

     

    Thanks a lot!

  • William Boyd, Jr. Level 6 Level 6 (10,475 points)
    Currently Being Moderated
    Aug 9, 2011 2:55 PM (in response to tripm)

    tripm wrote:

     

    the first command returned an invalid argument message

    For future reference, if you ever get an error message while using commands in a Terminal session that you got from another source, you should stop immediately, report the problem, and ask for further help.  Using someone else's commands then ignoring an error message is an easy way to destroy your system.

  • stianbrathen Calculating status...
    Currently Being Moderated
    Aug 10, 2011 8:20 AM (in response to cgDesign)

    That is dangerous. Don´t try it.

  • cgDesign Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2011 9:12 AM (in response to stianbrathen)

    stianbrathen, what do you mean it's dangerous? It secures the permissions on your home folder. If anything, it's recommended.

     

    William, I completely agree. And that is precisly why I enlisted "brave" users only to do some testing with me. While I am quite comfortable and familiar with the shell, things can always go wrong. From what I know, if a command encounters an Invalid Argument, it will halt the command before it begins since it's conditions were not met.

     

    From the response I've gotten here and on other boards, it sounds like the ACLs are not the issue, it's strictly permissions. I recommend skipping the first command, run the second. For clarification, this sets your home folder to read/write privilages for your user only and sets everyone else to read only.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.