Previous 1 2 Next 24 Replies Latest reply: Feb 3, 2012 7:44 AM by bradkaye
s. luke Level 1 Level 1

There is one glaring difference in the new iTunes 10.4 (80). I can't drag songs from one playlist to another. It doesn't matter whether the source is a smart playlist or a regular dumb one, or even the main music library.

 

smart playlist or dumb playlist or even the main music library) into other (dumb) playlist.

 

As a workaround, I can copy (cmd-c) and paste (cmd-v), but this is ... umm ... sub-optimal, because you have to change playlists to do it. Then when you go back to the first folder, any search you might have used before is now gone.

 

Is there any way to bring back drag and drop? Some weird .plist hack or anything?


iTunes, Mac OS X (10.6.8)
  • s. luke Level 1 Level 1

    Well. My first efforts to search for a solution were poorly executed, because I tried again and found lots of answers.

     

    The problem appears to be using a Wacom driver. See the discussion here and (same thread) here and here. No idea when that will be fixed. I use a 8 or 9 year old Graphire, and drivers have been a problem for most of those. Sigh.

     

    But this experience also made me learn that you can right click to add selections to a playlist.

     

    I even learned how that first column works, which I never knew before.

  • jungfrow Level 1 Level 1

    thanks so much for the help...i waas sitting here wondering how things can get so complicated

  • kris_margett Level 1 Level 1

    if you right click, even on a graphics tablet, you can add song to playlist. i'm using a bamboo

  • CyberNorris Level 1 Level 1

    Thanks for this info. I too have and love my older graphire3 .. am on the third mouse for it.

     

    I grabbed an Apple bluetooth mouse and was able to drag within iTunes. This confirms the problem is related to the Wacom. However something changed in iTunes or the OS to make the problem appear.

  • bradkaye Level 1 Level 1

    so glad I found this discussion, this was driving me mental.

     

    thanks kris, I can right-click to get by for now.

  • askii Level 1 Level 1

    Thanks s. luke - intuos 4 user here, and like everyone else this issue was driving me to drink.

     

    I have found that about half of the time I have success if I grab multiple items (all the tracks of an album say) and drag DOWNWARD before dragging to playlists - that way I get the icon with the number of items I'm dragging and it works.

     

    No luck with single tracks though. Let's hope Apple & Wacom work something out soon.

     

    There was a recent fix for Ableton Live which wasn't handling Wacom devices properly - the pen was *kinda* acting like a scroll wheel, you couldn't grab and drag, faders and knobs would just go right up and down when you grabbed them. The fix was a simple as creating and adding -AbsoluteMouseMode to a txt file to the Live prefs folder.

     

    Just had a hunt for something similar for iTunes, but no such luck.

  • ralphfromredlands Level 1 Level 1

    I am having the same problem. Both my macs have wacom Intuos 3's. Seems that this the problem I guess.

  • ishtarstar Level 1 Level 1

    I just upgraded to itunes 10.4.1 today and now I cant use my mouse to drag songs into playlists. I can right click, add to playlist etc but that is ridiculously time consuming. I have also worked out that I can use the pad on my macbook to drag and drop. Why cant I use my mouse anymore? I have reset my mouse but still no success.

    I really dont understand. Upgrading is risky business. Why is a simple function suddenly become difficult. Help!

  • jonLinder Level 1 Level 1

    ARGH. same problem here. is there any way to copy and paste to another device? i can no longer put music on my ipad or iphone. @#$(*&@(*)&

     

    FIX THIS PLEASE.

  • kdelmal Level 1 Level 1

    This is so annoying!!!!!!! you need to fix this, before I just used to drag the songs to my playlists, now I have to:

     

    Select song
    Press right click
    Go to add to
    Select a playlist

     

    Thanks for making my life more difficultt and my day a lot less productive.

     

    From 1 step to 4 steps... really... thanks Apple!!! #NOT

  • ferretface1 Level 1 Level 1

    I'm using a Cintiq, and I had this happening recently. Maddening.

    I have no useful information to share, however.

  • ellkabong Level 1 Level 1

    I'm having the same problem and don't have any kind of tablet or driver connected.  So it's really a problem with iTunes 10.4.1

  • s. luke Level 1 Level 1

    Well, yes, I think so. I've had problems with Wacom drivers - sometimes it just quits working and I have to plug in a mouse, go out to the login window, and come back in again - but this new behavior is unique to the 10.4x line of iTunes.

     

    I don't know what flim-flam Wacom is up to in their drivers, but I assume it's "legal". (I mean really, all you have to do is listen to what your hardware's doing, and then tell the OS it was really a mouse that did it, right?)

     

    And even if Wacom's driver has been breaking some Apple-issued rules, wouldn't that affect the entire OS? I can't figure out why the only thing to break would be an application like iTunes, rather than the entire system.

  • ellkabong Level 1 Level 1

    The problem is occuring WITHOUT any Wacom or other devices or drivers connected too.

Previous 1 2 Next