5 Replies Latest reply: Jul 23, 2011 3:48 PM by Sproctor61
Sproctor61 Level 1 Level 1 (0 points)

I used to run a program on port 8080 when I was running Lep Server.  It won't run on Lion.  It looks like something else is already running on port 8080 on Lion. When I point Safari to it I get a login box with:

 

"To view this page, you must log in to area “Subscription” on www.mydomain.com:8080."

 

If I login, all I get is a blank page.  What is this and how do stop it??

 

Thanks


iMac, Mini, MBPro/Air, iPhone/iPad, Mac OS X (10.7)
  • dreness Level 1 Level 1 (30 points)

    Hi,

     

    You can try the following Terminal command to see what's listening on port 8080:

     

    sudo lsof -i -nP | grep "8080 (LISTEN)"

     

    The first part of the result is the name of the process (program) that is listening on port 8080.

     

    If the name is 'httpd':

    This probably refers to Apache, the built-in web server. Check to see if web service is enabled in Server.app. If you believe the built-in web service should be disabled, but appears to be running anyway, you can try:

     

    sudo apachectl stop

     

    which should stop any httpd processes. Reboot to make sure it sticks. If it doesn't stick, that means some other web-based service thinks it should be running. In Lion Server, there are various services that want Apache to be enabled, including Web, Wiki, Profile Manager, iCal Server (for /webcal), and Mail (if webmail is enabled). Try running the following command and report back with the results:

     

    sudo webappctl status -

     

    anything other than 'empty array' means the server believes some web services are configured to be enabled.

     

    If the name is NOT 'httpd':

    This probably refers to some software you have installed. How you deal with this depends on the nature of the software in question. You can try using Activity Monitor to terminate the process (be sure to set it to view All Processes), but the process may be automatically restarted if it was configured that way. If so, you'll have to undo that configuration, perhaps by removing the associated LaunchDaemon from /Library/LaunchDaemons and rebooting.

     

    HTH,

    -dre

  • eforbell Level 1 Level 1 (0 points)

    By default, tomcat, a java application server will operate on port 8080 (see /Library/Tomcat).

  • Sproctor61 Level 1 Level 1 (0 points)

    Looks like its Jabber!

     

    APNBridge   115        _jabber    5u  IPv4 0xffffff800e559320      0t0    TCP *:8080 (LISTEN)

     

    Now how do I change it lol.  I want my port 8080 back

     

    Steve

  • dreness Level 1 Level 1 (30 points)

    Not exactly, but close

     

    APNBridge is the process that brokers the new Apple Push Notification Service (APNS), which can be used to deliver push notifications to iOS devices. APNS is now included in addition to the previously available XMPP (jabber) push notification protocol.

     

    APNBridge needs to accept connections on 8080 in order to set up APNS with clients.

     

    Check to see if APNS is enabled by looking in Server.app for your computer under "Harware" in the sidebar. In the Settings tab, there is a checkbox called "Enable Apple push notifications". If it's checked, uncheck it. If it's not checked, try enabling it and then disabling it again. If that still doesn't work, you can try manually unloading the APNBridge process as follows:

     

    sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.APNBridge.plist

     

    Please note: Server.app is the only true safe way to enable or disable APNS, because part of this process involves adjusting the configuration of other services which can use APNS. Manually enabling or disabling the APNBridge job using launchctl *does not* adjust other service configurations, so this should only be used as a last resort for disabling APNBridge, if you're sure you don't want it.

     

    HTH,

    -dre

  • Sproctor61 Level 1 Level 1 (0 points)

    That did it.  Thank You

     

    Steve