9 Replies Latest reply: Apr 27, 2012 8:48 AM by ZAndersonFilm
mlx395 Level 1 Level 1 (0 points)

Just got a new iPad 2, wi-Fi turned on, detects my home network, but after typing in password, clicking Join, receive message Unable to join the network "home". Any help would be appreciated.


iPad 2
  • 1. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    gbullman Level 2 Level 2 (295 points)

    I have a Linksys wireless router and find that I have to restart it (pull power, wait a few seconds and plug it back in) fairly frequently because I get behavior like you're describing with both my iPhone and iPad 2.  Before going to crazy with other fixes I would restart your wireless router and restart your iPad 2.  Then if it still doesn't work you'll need some other trouble shooting steps.

     

    Some of the more obvious things to check;

    1) Does the wireless router have Mac Address filtering turned on, if yes is your iPad 2 permitted to join

    2) Do other devices connect to this wireless with no problems?

    3) Any chance the password didn't get typed in correctly?

  • 2. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    mlx395 Level 1 Level 1 (0 points)

    Thanks for the reply. I have a Linksys wireless router too. Tried restarting both the router & the iPad 2 and still no go. How do I find out if the router has Mac Address filtering turned on?

     

    I have a laptop PC that connects to the router with no problems.

     

    Tried the password several times, just to make sure, so it did get typed in correctly.

  • 3. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    gbullman Level 2 Level 2 (295 points)

    Someone would have turned on MAC Address Filtering since it is off by default.

     

    To see if it is on log into your router with your PC, click on Wireless on the upper set of menus, then click on MAC Address Filter and see if is Enabled.  If it is Enabled add your iPad's WiFi address from settings->General->About to the list.

     

    If it is not Enabled you could try changing the Wireless Channel on the wireless Basic settings. If you have any other WiFi devices that are on the default channel (6) you might possibly have some interference issues.

     

    One last thing, have you successfully connected this iPad to any WiFi networks? If not try another network & if that doesn't work either make a Genius appointment and get it looked at by apple.

  • 4. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    mlx395 Level 1 Level 1 (0 points)

    Thanks again for your response. I ended up chatting with Apple Support, and they told me how to log into my router with my PC (which I can't seem to do again for some reason - doesn't like the user name & password now). Anyway, I turned off MAC address filtering, and now both the iPad and iPod Touch are able to acces the network. I read in the documentation for Network Magic (came with my router) that the Network  Lock feature, turns on MAC address filtering within the router, so that's how it got turned on.

     

    Only thing is, now the Network Lock is off. I would like to turn it back on, but since I can't seem to get back into my router using my PC, I wouldn't be able to add the iPad's WiFi address.

  • 5. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    gbullman Level 2 Level 2 (295 points)

    I just went through this with a wireless access point (couldn't log into it for administration).  On Linksys if you press and hold the reset button for 10 seconds it sets the router back to factory settings.  At that point you can log in and set it up either through the web interface or Network Magic.  I would think that Network Magic gives you some way to add MAC addresses.

     

    I've always just used the web interface (192.168.1.1, no user, default password is admin after a reset to factory settings).  Most of what you'll want to set up is on the Wireless set of tabs.  Also change the default password since the factory one is common knowledge.

  • 6. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    mlx395 Level 1 Level 1 (0 points)

    I can't thank you enough for all your help!! Before going through the process of re-setting the router, I decided to turn the network lock back on using Network Magic. Lock is on, network is protected (WPA2) and all devices are still able to access the network.

     

    Network Magic has an Add a Device option, which I used to add the iPad and iPod Touch. I am thinking it is pretty much the same thing as going through the web interface to add MAC addresses, just more user friendly (for me anyway).

     

    I have saved our "conversation", so I can refer back to all the great info if the need should arise again.

     

    THANK YOU so much for taking the time to help me....YOU ROCK!

  • 7. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    gbullman Level 2 Level 2 (295 points)

    I would agree that Network Magic is probably just a somewhat more user friendly interface than the web configuration.  The only reason I tend to shy away for things like that is they install software on your PC that has stuff running all the time to detect the router on the network.  Not a huge deal, I just like to keep what is running on any of my computers to a minimum.

     

    You're definitely welcome for the help, glad you got straightened out.

  • 8. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    Ola007 Level 1 Level 1 (0 points)

    I had the same problem and notice it wasn't assigning a DHCP IP  address to my wireless devices, so had to remove wireless WPA security and then got the DHCP IP assigned and then went back and  added WPA wireless security.

  • 9. Re: iPad 2 Unable to join the network "home". Any help would be appreciated.
    ZAndersonFilm Level 1 Level 1 (0 points)

    Hey Guys,
    I had a problem also. 

    I restarted my router, nothing.  Changed the brightness, try to add the network 15 times, did the "Other" network solution...nothing.  I woke up and it still didn't work. 

    I decided to turn off my printer, and restart all my other computers. BOOM!  It fixed it.   I usually don't sign intot these forums to address solutions, but this was frustrating and I hoped it helps for you guys.