Skip navigation

How to stop Safari reopen on last page

87845 Views 62 Replies Latest reply: Feb 27, 2014 12:01 PM by stevefromwoodhaven RSS
1 2 3 ... 5 Previous Next
rshillington Calculating status...
Currently Being Moderated
Jul 23, 2011 11:32 AM

When I quit Safari, and then reopen it, it returns to the last page viewed, and not to the Top Sites view, as I have configured in Preferences.  Is this part of the new Resume feature of Lion, and if so, how do I turn that off?

MacBook Pro, Mac OS X (10.7)
  • leroydouglas Level 6 Level 6 (13,415 points)
    Currently Being Moderated
    Jul 23, 2011 11:38 AM (in response to rshillington)

    >Sys Pref>General> 'Restore windows when quitting and re-opening apps' check box

     

     

    You can also hold the option key when you use the Quit from the dropdown menu.

  • NoJob Calculating status...
    Currently Being Moderated
    Jul 23, 2011 12:33 PM (in response to leroydouglas)

    I'm seeing Safari re-open on boot with the last pages viewed, and no, the box "Restore windows when quitting and re-opening apps" isn't checked.  It seems to have nothing to do with this issue.  Good try, tho, leroydouglas.

     

    I don't want to see the pages I last had open, I just want to see one tab with my homepage open  when I boot up my computer.  For some reason, even tho I turned Extensions off when I first started up Mac OS Lion, (and I never downloaded any extensions to begin with), it's acting like I have installed SafariRestore (judging by what that "extension" says it does).

  • ckelly176 Calculating status...
    Currently Being Moderated
    Jul 23, 2011 12:41 PM (in response to NoJob)

    Is Safari opening up when you boot by itself?  There are many people reporting the same thing about Safari and it usually has to do with Lions feature to resume applications where they left off when closing them down, which is why leroydouglas suggested turning it off.

     

    Since you have disabled extensions in Safari do you by chance had the add-on Glims installed in Safari?

  • NoJob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 12:46 PM (in response to ckelly176)

    Safari is opening up when I boot, yes, by itself.  I unchecked the box leroydouglas suggested (a friend on another message board told me about it), but it has no effect.  If Safari is open when I shut down the computer, when I next boot up, Safari re-opens to the same pages that were open when I turned the computer off.  Restarting also sees Safari re-open as soon as the re-boot is complete.

  • NoJob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 12:49 PM (in response to NoJob)

    HAHA!  I just found it!

     

    When you go to shut your computer off or restart, there is now a box that says "Reopen windows when logging back in".  It is currently checked, and although I unchecked it and hit "Cancel" it was checked when I next tried to do a restart.  I'll uncheck and restart and see if it stays unchecked.

     

    BTW, this is a stupid thing to have in the Restart or Shut Down confirmation box, and should just be an option you can set in System Preferences.

  • NoJob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 12:54 PM (in response to NoJob)

    Well, that stopped Safari from re-opening immediately on reboot, but it doesn't prevent Safari from opening with all previously open pages once you DO open Safari.  In other words, I shut down with 3 tabs in Safari, and when I reopened Safari, all 3 of those tabs with the appropriate pages opened.

     

    This is a feature I really don't need or want.  I just want to see my home page on a single tab when I open Safari.  I'll open new tabs as I need them each session.  I shouldn't have to close all tabs before I shut down my computer; I'm shutting it down and it should be a given that I'm done with whatever browsing I was doing at the time.

     

    Oh, and the box in the shut down confirm window is checked again.  It doesn't stay unchecked.

  • NoJob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 1:00 PM (in response to NoJob)

    This is a really poorly thought out feature.  I do not want this, I can't turn it off, and I bet I can't get a refund and go back to Snow Leopard, can I?

  • ckelly176 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Jul 23, 2011 1:06 PM (in response to NoJob)

    There has to be something else going on. On the two systems that I have they do not behave the same way as yours is. You said that you have extensions turned off, do you have anything like Glims installed for Safari?

  • Thebestplacehere Level 3 Level 3 (700 points)
    Currently Being Moderated
    Jul 23, 2011 1:58 PM (in response to rshillington)

    If you close all windows and you quit safari when open again it open what you configure because you haven't open windows when quit so you no using the feature..I mean which windows you want it to open if you haven't any.It can't open what you thinking is why the option to choose the new window to open..

  • NoJob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 23, 2011 1:56 PM (in response to ckelly176)

    No.  I don't even know what Glims is.  I've never downloaded an extension, and didn't even know of them until yesterday (after I installed Lion I saw it under Safari Preferences and imediately turned it off).

  • Thebestplacehere Level 3 Level 3 (700 points)
    Currently Being Moderated
    Jul 23, 2011 1:59 PM (in response to rshillington)

    Anyway i think your answer is there so mark it like correct..

  • strakagirl Calculating status...
    Currently Being Moderated
    Jul 23, 2011 7:45 PM (in response to rshillington)

    Try Option-Command-Q when exiting Safari. When you reopen, it should give you just your homepage.

  • markfalta Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jul 26, 2011 8:40 AM (in response to rshillington)

    Here's the solution to force Safari to start clean everytime:

     

    Go to terminal and type in the following:

     

    defaults write com.apple.Safari ApplePersistenceIgnoreState YES

     

    If you decide that you rather have the new resume behavior, execute the above commands but change YES to NO.

     

    You can also do the same for Preview:

     

    defaults write com.apple.Preview ApplePersistenceIgnoreState YES

1 2 3 ... 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.