11 Replies Latest reply: Jun 28, 2012 5:18 PM by Barry
Lita Kaufman Level 5 Level 5 (5,315 points)

In one of my Pages installs, I have strange autocorrect problems.  "Couldn't" automatically becomes "could't" and "hadn't" becomes "had't".  I've found that if I type "couldnt" it corrects properly to "couldn't" and doesn't recorrect.  Same thing with "hadn't" - there seems to be a glitch in the dictionary.  Any idea how I can fix this?

  • 1. Re: how do I fix incorrect autocorrect?
    fruhulda Level 6 Level 6 (15,110 points)

    No, we don't. It is in the spellchecking dictionary, not ín the Auto-correction though. You could use The Auto-corection in Pages preferences to change had't to hadn't when you write.

  • 2. Re: how do I fix incorrect autocorrect?
    Level 8 Level 8 (41,760 points)

    Would be useful to give more informations.

     

    (1) which is the running operating system ?

    OSX 10.5.8, 10.6.8, 10.7 or iOS

     

    (2) which is the exact Pages version in use ?

    for OSX, 4.0.5 or 4.1

     

    Here, running Pages 4.1 under OSX 10.6.8, I got :

    2011_07_24b.jpg

     

    As you see, hadn't behave wrongly but not as you described,

    couldn't is well treated.

     

    Yvan KOENIG (VALLAURIS, France) dimanche 24 juillet 2011 10:55:19

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8


    Please : Search for questions similar to your own before submitting them to the community

     

    To be the AW6 successor, iWork MUST integrate a TRUE DB, not a list organizer !

  • 3. Re: how do I fix incorrect autocorrect?
    fruhulda Level 6 Level 6 (15,110 points)

    Does that mean you can't Save as iWork '08 any more???

  • 4. Re: how do I fix incorrect autocorrect?
    Level 8 Level 8 (41,760 points)

    Hi Fruhulda, I guess that this question is not in the wanted thread

     

    As I wrote already three times, under Lion, the Save As… feature is replaced by:

     

    File > Duplicate

    cmd + S

    Doing that we reach the dialog which was reached thru Save As…

     

    Just a different way to do the same thing.

    I guess that it's required to freeze temporarily the autosave process.

    I will look a that closely this afternoon.

     

    Yvan KOENIG (VALLAURIS, France) dimanche 24 juillet 2011 12:39:38

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8


    Please : Search for questions similar to your own before submitting them to the community

     

    To be the AW6 successor, iWork MUST integrate a TRUE DB, not a list organizer !

  • 5. Re: how do I fix incorrect autocorrect?
    Kenneth Collins1 Level 1 Level 1 (5 points)

    I am using Pages 09, fully updated, in Lion. There is no version of English in which hand't and would't are words. Pages ruins any word that ends in n't, rendering the entire, otherwise desirable, feature totally useless. There's a feature fight. Check Spelling knows that Auto Correction is misspelling the words!

     

    Where are these things stored so we can fix them manually?

     

    Question in case an Apple employee trolls this page:

     

    Apple is a quality-conscious company that has had plenty of time to find and fix this ridiculous problem. Where is the update?

  • 6. Re: how do I fix incorrect autocorrect?
    Level 8 Level 8 (41,760 points)

    I apologize but on my machine, the hadn’t, wouldn’t forms aren't killed.

    They are accepted flawlessly.

    What I feel odd is that hand’t is accepted too.

     

    I enlarged the words to highlight the fact that I use the curly quote.

     

    Yvan KOENIG (VALLAURIS, France) vendredi 16 décembre 2011 11:04:18

    iMac 21”5, i7, 2.8 GHz, 12 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.2

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

     

  • 7. Re: how do I fix incorrect autocorrect?
    Michael Force Level 1 Level 1 (35 points)

    I just discovered this peculiar issue yesterday, and the thread here seems to have reached a dead end. I only recentlly upgraded to Lion 10.7.3 on my 15" MacBook Pro (early 2010) model, running the latest version of Pages 4.1(923) and was astonished at how infuriating it was. An incorrect auto-correct? How ludicrous! The issue as far as I can tell is unique to Pages as I can't seem to replicate it in Mail or TextEdit.

     

    So everyone is certain there is no way to access the system-level auto-correction files to fix this, or do we have to wait for Apple's iWork 2012? 2013?

     

    regards

  • 8. Re: how do I fix incorrect autocorrect?
    Trovki Level 1 Level 1 (0 points)

    Go to Pages/Preferences; then uncheck "Automatically use spell checker suggestions."

     

    Hope that works for you.

    Good luck with your writing endevours,

     

    Trovki

  • 9. Re: how do I fix incorrect autocorrect?
    Kenneth Collins1 Level 1 Level 1 (5 points)

    That's more like killing the patient instead of curing him. There ought to be a way to fix the feature instead of excising it.

  • 10. Re: how do I fix incorrect autocorrect?
    Michael Force Level 1 Level 1 (35 points)

    Thanks for the input. As far as I can tell, there's no fix. I got around it by putting the corrections for  incorrect auto-corrects in the substitions list found in the text tab of the "Language and Text" System Preferences pane. So when Pages inserts an incorrect auto-correct, another feature of the operating system fixes it. It works. But...it's stupid that one has to do this in the first place. The fairly recent release of Lion 10.7.4 unfortunately doesn't address this problem. iWork is getting pretty long in the tooth and is in desperate need of a complete update. When??

     

    Michael

  • 11. Re: how do I fix incorrect autocorrect?
    Barry Level 7 Level 7 (29,180 points)

    Hi Kenneth,

     

    No way of correcting the  issue, but there is a workaround.

     

    The spellchecker recognizes the single quote (which you're using as an apostrophe) as an 'end-of-word' marker and immediately checks the spelling of the "word". If you have "automatically use spell check suggestions" that action occurs immediately, and the non-word "hadn" is replaced with the most likely correction, "had", with the end-of-word marking single quote left intact, even after you add the "t".

     

    The workaround is to 'teach' the spelling dictionary to accept several incorrect spellings as 'acceptable words'.

     

    Turn off the "automatically accept" spelling option.

    Open a new document, type "hadn hasn couldn" etc.

    Then check spelling.

     

    The spellchecker will stop at each of the 'words', offer suggestions, and wait for your input. Click the Learn button for each 'word'.

     

    When done, you should be able to safely turn the automatic substitution on again. The partial words will be accepted, allowing you to complete the word without triggering auto substitution.

     

    Regards,

    Barry