9 Replies Latest reply: Sep 4, 2011 12:09 AM by llendogg
MarkPek Level 2 Level 2

Hi all,

 

Watching a Netflix movie, if I click on "full screen," I get nothing -- just a stutter.  If I do it a couple of times, eventually the screen goes black but I continue to get the movie's audio.  I've updated, uninstalled and reinstalled Silverlight, and I just can't get this to work.  Haven't had any problems before the Safari update.  Any ideas?  Thank you!


MBP 15" i7, 2.8GHz, hi-res, non-glare, Mac OS X (10.6.6), iPod Touch 4G, iPod Nano 5G, Aperture 3.1.1
Solved by MarkPek on Aug 1, 2011 6:41 PM Solved

Go to System Preferences > Hardware > Energy Saver.  It's at the very top and therefore easy to overlook.

  • Carolyn Samit Level 10 Level 10
    expertise.safari
    Safari

    If you have any extensions installed, Safari / Preferences - Extensions. Turn that off, quit then relaunch Safari. Try Netflix.

     

    If it's not an extensions conflict, reset Safari from the menu bar, select the top 7 buttons, click Reset.

  • MarkPek Level 2 Level 2

    Hi.  Thanks for your effort, but that didn't work.  I don't have any extensions, and the reset didn't get rid of the problem (though I did lose a lot of stuff in the process).

     

    Does anyone have any other ideas?

  • MarkPek Level 2 Level 2

    Am I really the only one with this problem?  I've also noticed that it won't play in HD anymore.  Anyone?

  • MarkPek Level 2 Level 2

    Well, unchecking "automatic graphics selection" seems to solve the full-screen and the HD problems, but I'm not sure I'm happy with that solution . . . .

  • rachel_k Level 1 Level 1

    I'm having the same problem... Where is it that I'm supposed to uncheck the "automatic graphics selection"?

  • MarkPek Level 2 Level 2

    Go to System Preferences > Hardware > Energy Saver.  It's at the very top and therefore easy to overlook.

  • rachel_k Level 1 Level 1

    Thanks!

     

    Though it looks like the problem was miraculously fixed—full screen is working again without my doing anything...

  • fulofunk Level 1 Level 1

    Thanks MarkPek, this solved my "full screen" problem with Netflix.

     

    'Go to System Preferences > Hardware > Energy Saver...uncheck the "automatic graphics selection" '

     

    MacBook Pro 15" 2010. OS 10.6.8. Silverlight Version 4.0 (4.0.60531.0)

     

    I had the same problem while watching Netflix instant play. Started after my most recent OS update.  I click "full screen" once, nothing but a quick pause, then back to same screen as before. Click "full screen" again and screen blacks out, though audio continues. Netflix site was no help unless I called (which I didn't ) - I searched their site for 20 minutes and still unable to find any mention of others with same problem nor was I able to navigate to a window where I could explain the problem. Very frustrating, but glad for the support found here

  • llendogg Level 1 Level 1

    Yes great! I got my full screen back....only now I don't have any sound (netflix or hulu)

     

    Help!