1 2 3 Previous Next 37 Replies Latest reply: Dec 26, 2013 9:19 PM by pfkellogg Go to original post Branched to a new discussion.
  • 15. Re: Lion Silverlight and Netflix oh my
    *nickMcC* Level 1 Level 1 (0 points)

    Also the memory usage in Lion seems to be extremley high. Is this the same for everyone else?

  • 16. Re: Lion Silverlight and Netflix oh my
    prajnaji Level 1 Level 1 (20 points)

    Mine has too.

     

    Sometimes my processor just goes off the charts as well.

     

    I have also found that the finder preview feature on h264 quicktimes won't run in real time. Stutters really bad. Ugh. Huge issue for me currently.

  • 17. Re: Lion Silverlight and Netflix oh my
    *nickMcC* Level 1 Level 1 (0 points)

    I think I have found a work around. With two ways or both

     

    1. Go to System Preferences-> Energy Saver -> Switch it from Battery Life to High performance.

     

    This turns off the GPU switching which for me is a NVIDIA 9400m to 9600m gt . So basically now the battery will drain tons faster but it is stable. I got through three episodes of Breaking Bad lastnight wih Zero crashes.

     

    2. Get GfxStatus program @ http://codykrieger.com/gfxCardStatus

              This allows you to set which GPU is running and to allow it to switch or not. So a good test is to leave the Battery Life on and see if the switch and crash happen at the same or close times.

     

    FYI this does not help with the memory consumption, that is a LION problem that may never be fixed. Maybe it is efficent maybe its not. I do know Virtualbox ***** on this compared to SL.

     

    Good luck!

  • 18. Re: Lion Silverlight and Netflix oh my
    leonardo87 Level 1 Level 1 (0 points)

    I`m having the same problem,

    i use safari, firefox and chrome, all browser in their last updates, including silver light,

    and i can't watch nothing in netflix, and all browser is configurate like thay say that is correctly. when i call there, they say the problem is with apple! and now, Apple?

  • 19. Re: Lion Silverlight and Netflix oh my
    TheSmokeMonster Level 4 Level 4 (3,240 points)

    Leonardo, something else is wrong with your setup. it could be your internet service provider. have you tried clearing your cache?

  • 20. Re: Lion Silverlight and Netflix oh my
    leonardo87 Level 1 Level 1 (0 points)

    yes man, i've tried everything... =/ nothing with the three browsers.. my mac ox is 10.7.2.

  • 21. Re: Lion Silverlight and Netflix oh my
    TheSmokeMonster Level 4 Level 4 (3,240 points)

    can you give me more information of what is happening and what you are seeing and what you've already done?

  • 22. Re: Lion Silverlight and Netflix oh my
    BaronIstefan Level 1 Level 1 (0 points)

    Hi, I have the exact same issue.  I was watching Netflix and it asked me to upgrade from v4 to v5 of Silverlight.  Now nothing works in Silverlight and each browser just shows that the plugin has crashed.  I have deleted the files for Silverlight on several occassions, deleted caches, restarted the computer several times and it still will not work.  Reinstalling v4 Works fine, but Netflix will not let me watch using the older version of the plugin.

     

    I have a Mac Pro (Server) 2009 with 1 Quad Core 2.66 GHz Xeon, 8 GB 1033 DDR3 RAM, 2 Monitors, 2 NVidia GT 120 graphic cards running OSX 10.7.2.

     

    Process:         plugin-container [1066]

    Path:            /Applications/Firefox.app/Contents/MacOS/plugin-container.app/Contents/MacOS/pl ugin-container

    Identifier:      org.mozilla.plugincontainer

    Version:         ??? (1.0)

    Code Type:       X86 (Native)

    Parent Process:  firefox [958]

     

     

    Date/Time:       2012-01-23 16:04:54.986 -0500

    OS Version:      Mac OS X 10.7.2 (11C74)

    Report Version:  9

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

     

     

    VM Regions Near 0:

    --> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/Firefox.app/Contents/MacOS/plugin-container.app/Contents/MacOS/pl ugin-container

        __TEXT                 0000000000001000-0000000000002000 [    4K] r-x/rwx SM=COW  /Applications/Firefox.app/Contents/MacOS/plugin-container.app/Contents/MacOS/pl ugin-container

     

     

    Application Specific Information:

    objc[1066]: garbage collection is OFF

     

     

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

    0   com.microsoft.SilverlightPlugin          0x0697f063 XcpFlatAllocate + 10867

    1   com.microsoft.SilverlightPlugin          0x06f88641 StylusPointCollection_InsertItem + 493441

    2   com.apple.QuartzCore                    0x9111bb85 _ZL17CAOpenGLLayerDrawP13CAOpenGLLayerdPK11CVTimeStampj + 378

    3   com.apple.QuartzCore                    0x9111b842 -[CAOpenGLLayer _display] + 416

    4   com.apple.QuartzCore                    0x910eaff5 CA::Layer::display() + 223

    5   com.apple.QuartzCore                    0x910eaf11 -[CALayer display] + 20

    6   com.apple.QuartzCore                    0x910e2aec CA::Layer::display_if_needed(CA::Transaction*) + 670

    7   com.apple.QuartzCore                    0x910e1883 CA::Context::commit_transaction(CA::Transaction*) + 427

    8   com.apple.QuartzCore                    0x910e1594 CA::Transaction::commit() + 266

    9   com.apple.QuartzCore                    0x910e13f8 +[CATransaction commit] + 32

    10  XUL                                     0x010832bd nsCARenderer::SetupRenderer(void*, int, int) + 1389

     

     

    Thread 1:: Dispatch queue: com.apple.libdispatch-manager

    0   libsystem_kernel.dylib                  0x97dce90a kevent + 10

    1   libdispatch.dylib                       0x95846c58 _dispatch_mgr_invoke + 969

    2   libdispatch.dylib                       0x958456a7 _dispatch_mgr_thread + 53

     

     

    Thread 2:

    0   libsystem_kernel.dylib                  0x97dcbc22 mach_msg_trap + 10

    1   libsystem_kernel.dylib                  0x97dcb1f6 mach_msg + 70

    2   XUL                                     0x00048cdb catch_exception_raise + 2283

    3   libsystem_c.dylib                       0x9b1646de thread_start + 34

     

     

    Thread 3:

    0   libsystem_kernel.dylib                  0x97dce02e __workq_kernreturn + 10

    1   libsystem_c.dylib                       0x9b162ccf _pthread_wqthread + 773

    2   libsystem_c.dylib                       0x9b1646fe start_wqthread + 30

     

     

    Thread 4:

    0   libsystem_kernel.dylib                  0x97dce90a kevent + 10

    1   XUL                                     0x0101d0e0 nsXPTCStubBase::Stub249() + 91160

     

     

    Thread 5:

    0   libsystem_kernel.dylib                  0x97dce02e __workq_kernreturn + 10

    1   libsystem_c.dylib                       0x9b162ccf _pthread_wqthread + 773

    2   libsystem_c.dylib                       0x9b1646fe start_wqthread + 30

     

     

    Thread 6:

    0   libsystem_kernel.dylib                  0x97dcd83e __psynch_cvwait + 10

    1   libsystem_c.dylib                       0x9b164e21 _pthread_cond_wait + 827

    2   libsystem_c.dylib                       0x9b11542c pthread_cond_wait$UNIX2003 + 71

    3   com.apple.CoreServices.CarbonCore          0x99fbff36 TSWaitOnCondition + 124

    4   com.apple.CoreServices.CarbonCore          0x99f31579 TSWaitOnConditionTimedRelative + 136

    5   com.apple.CoreServices.CarbonCore          0x99f92dfe MPWaitForEvent + 296

    6   com.microsoft.SilverlightPlugin          0x06993238 wcscat + 48056

    7   com.microsoft.SilverlightPlugin          0x06c6825c CreateMediaSourceFromStream + 33724

    8   com.microsoft.SilverlightPlugin          0x06993720 wcscat + 49312

    9   libsystem_c.dylib                       0x9b160ed9 _pthread_start + 335

    10  libsystem_c.dylib                       0x9b1646de thread_start + 34

     

    Thanks!

  • 23. Re: Lion Silverlight and Netflix oh my
    TheSmokeMonster Level 4 Level 4 (3,240 points)

    Hey Baron! please file this with apple http://bugreport.apple.com

  • 24. Re: Lion Silverlight and Netflix oh my
    claas kuhnen Level 1 Level 1 (0 points)

    Hi there

     

    I also had the issue that Netflix loaded the Silverlight plug-in showed the image but did simply not play the movie.

     

    I followed MS advice to uninstall SL manually by removing it from Library/Internet Plug-ins

    and then reinstalling.

     

    However the error never went away.

     

    I tried to install SL 3 and it told me a newer version was present which gave me the impression SL 5 was not 100% removed. Searching the web a but I found this thread:

     

    /private/var/db/receipts:

com.microsoft.installSilverlightPlugin.bom

    com.microsoft.installSilverlightPlugin.plist

    com.microsoft.installSilverlightPluginDebugApp.bom

    com.microsoft.installSilverlightPluginDebugApp.plist

    com.microsoft.installSilverlightPluginDebugFiles.bom

    com.microsoft.installSilverlightPluginDebugFiles.plist

    Remove all those files and it will propably work now.

    I installed SL3 which worked after a restart then Netflix wanted to update to SL5 which I did and all runs smooth again.

     

    MS great job - what a garbage.

  • 25. Re: Lion Silverlight and Netflix oh my
    claas kuhnen Level 1 Level 1 (0 points)

    OMG MS or Apple must be kidding me.

     

    I just realized that when under OS X Lion I switch from speaker to USB headphone Netflix/Silverlight stops playing the movie. The moment I switch back to speakers it runs.

     

    This is pathetic and I start getting the feeling this might be an issue with Apple as their USB AUdio drivers also do not work with Skype anymore.

  • 26. Re: Lion Silverlight and Netflix oh my
    claas kuhnen Level 1 Level 1 (0 points)

    UPDATE:

     

    To make Skype run via USB Audio on Lion you could use the MIDI input and change the frequency to 16 KHz.

    However this produces an issue with Silverlight.

     

    I switched back to 32 KHz and SL runs fine again.

     

    OMG.

  • 27. Re: Lion Silverlight and Netflix oh my
    jmpsfs Level 1 Level 1 (10 points)

    Thanks for this. I spent an hour on the phone with Apple Customer Care discussing the Silverlight problem, and the tech finally gave up and told me to contact Microsoft.

     

    I switched the audio output from my Logitech USB headset to the internal speakers and Netflix came back to life.

     

    Now I guess I'll get back on the phone with Apple to see how to reconfigure the headset so it will work with video. Another PITA problem, but at least the video is moving again.

     

    John Pearce

    Sarasota, FL

  • 28. Re: Lion Silverlight and Netflix oh my
    grouver Level 1 Level 1 (0 points)

    This has been tested and confirmed solution on 10.7.3

     

    If you are having problems with Silverlight staying in full screen on your secondary display then something bad has happened to your preference files. Anyway long story short the fastest and easiest way is to remove Silverlight and ALL the preference files and reinstall it. If everything has gone as it should, at that point you will be prompted if you want to permit Silverlight to stay in full screen mode. You should do so and after that your problems will be solved. As to the high RAM usage and CPU load while playing Netflix in high def there really isn't anything you can do. Silverlight does suport hardware acceleration, however that is only in Windows 7 SP1 + and only in IE9. As to the amount of RAM, Silverlight on OS X is 32 bit (even version 5) and unfortunatelly that means loading additional libraries in Safari and RAM usage does go up. That said, on a MBP mid 2010 with a 2.4 Ghz Core i5 CPU, it runs without a hitch and does not really affect the performance of the other Applications. Silverlight does however use about 50% of one of the cores so on an older machine, that would be a serious.

     

    Ok here's what you need to delete

     

    • /Library/Internet Plug-Ins/Silverlight.plugin
    • /Library/Receipts/Silverlight.pkg
    • /Library/Receipts/Silverlight_W2_MIX.pkg
    • /Library/Internet Plug-Ins/WPFe.plugin
    • /Library/Receipts/WPFe.pkg
    • "/Applications/Microsoft Silverlight.app"

     

    You can do this by using sudo rm -rf <one of the above> but you probably shouldn't since you can easily delete something by mistake and the OS will not even give you a warning, or you can use Finder to navigate to the locations and delete the files by moving to Trash. You will be asked for a password (your own) and also, since it's Lion, you will have to use Cmd+Shift+G and then paste the location.

     

    One last thing, some of the above might not exist which is alright. Some were removed in latter versions of Silverlight so don't worry.

     

    Oh and Microsoft suggests that Silverlight does not work in Chrome on OS X ... that is false! You might however, have flaky performance in the beta or developer versions so stick with stable.

  • 29. Re: Lion Silverlight and Netflix oh my
    Unknown Citizen Level 1 Level 1 (15 points)

    I haven't had any issues running Silverlight, it's just frustrating that all the fans turn on once I try to run Netflix using the silverlight plugin.  The same is true with flash of course.  I'm just waiting for web developers to adopt HTML5 already and ditch these plugins that tax the system so heavily.