6 Replies Latest reply: Jul 26, 2011 5:19 AM by Karlo Facherpour
Karlo Facherpour Level 1 Level 1 (5 points)

I was messing with the two finger swipe in safari where you swipe back and forth for the forward page and backward page with the cool animation. Everything was fine until i found out that this can not be done in Google Chrome or Firefox. So I decided to switch to the three finger swipe and sure enough, the back and forth in those browsers worked like a charm. I was showing off to a buddy and went back to the two finger swipe to show him the animation and how cool and easy it was and the weirdest thing happened. The page would swipe about a quarter of the way and than bounce back. I tried more gesture settings and nothing. I quit safari and rebooted and nothing. I have set every defualt setting and nothing. Is there anyone that would know whats going on? Thanks


MacBook Pro, Mac OS X (10.7)
  • SuperflyTNT Level 1 Level 1 (0 points)

    No fix, Karlo.  Just wanted to mention that the EXACT thing happened to me.  When I use two-finger swipe to go "back" in Safari, the page just bounces back to the current one.  I can see the right previous page when I start to swipe, but the current page just bounces right back preventing my from using this technique to navigate history.

  • SuperflyTNT Level 1 Level 1 (0 points)

    More info - I noticed that when I use quite a bit of velocity to swipe, meaning that I start literally on one end of the keyboard and swipe across the trackpad and well onto the other side of the keyboard, then the pages will in fact move as they're supposed to (forward or backward).  Thing is this is in no way supposed to be normal behavior.  It's like there's a speed caliper on the feature that's set way too insensitive.  Now I'm wondering if this is actually a setting in preferences that somehow got out of whack.  The only setting I can find though has to do with the speed of the arrow pointer, not with the sensitivity of the two-finger swipe to activate. 

  • Karlo Facherpour Level 1 Level 1 (5 points)

    It's something silly buts it's driving me crazy that we can't figure it out. In other Mac forums there are a few people with the same problem but no solutions.  I have a MacBook air so I have compared all setting and everything is normal on the air but it behaves normally. I really don't want to reinstall the os if I don't have to.

  • SuperflyTNT Level 1 Level 1 (0 points)

    Can't explain, but I rebooted and everything works fine... until I fill out a form like this note I'm typing now.  Somehow entering in text into a WYSIWYG box "breaks" the two finger swipe gesture.  Of course when I reboot everything is fine, for the moment at least.  Wish I was more helpful.  Curious if other people see the same behavior - safari and two finger swipe working fine after a fresh reboot until you enter in text into a form or something...

  • gbfluteman Level 1 Level 1 (0 points)

    Go to "System Preferences- Track Pad- Point & Click"  At the bottom of the window pane is a sensitivity bar that you can adjust.  Try messing with that and see if it works.  Also, click on the "More Gestures" tab and see if perhaps something in your swiping gestures got messed up.

     

    Hope that helps!

  • Karlo Facherpour Level 1 Level 1 (5 points)

    I did notice that when i close safari and restart computer, it does go back to normal. I cant figure out for me what triggers the problem