Previous 1 2 3 Next 35 Replies Latest reply: Dec 17, 2012 10:02 AM by CharlesY Go to original post
  • htandra Level 1 Level 1 (0 points)

    It doesn't work even after turning off Greylisting. Did anyone get it to work ? I am running Lion 10.7.2 server.

    Thank you.

  • JeroenPotters(Macpot.nl) Level 1 Level 1 (0 points)

    I didn't test it with 10.7.2 again, but got it to work with 10.7.1. If you like I can help you out with it?

  • htandra Level 1 Level 1 (0 points)

    Hi Jeroen,

     

    Thank you for offering to help, it will be great if i can get it up before the holiday season !!

    I checked my main.cnf file and the greylist is turned off. I created a new filter set set to "reply to all messages"

    and then activated the filter set. I don't see any auto-reply though.

    Please let me know if I am missing something.

     

    Thanks again!!

  • JeroenPotters(Macpot.nl) Level 1 Level 1 (0 points)

    I'll try to powerup my test set-up this week to see if every thing is still running and how its configured.

  • iYom Level 1 Level 1 (0 points)

    This issue is by no means solved.

     

    setting "Reply to all messages" is obviously the solution. but in the current version of Mac OSX Server 10.7.2, you must provide a return address.

    Is there not a generic code to indicate the return address of the message received?

     

    To be continued ...

  • pandine Level 1 Level 1 (10 points)

    I solved that for me by entering the user's own e-mail adress in the list of further addresses. After that the responder answered the incomming messages.

     

    I hope this will help you too.

     

    Regards,

    Thomas

  • iYom Level 1 Level 1 (0 points)

    This is right !!!

     

    It works !!!! 

     

    Regards,

    Guillaume.

  • htandra Level 1 Level 1 (0 points)

    It works for me too !!!!

     

    Thank you.

  • Mike Friedman Level 1 Level 1 (0 points)

    I also found that it's necessary to ACTIVATE the set of filters that you are using, otherwise nothing happens.

     

    I have to say that this is a huge step backwards for something that should be trivial. It was trivial in Snow Leopard and now they've made it hugely difficult to do something simple.

     

    I can't for the life of me fathom why.

  • iBlink Level 2 Level 2 (180 points)

    I got mine to work, just by adding the filter, but it only seems to respond once to each email address that it receives emails from.  let's say I send three emails from the same address throughout the day.  The autoresponse is only sent for the first email and not the other two.  I can send an email from a different email account and I get an autoresponse, but I send another from that same account and there is no response. 

     

    I guess this is fine, but I would like to have the option.

     

    My question is how can I get an autoresponse to every incoming email, even if the emails are from the same account?

     

    My filter:

     

    All Messages

    Reply With Message

  • bsandor Level 1 Level 1 (0 points)

    Is there any hope of vacation notices and settings as easy and user-friendly as in Snow Leopard Server?  My users are not going to want to go through all these steps setting up rules and remembering to turn them on and off, after the easy "pick start date, pick return date, type message, check Enable" of Snow Leopard Server.

  • jorge cristian Level 1 Level 1 (0 points)

    I have noticed in mailaccess.log when a mail arrives to a user with an autoanswer filter active and configured, the part of the system that is responsible for delivering to the user's mailbox folder, which i think is called DOVECOT, puts a log saying

     

    "discarding vacation response for implicitly delivered message; no known (envelope) recipient address found in message headers (recipient=<user@hostname>, and additional `:addresses' are specified)"

     

    and that gave me a hint.

     

    The problem is that DOVECOT does not uses the user's mail address.

     

    After looking a way to correct this I found a line in master.cf, wich is located in /etc/postfix, that says

     

    dovecot   unix  -       n       n       -       25      pipe

      flags=DRhu user=_dovecot:mail argv=/usr/libexec/dovecot/dovecot-lda -d ${user}

    # Use these settings to enable +addressing (user+mailbox@example.com)

    # flags=DRhu user=_dovecot:mail argv=/usr/libexec/dovecot/dovecot-lda -d ${user} -a ${recipient} -m ${extension}

     

    I've added at the end of the flags line what is suggested

     

    -a ${recipient} -m ${extension}

     

    and reloaded postfix master.cf

     

    After that, vacation messages started to be sent.

     

    Hope this helps.

  • feelhip Level 1 Level 1 (0 points)

    I found another approach to set up autoresponder that requires less technical expertise:

     

    - Log on to Lion Server with the account you want to set up an autoreponder for

    - Setup Mail using 'localhost' for IMAP and SMTP servers

    - Setup a rule in Mail to reply to all incoming messages of type "email"

     

    Please be aware that Mail needs to run for this to work. Please also be aware that this is not the way to do - it should be done server-side as previously described, not "client-side on the server". I also wouldn't go this way if you're using POP instead of IMAP.

  • feelhip Level 1 Level 1 (0 points)

    My approach is not working yet - when the screen lock jumps in, Mail on the server does not check mails and as such, no responses are being sent. Playing around with it, will update if I find out more.

  • AIzzard Level 1 Level 1 (5 points)

    Wow! That's the least intuitive thing I've seen Apple do in years.

     

    Yes, apparently to get Roundcube's "Reply with Message" filter to work you must enter the email address of the user who is trying to run the filter (i.e. the person on vacation) into the "Additional list of recipient e-mails (comma separated):" field. Once I did this the auto-reply started working. Go figure.