5 Replies Latest reply: Aug 7, 2011 8:16 PM by ugly__dog
ugly__dog Level 1 Level 1 (25 points)

Hi All,

I think Lion is terriffic, aesthetic disasters aside. Everyting seems to work okay except my Kindle for Mac app.

When I opened it today all the books under the Home tab were present, correct and readable

 

Unfortunately the books in the archived section had all been deleted. I tried re-downloading a couple of them but they did not arrive. I found them elsewhwere on the Amazon site as "pending downloads".

 

The problem does not exist on my iPhone. The archived books are still present.

 

I don't know if it is Lion or Kindle app problem or both of them.

 

Can anyone help?

 

Thanks guys :-)

ugly_dog

  • jamiana Level 1 Level 1 (10 points)

    you need to delete/uninstall it and reacquire it.  even then it is shaky but works.

  • JanBP Level 1 Level 1 (10 points)

    It could be some filepermission problems.

     

    Run repair filepermissions in diskutility.

    Reboot.

    Remove folder ~/library/application support/kindle

    Remove ~/library/preferences/com.amazon.Kindle.plist

    Remove ~/library/preferences/com.amazon.Kindle.plist.lockfile

    Remove ~/applications/Kindle

     

    Empty trash

     

    Reboot again (dont know if this is necessary)

     

    Go to Amazon website and manage your kindle

     

    deregister your computer

     

    Install Kindle from AppStore (not from Amazon)

     

    Start kindle and register.

     

    Go to Amazon again.

    Select your items and action deliver to your computer.

     

    Sync and wait for your items to download.

  • ugly__dog Level 1 Level 1 (25 points)

    Thanks Jan,

    You've hit the nail on the head as far as downloading from the Application Store is concerned. The problem seems to be with the particular version of the Kindle app. The one from the Application Store is v 1.2.3. The one I had been using with Snow Leopard was v 1.5.1 which I downloaded from MacUpdate in April. It was great and I had no problems with it.

     

    Being a later version it had a few more bells and whistles on it than 1.2.3 and I must admit I am missing a couple of them. I use a system of 4 bootable backup discs (don't beleive in Time Machine) and I actually sortred things out using one of them. Just for fun, once I'd done that I booted from another backup disc and just deleted/installed only the app itsef. Worked like a charm. I was able to register straight away and synchronise in the blink of an eye. Then I re-installed 1.5.1 and I was back to square one. Didn't matter of course, just cloned over the top of it, but I thought it was a useful thing to know.

  • mt mind Level 1 Level 1 (0 points)

    JanBP - thank you. I was on the phone with 2 people from Amazon for over an hour and they couldn't figure it out (my account wouldn't register). I followed your advice & it works fine. :-)

  • ugly__dog Level 1 Level 1 (25 points)

    Since my last post v1.6.2 has appeared in MacUpdate. Just for fun I installed it onto one of my backup discs to see what happened. It works okay. It has a couple of extra features that I like.

     

    I did have to register again but that went through straight away. It is a bit iffy in that it flickers occasionally but basically it works as it should.