Skip navigation

Unable to update bundled iMove/iPhoto/GarageBand?

68988 Views 157 Replies Latest reply: Jan 11, 2013 4:18 PM by JeanXOXO RSS
  • su.mac Calculating status...

    Now to add a twist to this issue which I'm dealing with - how to update when the bundled apps were purchased with a different Apple ID (I bought the machine from someone else)? I'm awaiting Apple's fix but am curious what the support community has to say...

  • Dah•veed Level 7 Level 7 (29,625 points)
    Currently Being Moderated
    May 15, 2012 3:40 PM (in response to su.mac)

    Only Apple can help you. They have to release these bundled apps on this machine from this other guy's Apple ID so that you can accept them into yours. There isn't another way around it, unless you have bought these apps with your ID for another Mac in the past.

    '09 Mac mini, iPad 2, iPhone 4S, Mac OS X (10.7.3), iOS (5.0.1) Mac fanboi since 1984!
  • su.mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2012 8:33 AM (in response to Dah•veed)

    Thanks Dahveed - apparently AppleCare didn't get the memo - it took an hour on hold for them to id the issue which is still not resolved.

  • su.mac Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 17, 2012 12:44 PM (in response to su.mac)

    An update: Apple "cleared the previous AppleID from your computer's iLife. They provided new acceptance codes to get the iLife applications updated." I went to the App Store, redeemed the codes, and downloaded these apps/updates individually. Which is great but I think they need to automate this process - it took two days.

  • JeanXOXO Calculating status...

    I had the same issue but I had been attempting to "update all" so I tried updating one at a time and that did it.  They're all updated.  That was simple.....

  • alexdloia Calculating status...
    Currently Being Moderated
    Jul 7, 2012 10:09 AM (in response to Taristin)

    Same with me. This is my first mac. I have a 13" MacBook Air with Lion 10.7.4. It wont let me update saying "Login with the account you purchased it with to update. I constantly have a little red badge that drives me crazy!!!! HELP!!!

  • Rocky007 Level 1 Level 1 (0 points)

    I am also experiencing this problem. I just got my retina display macbook pro and ilife came pre loaded. I cant update those apps, I get the same message. I tried everything written here, I called apple and they said they'll call back with a solution......I guess ill have to wait around until then......

  • alexdloia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 12, 2012 2:56 PM (in response to Rocky007)

    Just delete the apps and reinstall them in the Mac Apps Store. You'll see an accept button. It retrieves all your data.

  • cronopio-cronopio Calculating status...
    Currently Being Moderated
    Jul 13, 2012 5:14 AM (in response to ebasan)

    It just helped me too with same issue. Big thanks!

  • fazleskhan Calculating status...
    Currently Being Moderated
    Jul 15, 2012 11:59 AM (in response to Kukzee)

    This worked for me

  • bandit Level 3 Level 3 (875 points)
    Currently Being Moderated
    Jul 16, 2012 8:58 PM (in response to Rocky007)

    Rocky007, Please report back when you hear from apple. This is very annoying.

  • Rocky007 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 16, 2012 9:43 PM (in response to bandit)

    well please excuse me for being so annoying...... I didnt report back because I was waiting for apple to respond to me....they did...They sent me 3 redemtion codes that I used in app store. The apps were then credited to my account and I was able to update. Deleting the apps didnt work for me. I also tried accepting the apps but that didn't work and neither did spotlight indexing or something....anyway if anyone else is experiencing this problem I suggest just contacting apple and asking for redemtion codes, its the most reliable way.

  • bandit Level 3 Level 3 (875 points)
    Currently Being Moderated
    Jul 16, 2012 9:47 PM (in response to Rocky007)

    Rocky007,

     

    I'm really sorry if you thought I was annoyed at you. I was referring to this situation that we are all having to deal with.

  • Bucharest021 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2012 11:47 PM (in response to Dah•veed)

    Yes Yes Yes!

    I had the same problem. I purchased a new Macbook Pro (so I thought) and the actual hardware ID was already coupled with another Apple ID (it turned out my Macbook was activated once). I need to stress that I purchased my Macbook from a reseller for more than 25% below the market price here (in Romania that is, where Macbooks are much more expensive as we dont have Apple Stores)

    The iLife apps showed up ones for me to accept, giving me an error that the iLife apps were linked to a different Apple ID.

    Solutions

     

    1. 1. Email Apple Support and explain them the error (”iLife apps are linked to another Apple ID” (in case this is your problem, as was with me)
    2. 2. Apple Support needs to decouple the hardware ID linked to the iLife software suite


    3 - Log out and quit iTunes and the Mac App Store (MAS)

    4 - Go to System Prefs/Users & Groups/~user/Password and enter the Apple ID connected to your iTunes/Mac App Store account. Close Sys Prefs

    5 - Delete /Mac HD/Library/Caches/com.apple.appstore/adoption.plist

     

    OR: Delete /Mac HD/Library/application support/appstore/adoption.plist (this one worked for me!!)

     

    4 - Reboot your Mac

    5 - Open Mac App Store

    6 - Go to the Purchased pane and Accept the three iLife apps. Enter iTunes/MAS username/password if prompted.

    7.  Download the 3 apps

  • mestiza Calculating status...

    Hello all,

     

    I'm new to the forums and have been pulling my hair out over this issue for a few days. The chap at the genius bar said it was a problem with my account, and told me to phone Apple Care as they could deal with it. Apple Care told me it was a problem with my account, and told me to email Express Lane as they could deal with it.

     

    After a few emails back and forth with someone in Express Lane (who is much too informal in dealing with customers, and makes basic mistakes in English), I've been told that they can't deal with it and that I should get in touch with Apple Care. I'm starting to consider bashing my head against the wall - but perhaps following some steps would be more constructive (though I doubt it).

     

    Anyway. I've tried updating from the 'Purchases' tab - I get an error message saying the download is not available. Trying via 'Updates' gives the same result.

     

    Moving the programs to the trash and then trying the same again gets me in a loop of having to endlessly log in with my Apple ID (via 'Purchases') or leads me to a blank 'No updates available' screen (in 'Updates').

     

    The person I was emailing with at Express Lane then suggested finding and deleting the adoption.plist file - but I can't find that file. Actually I can't find Macintosh HD/Library/Caches/com.apple.appstore, nor can I find Macintosh HD/Library/Application Support/appstore/ (as suggested in Bucharest021's post).

     

    Does anyone have any suggestions, given I can't find/see these two folders?

     

    Many thanks in advance.

Actions

More Like This

  • Retrieving data ...

Related Articles

Bookmarked By (15)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.