Previous 1 2 3 Next 136 Replies Latest reply: Sep 21, 2014 6:50 PM by brad-dog
gerdgruhn Level 1 (0 points)

I have updated von SL to Lion Server. Now, I don't gave Access to my Windows shares from any Windows Computers. If I connect a Windows share u.e. froom Windows 7 Workstation I will see a window with username and password for the share. But the username und password from lion for this share will not work. It was no problem in SL. Any idea?


Mac OS X (10.7)
  • greenvespa Level 1 (5 points)

    same problem here... did someone have access from Windows PC to Lion Server shares (smb)?

  • MaartenP Level 1 (0 points)

    I have the same behaviour on a server that has been upgraded from SL.

    No connection from a Windows 7 client to Lion Server.

  • gerdgruhn Level 1 (0 points)

    I updatet from SL Server without problems. Apple will update from a Lion client. It's possible, thats the problem? Some missing SMB/CIFS-configurations, dependent on new SMB/CIFS-Stack without Lion client installation before?

    If I share a folder on Lion client, I can access the share from a Windows 7 computer without problems. But not on the Lion server.

  • pkaplan2524 Level 1 (15 points)

    I think I have found the issue. Kerberos wants the domain and the PCs are logging in as LOCALMACHINENAME\Username. What I did was logged in as SERVERNAME\Username and it worked.

     

    Look in the file /private/var/log/krb5kdc/kdc.log to get some clues as to what name it might be looking for in your particular environment.

  • birkhead Level 1 (0 points)

    I can't get this to work even changing the domain.

  • greenvespa Level 1 (5 points)

    mee too. Seems to be impossible to connect to Lion Server shares (SMB) from any Windows clients (XP, Vista, 7). Is there anybody who did it? (my configuration is a clean Lion Server installation with Open Directory as master)

    Any help will be appreciated. Thanks

  • gerdgruhn Level 1 (0 points)

    Thanks a lot! It works. But it works different from Windows or SL in a workgroup. This works like a Domain authentification. But it is'nt a Windows Domain. It's a workgroup.

  • greenvespa Level 1 (5 points)

    Hi gerdgruhn, could you please explain better what you did to make it work?

    Thanks!

  • gerdgruhn Level 1 (0 points)

    The answer from pkaplan2524 works. See above.

  • greenvespa Level 1 (5 points)

    Yes, i can confirm that this solution is working with Windows Vista and 7, but not with XP. Any ideas?

    Thanks.

  • arikk Level 1 (0 points)

    It works guys, I just unchecked and checked "Share files and folders using SMB", then I restarted my PC, and accessed Lion from Windows 7, without username and password.

  • jeremy200 Level 1 (0 points)

    I could access smb shares from windows 7 from my account but not others. Server App showed the other users as having an error it couldn't access some services. After fixing the error, I had to enter the users password to fix it, I was able to access smb shares from this user as well.

  • seblbuk Level 1 (0 points)

    To get this to work on windows 7 I...:

     

    1. Start > Computer
    2. Disconnected my mapped netowrk drive that would not connect
    3. Selected the Map network drive button in the toolbar at the top
    4. Typed in the folder location manually (if you try the browse it will fail)
    5. Selected Connect using different credentials
    6. Selected Finish
    7. On the credentials screen that pops up:
      1. User name: <SERVER\username>
        1. I found that my server name had to be in capitals (/private/var/log/krb5kdc/kdc.log helps you know exactly what it is)
      2. Password: <your password>
    8. Select Remember my credentials
    9. Select OK

     

     

    After this i found no issues access any of the shares on the server and everything came back to life

  • Mista2 Level 1 (0 points)

    Something is still broken with SMB on lion, I cannot access SMB shares from lion on any other computer, running Windows, XBMC, or linux.

    I have tried turning off AFP shares.

    I removed all shares and stopped SMB sharing, then just enabled one SMB share.

    Still no luck authenticating to the share off my external drive. I did get on to a share on the OS volume from Linux, but unable to access data - Error indicates unsupported feature.

     

    This is a major bug in Lion, and I cant believe I havn't seen anything like a samba-gate scandal in the IT press yet!

Previous 1 2 3 Next