Previous 1 2 3 4 Next 108 Replies Latest reply: Sep 9, 2014 9:51 AM by wasinsandiego Go to original post
  • Noleigator Level 1 Level 1 (0 points)

    To Thomas A Reed: After posting a moment ago I examined the permissions assigned to the files from my desktop from the previous installation of OS X Lion.  There exists a second "everyone" permission that has "custom" access assigned to it.  Moreover, for every file that came from that desktop the Sharing & Permissions info reads as follows:

     

    Name                         Privilege

    everyone                    Custom

    Noleigator (Me)           Read & Write

    staff                           Read only

    everyone                    Read only

     

    I thought I might simply delete the additional "everyone" group with "Custom" privileges, but the delete ('-') button is grayed out even after unlocking the info window and selecting the name I wish to delete. 

     

    Perhaps you can suggest something I can do to attack this issue?

  • mocko Level 1 Level 1 (0 points)

    Hi, I had the same Problem.

    Even if I deleted files, my Trash won't fill and couldn't be emptied although the files dissapeared from my folders.

    Then I detected, that Admin or MyAccount (Me) had no permissons on my Systemdisc Macintosh HD. I added Admin Read&Write and now it works.

  • thomas_r. Level 7 Level 7 (30,365 points)

    Well, if this is only affecting files on your desktop, you could try executing the following command in the Terminal:

     

    sudo chmod -R 755 ~/Desktop/*

     

    That should change the permissions on everything in the Desktop folder to what they ought to be.

  • howie79blue Level 1 Level 1 (0 points)

    Hi Neloigator- I'm having exactly the same problem. I have the second 'everyone' permission, although mine seems to have come from the Time machine backup.

    I'll keep watching this post until someone provides an answer.

     

    All the best.

  • banjoatte Level 1 Level 1 (0 points)

    I have the same problem after installing Lion and tried your remedy. Found out the same permission for the trash and changed it. Also repaired permissions. Nothing works. I don´t want to make a clean install because of this bug. I´ll drag on with this until Apple has fixed the bug.

  • bitpuddle Level 1 Level 1 (5 points)

    It doesn't seem like file permission issue, rather a directory permission issue, I assume the home directory.  Do you have multiple user accounts on this computer?  Are you definitely logging into the computer with the same account that owns the files?

     

    If you create a second, test account on the computer, are you able to copy and delete files with it?

     

    When you say you did a clean install, I assume you don't mean that you reformatted the drive and installed Lion from nothing; because that would be weird.

  • banjoatte Level 1 Level 1 (0 points)

    I created a testaccount that worked perfect. And deleted items also stayed in the waste until i deleted them. I´m making a new premission repair again  and will also log in as root to see what´s happening there. I also realize that this problem propably started already with snowleopard and have now excalated with Lion. In s swedsih thread about this anothert user also complained over that when he deleted files usin  command backstage ( and then writing the pw)they disapppeared without passing the wste. This also happened to me  in that time when I could deleti with shortcut but without getting promted with PW.

  • sdevan Level 2 Level 2 (465 points)

    Try this:

    1. Open your Finder

    2. Under Favorites, click on the house icon.  It should have your short name next to it.

    3. Right click on your documents folder and select "Get info"

    4. Unlock it with your password (if necessary) by clicking on the lock icon on the bottom right.

    5. Click on  Your name (Me) to select it.  Make sure it stays highlighted.

    6. If the Privilege is not set to Read & Write change it to Read & Write.

    7. At the gear icon drop down at the bottom of this window select Apply to Enclosed items.

     

    If this works, you may need to repeat these steps for other folders that are not in your documents window. 

  • banjoatte Level 1 Level 1 (0 points)

    I have tried everything. Started up from Lion partition and repaired harddisk and permissions. Checked a.o trash and find that I have permissions needed.I have checked my other accounts ond those no password is needed to trash. By the wsay during this  I also used root and now I can´t log out from root

    Is it time for bugreports?

  • banjoatte Level 1 Level 1 (0 points)

    I have done it and the permissions on the dokument folders are OK. This problem is on alla files for example pictures, screenshots etc.

  • sdevan Level 2 Level 2 (465 points)

    I can't tell if you tried the steps I gave you on the Pictures folder or not.  Try it and if it works, let me know and I'll take you through doing your whole disk drive at once.

     

    Steve

  • banjoatte Level 1 Level 1 (0 points)

    Solution from Pocahontas in the swedish Mac forum.  gå to map of HD map and click info. change permission so  also everyone can read and write. That did the trick for me.

  • thomas_r. Level 7 Level 7 (30,365 points)

    That's bad advice.  "Everyone" should not normally have write access to your hard drive.  Not to mention that if you made the mistake of applying that change to all enclosed items, you'd bork your entire system.  You'd end up having to reinstall the system.

     

    There are a lot of people chiming in here with problems that are NOT the same as Noleigator's and with solutions that do not apply to his particular situation (only having trouble with the desktop).  Those people need to start their own topics so as not to screw up Noleigator's topic.  Please be considerate.

  • Noleigator Level 1 Level 1 (0 points)

    Thomas,

     

    My permissions issue remains unresolved even after attempting your most recent terminal entry suggestion.  I have actually been duplicating individual documents and re-saving them to alleviate the permissions issue.  It is time consuming but seems to work.  Unfortunately, I have about 500 JPEGs that have the permissions problem.  Taking the time to individually re-save all of those files to correct the problem will be very time consuming, so I am waiting on a solution from Apple.  Hopefully as Lion matures a solution will become available.  Until that time, should you have any further suggestions, I will continue to watch this thread and attempt anything you can throw at me. 

     

    I appreciate your time and support. 

  • thomas_r. Level 7 Level 7 (30,365 points)

    So, I guess the problem is not with the desktop folder.  I'm honestly not sure what's going on here, but I still think you need to try resetting the permissions on your user account.  I finally located some instructions for doing that in Lion, though I have to preface this by saying I haven't tried it.  That said, see:

     

    http://drtyhnds.blogspot.com/2011/07/how-to-reset-password-in-mac-os-lion.html

     

    Instead of resetting the password at the end, click the Reset button in the bottom right corner of the window.

Previous 1 2 3 4 Next