Previous 1 2 3 4 5 Next 108 Replies Latest reply: Sep 9, 2014 9:51 AM by wasinsandiego Go to original post
  • jolorenzo Level 1 Level 1 (0 points)

    Check your File Vault settings under security and privacy.  If the File Vault is turned on, it will require a password for every move.

  • tklasinski Level 1 Level 1 (0 points)

    A fix for this has now been found. The reason why this is happening is because the .Trash folder has changed ownership to root. The fix simply requires ownership of the folder being put back to you. Open Terminal and run the following command: (replace "yourusername" with the name of your home folder)

     

    sudo chown yourusername .Trash

     

    This should resolve the problem without having to create new user profiles etc.

  • thomas_r. Level 7 Level 7 (30,385 points)

    That is not the original poster's problem, as evidenced by the following information that he posted earlier:

     

    drwxr-xr-x+  3 noleigator  staff    102 Jul 24 16:18 .Trash

     

    Whether or not he has foud his solution is for him, and only him, to say.

  • banjoatte Level 1 Level 1 (0 points)

    Problem solved for me. I made a permission repair a few times and then manually checked some folders  I found out that some had wrong owner a.o the trash. So I already have done that when tklasinski suggested it. Sorry for not telling this earlier.

  • oldcro Level 1 Level 1 (0 points)

    I had the same problem with password required to trash anything, and have managed to cure the problem by doing the following.

     

    First in System preferences, users and groups, open lock and set preferences to read and write for all those listed.

     

    Then right click Macintosh HD and click "get info" and do the same with the sharing and permissions list.

     

    I have a USB backup HDD and repeated the last instruction as used in Macintosh HD.

     

    Previouly I had ignored the USB backup disk and now files can be moved into the Trash basket and deleted as before Lion update without having to enter a password each time.

     

    Hope this is helpfull as I'm certainly no computer geek.

  • probe_droid Level 2 Level 2 (470 points)

    Never mess around with any permissions outside of your user's folder.

    As Thomas wrote above:

     

    That's bad advice.  "Everyone" should not normally have write access to your hard drive.  Not to mention that if you made the mistake of applying that change to all enclosed items, you'd bork your entire system.  You'd end up having to reinstall the system.

     

     

    It also does not make sense to solve a problem in your user's folders by altering the permissions and access rights of your whole system. That is more like to crack a nut with a sledgehammer and mostly has the same effect: everything is totally pulverized.

  • Level 8 Level 8 (41,790 points)

    Is the password requested for every file or for files from some of them.

     

    In Lion, there are more folders whose contents can't be modified witout a passwoed than in older OS.

    If I understand well it's an attempt to reduce the risks of accidental deletions. It's the same goal which pushed them to hide the User's Library folder.

     

    I guess that Apple is more aware than us about the number of system rendered odd by changes made by "ignorant" users.

     

    Yvan KOENIG (VALLAURIS, France) jeudi 11 août 2011 14:55:38

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.0

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

    To be the AW6 successor, iWork MUST integrate a TRUE DB, not a list organizer !

  • oldcro Level 1 Level 1 (0 points)

    I should have added that I am the only one who uses the iMac, so altering permissions for othe users is errelevant in my case.

     

    Good or bad it worked for me when all other suggestions given in good faith had failed.

  • probe_droid Level 2 Level 2 (470 points)

    That is good, but above you said this:

     

    Then right click Macintosh HD and click "get info" and do the same with the sharing and permissions list..

     

    This was what I was referring to and this is something you should step away from as it could render your system totally unusable.

  • Level 8 Level 8 (41,790 points)

    You are playing with matches.

    Don't be surprized if soon you burn your fingers.

     

    Yvan KOENIG (VALLAURIS, France) jeudi 11 août 2011 16:34:12

    iMac 21”5, i7, 2.8 GHz, 4 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.0

    My iDisk is : <http://public.me.com/koenigyvan>


    Please : Search for questions similar to your own before submitting them to the community

     

    To be the AW6 successor, iWork MUST integrate a TRUE DB, not a list organizer !

  • oldcro Level 1 Level 1 (0 points)

    Your comment is probably true, but unfortuneatly not in the least helpfull I'm afraid.

  • RadRod Level 1 Level 1 (5 points)

    Lion….I've got the same issues:

    Moving a file requires a password.

    Deleting a file requires a password.

    Moving a Folder is denied because I don't have permission to "access some items".

    I have the double "everyone" & "custom" privileges on a file info check.

     

    Brand new MacBookPro 15"

    I performed a clean install (with a 3 pass wide) last weekend.

     

    Why?  because "Migration Assistant" brought over Another weird POA problem (In both Snow Leopard & Lion) where Safari would not load the certificate items in The Page for logging on to MobileMe Mail & Calendar.  The other MM services were fine.   Same for Amazon account page. That page was totally unformatted bunch of left justified blue hyperlinks.  When I logged onto my Mac with another user ID everything is fine.

    There are others with the same problem…  Finally after a couple of case calls and visits to the Apple store  (don't say anything!)….  I had to wipe and install for peace of mid.

     

    Sorry to digress……

     

    After the wipe and bringing select files over from Time Capsule, I started seeing this error.

    First I thought it was a Lion "feature" that I didn't understand….  Then I went looking and found this Post.

     

    I suspect that some of my permission problems are from restoring Time Machine files.  Why.  Time Machine had recent backups of nothing from right after the install….  When I went to the date where my Doc's Pic's and whatnot were the Genie Bar on the right turned Purple and all the folders had the Red Circle minus sign in the lower right corner.  "Permission Problems"..  Plus I could not click to the file level.. only folders.

     

    So folder by folder I brought the files in and changed privileges to make me the owner and have R&W.   My backup User ID and password were exactly the same when I migrated, but I did not change the "machine name".

     

    The problem Does Not seem to happen with newly created documents.

    I have to conclude that my issue is with files/folders restored from Time Machine.

     

    I thought I had the backup covered twice.  On top of Time Machine, I formatted a LaCie 1T drive and Dropped all the files to the drive.

    Get this… I should have noticed something was up with the LaCie when I was copying the files.  It just took too long… Hours.

     

    After the reinstall, I went to the LaCie and it was JackedUp.  Folders were there but no files.  Un believable.  So Time Machine was my only source.

     

    Because of all this &^()@#, I have not installed ANY 3rd party utilities. Zip.

    No Microsoft Office. Zip.  Only my Adobe Photoshop & Lightroom, add-ons and Apple Pages.

     

    I've been using Mac's a very long time.   In IT  before the Internet and the PC.  Today, going into the bowels …  root / terminal/ chon, etc… on my own…  Ain't my Bag.   Too many bad things can happen.  Gotta know Cold that it's going to fix and not add more issues.

     

    So…. Once again.

    I opened up a case today.  The call lasted 90 min., mostly with Sr. Advisors.

    He was very diligent.

     

    However the problem could not be resolved.

     

    The call ended with a System dump for engineering along with many screen shots.

     

    If I hear back, I'll report.

    If anyone has more info, I'd love to read about it.

     

    Thanks for reading.

     

    Cheers.

    jpg File Permissions dbl everyone.jpg

  • RadRod Level 1 Level 1 (5 points)

    I reread this thread and saw Thomas's post with a link about a Corrupt User ID and Folder.

     

    The Apple tech had me perform the root level repair documented in the thread....

     

     

    That's because Repair Permissions doesn't touch anything inside the Home folder(s)

    To repair permissions within the Home folder...

     

    1.Start up from your Install Disk 1 that came with your computer.

    2.Choose your language.

    3. Choose "Reset Password" from the "Utilities" Menu.

    Don't worry we are not going to do that.

    4. Choose the option at the bottom to Repair Permissions and ACLs on your Home Folder.

    5. When finished restart from HDD.

     

    It didn't help.

    Because of the history of my Safari certificate stuff & the issues with restoring files from Time Machine, I suspect it goes back to a corrupt user acct with files created from said acct while running Snow Leopard.  I suspect the Password issue in Lion is a manifestation of the prior problem with all my files not just Safari accepting Certificates from some issuers.

     

    I didn't see the problem, but I'll bet it was there.

     

    Now.  Can I cleanup my files ?

     

    Thanks Thomas !

  • RadRod Level 1 Level 1 (5 points)

    I'm very sorry I didn't start a New Topic.

     

    I haven't posted much and didn't know the Forum etiquette.

    Also a bit desperate...

  • Noleigator Level 1 Level 1 (0 points)

    To RadRod:Your issue matches mine.  However, I have not had complications involving Safari as you have.  If indeed you find a solution then please post it to this topic.  I still have a few thousand photographs and random documents that fell prey to the "permissions" issue.  The best solution I have found thus far takes far too long.  It involves opening, editing, and saving a copy of every single file individually, not to be confused with simple duplication of files. 

     

    On a related note, I too used to use Time Machine.  I used it once to restore files on Snow Leopard.  However, the files in question above were not included in that backup and restoration.

     

    To All: Thank you for continuing to provide possible solutions.  Unfortunately we are all still waiting around to find one that works.

Previous 1 2 3 4 5 Next