Skip navigation

Finder requires password for moving or deleting files every time.

66737 Views 105 Replies Latest reply: Jan 25, 2014 4:37 PM by T.S RSS
  • alexlluisg Calculating status...

    Thanks, this worked for me

  • DarMah Calculating status...

    I have been through nightmares with permission problems and all I can suggest ist to go ahead with "Clean Install".

    My problems started with Safari freezing after an update and the "genius" staff at "Genius Bar" performed all magic they knew and suggested there being a problem within my "user profile". They suggested me creating a new User and "they" transferred all my files to the new user and deleted the old one. The nighmare got worse because the transferred files had something attached to their tail from 1st user and would not let the 2nd "new" user deal with them. Next advice by Genius Bar was upgrade to Lion as my OS was Snow Leopard. I did this too and nothing changed and all Permission Repairs did no change. I had problems backing-up iPhone, I was unable to deal freely with iPhoto, iCal, etc, etc.

    The story is simply too long and I can only suggest, do a clean install and forget the rest.

    I did this yesterday and my only worry is; "if I use my back-up from Time Machine, will I again face the same permission problems since the back-ups were from a user now deleted and non-existant?"

  • Mr Saphique Calculating status...

    There is a slight possibility that the trouble will continue if you use your timemachine back-up.

    The files on there belong to the account of which the back-up was made.

    I'm not 100% sure though, it's just a wild thought.

  • Cbuzio Calculating status...

    DarMah,

     

    Yes it will!

    I had a freshly bought MacBook Pro and it all started when I installed from the Time Machine...

    The only suggestion I have is to copy and paste one folder, and see if it has any problem. Back then I was so happy with the function of migrating the whole previows computer that I didn't do it "one by one", or by hand each file...

    Do try it and let me know, please, I'm considering re-installing the whole system and I'm wondering if that would happen.

  • thomas_r. Level 7 Level 7 (26,980 points)

    The Genius who helped you was nothing of the sort.  If you find yourself back in that same Apple Store looking for assistance, and the same Genius tries to help you...   RUN!  Suggesting that you install a major OS update to fix this is about as dumb as a mechanic wanting to rebuild your car's engine to fix a sticky sunroof.

     

    You've posted this on the tail end of an old, long topic...  that's never a good idea.  In the future, start your own.  However, what you need to do is probably to reset your user folder permissions.  Since you are now using Lion, hold down command-R at startup.  When the Mac OS X Utilities window appears, choose Terminal from the Utilities menu.  Type "resetpassword" (without the quotes) and hit return.  Do not change the password in the window that appears...  click the Reset button under "Reset Home Directory Permissions and ACLs".

  • Level 8 Level 8 (41,760 points)

    Thomas A Reed wrote:

     

    The Genius who helped you was nothing of the sort.  If you find yourself back in that same Apple Store looking for assistance, and the same Genius tries to help you...   RUN!

    A "Genius" is just a vendor which sold sufficiently well to get a new cap.

     

    Yvan KOENIG (VALLAURIS, France) dimanche 22 janvier 2012

    iMac 21”5, i7, 2.8 GHz, 12 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.2

    My Box account  is : http://www.box.com/s/00qnssoyeq2xvc22ra4k

    My iDisk is : http://public.me.com/koenigyvan

  • DarMah Level 1 Level 1 (0 points)

    Your guess is right and the problem persist when files are restored from back-up.

    I just tried this with Mail restore. It does restore all mail in the Mail Folder in the new User Library of the new Mac OSX Lion, however, it does not make any changes to the preferences saying no permission.

    I will now try what "Thomas A Reed" has suggested, namely to "reset password" and see if this works with the Mail restore. If not, I don't know further.

  • DarMah Level 1 Level 1 (0 points)

    Dear Cbuzio,

    I did in fact copy only the "Mail Folder" from my back-up (Time Machine) and the permission problem has been revived. I also backed up the important files like the Mail Folder on USB flash, and will try to restore from there to see if this works.

  • DarMah Level 1 Level 1 (0 points)

    Dear Thomas,

    I have not yet tried your suggestion but the way it goes, I will do exactly as you said the next time I switch on the MacBook, and I sure hope it helps.

    If not, I will have no other alternative but to create mail accounts again and download mals again but the mails I kept on last Mail and deleted in Gmal & Yahoo are lost for ever. I will post my unique experiences!!

  • thomas_r. Level 7 Level 7 (26,980 points)

    I will now try what "Thomas A Reed" has suggested, namely to "reset password" and see if this works

     

    I did NOT recommend resetting your password!  That will not fix the problem.  Please be sure you follow the instructions I posted very carefully.

  • sherryfromsan diego Calculating status...

    I downloaded BatChmod free and easily after a google search. It worked well and unlocked my files! I no longer have a pencil with a line / slash through it on the bottom left of my finder window for these folders! Yay!

     

    Easily enough, Find the file/folder you're having trouble with, set your Owner to "R, W, X" and then check "Change ownership...", "Unlock", "Clear ACLs" and "apply to enclosed folders". You're done!

     

    I recently upgraded my computer and all my music/video/photo files were kept in an external hard drive "Meda" folder. The folder became locked out when I ported all the backup files on my Time Machine into a OS-Journaled hard drive. I'm not sure if they were initially locked because they were from a Time Machine backup or because I switched computers and lost the permissions somewhere. Since I moved my Time Machine profile over, too, I should've technically still had permissions.

  • Rafavila Calculating status...

    Hello! this appears on mine! Its different on the trash section! Please help! It keeps asking me for the password when I try to put something in the trash and then it deletes it automatically!

     

     

    drwxr-xr-x   26 501           staff     884 Jan 21 13:33 .

    drwxr-xr-x    6 root          admin     204 Jan 14 13:41 ..

    -rw-------    1 RafaelAvilaS  staff       3 Jan  2  2011 .CFUserTextEncoding

    -rw-r--r--@   1 RafaelAvilaS  staff   24580 Feb 13 16:05 .DS_Store

    drwx------   10 501           admin     340 Feb 15 00:06 .Trash

    drwxr-xr-x    4 RafaelAvilaS  staff     136 Mar 17  2011 .adobe

    -rw-------    1 RafaelAvilaS  staff    3747 Feb 15 00:11 .bash_history

    drwxr-xr-x    3 RafaelAvilaS  staff     102 Nov  9 23:09 .config

    drwx------    3 RafaelAvilaS  staff     102 Oct 22 18:07 .cups

    drwx------   14 RafaelAvilaS  staff     476 Feb 14 23:55 .dropbox

    drwxr-xr-x   17 RafaelAvilaS  staff     578 Sep 27 01:00 .fontconfig

    drwxr-xr-x    3 RafaelAvilaS  staff     102 Sep 27 00:58 .mplayer

    drwxr-xr-x   27 RafaelAvilaS  staff     918 May 25  2011 .pseint

    drwxr-xr-x    2 RafaelAvilaS  staff      68 Mar 17  2011 Applications

    drwx------   15 RafaelAvilaS  staff     510 Feb 14 14:59 Desktop

    drwx------   57 RafaelAvilaS  staff    1938 Feb 14 23:24 Documents

    drwx------  348 RafaelAvilaS  staff   11832 Feb 15 00:10 Downloads

    drwx------@  16 RafaelAvilaS  staff     544 Feb 14 15:16 Dropbox

    drwx------@  50 RafaelAvilaS  staff    1700 Feb 13 16:13 Library

    drwxr-xr-x    4 RafaelAvilaS  staff     136 Jan  5  2011 LimeWire

    drwx------    5 RafaelAvilaS  staff     170 May  9  2011 Movies

    drwx------    8 RafaelAvilaS  staff     272 Feb 24  2011 Music

    drwx------  171 RafaelAvilaS  staff    5814 Feb 12 23:32 Pictures

    drwxr-xr-x    6 RafaelAvilaS  staff     204 Jun 30  2011 Public

    drwxr-xr-x    5 RafaelAvilaS  staff     170 Jan  2  2011 Sites

    -rw-r--r--    1 RafaelAvilaS  staff  303805 Nov 16 20:45 save4e0e.tmp

     

     

    Thanks for your help!

  • Level 8 Level 8 (41,760 points)

    When I received the late release of Onyx, I applied it.

    Here are the permissions applying to items of my Home folder:

     

    2012-02-15T10.16.18.jpg

     

    Yvan KOENIG (VALLAURIS, France) mercredi 15 février 2012

    iMac 21”5, i7, 2.8 GHz, 12 Gbytes, 1 Tbytes, mac OS X 10.6.8 and 10.7.3

    My Box account  is : http://www.box.com/s/00qnssoyeq2xvc22ra4k

  • thomas_r. Level 7 Level 7 (26,980 points)

    Follow the directions I posted above for reseting your user folder permissions.

  • Meleschi Level 1 Level 1 (10 points)

    RadRod,

     

    Thanks for the sudo "chmod -RN ~" command!  -N removed the OSX specific ACL's from the files in my home directory but left the UNIX permissions intact...  I can copy, move, and delete files properly now...  -N is a nonstandard flag for the unix chmod command, so I didn't even know to check for it..  (sigh)

     

    To everyone afraid to try it.. Don't be...  Just make sure you're logged into terminal as the user who's having the issue.  You can tell because when you are in the terminal, if you look at the prompt, the user your currently logged into the terminal as will be the item just before the '$'.

     

    Jessicas-Awesome-iMac:~ jessica$

     

    If you're logged in under someone elses name, or you "sudo su - ", the prompt will not contain your username,  like this:

     

    Jessicas-Awesome-iMac:~ root#

     

    That being said, I ran the command as root (because I'm a tard) and it caused no ill effects.  The root user's home directory is NOT the same as the root directorty of your primary disk so I got a bit lucky there...  I don't recommend you attempt it as well though..  ;-)

     

    Ricardo

     

    Message was edited by: Meleschi

1 ... 3 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.