Skip navigation

My Mac don't go sleeping since Lion Update

49002 Views 113 Replies Latest reply: Mar 17, 2014 8:16 PM by csunsweet RSS
  • Actuality Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 23, 2011 12:09 PM (in response to andysd)

    I've had the same...

    Listed by owning process:

      pid 21: [0x0000012c00000015] PreventSystemSleep named: "org.cups.cupsd"

     

    Deleted an old printer and suddenly there's nothing preventing sleeping.

  • chinarut Calculating status...
    Currently Being Moderated
    Sep 30, 2011 6:10 PM (in response to boz0)

    that was it!!   for me it had to do with "Printer Sharing"

     

    I used the "pmset -g assertions" and noticed there was 2 processes, one of them was cups (related to printing)

     

    I toggled "Printer Sharing" off and our iMac is able to go to sleep - hallelujah!  this issue was driving me nuts as rebooting the machine didn't make a difference - so it has something to do with the way the printer sharing settings carried over from 10.6.x

     

    I've toggled Printer Sharing back on and another "pmset -g assertions" doesn't show any processes and sure enough it's able to go to sleep.

     

    I'll see how long this lasts and at least know if it does happen again, that this is likely to be the culrpit.

  • jbuczny Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2011 12:50 PM (in response to boz0)

    Hi,

     

    Processing # pmset -g assertions and killing a PID which prevented from sleep when my computer was plug-ined helped.

     

    J

  • Ali Hasan3 Level 4 Level 4 (1,795 points)
    Currently Being Moderated
    Oct 24, 2011 4:40 AM (in response to jbuczny)

    Friends - I made a seperate post about this issue and then found this forum

     

    I have a MBP (SSD) that wouldn't wake up after sleeping if MagSafe was plugged in

     

    This solution worked for me -

     

    I went into SYSTEM PREFS and noticed that I had PRINTER SHARING active on an HP printer that I never use - in addition, I had 3 HP printers installed, but I never use any of them

     

    I deleted the three HP Printers, turned PRINTER SHARING off on all printers and also went into SECURITY SETTINGS and DISABLED INFRARED REMOTE

     

    Lastly, I also made sure that FILE SHARING and all other types of NETWORK SHARING were off, which they were

     

    Fingers crossed, I hope it stays this way!

  • jbuczny Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 24, 2011 4:55 AM (in response to Ali Hasan3)

    Hi,

     

    Aparently the "sleeping" problem is usually caused by "active" printer or its drivers. This suggest a lack of full compatibility between Mac OS X and printers drivers. In my case the problem was associated with Brother printer.

     

    J

  • Ali Hasan3 Level 4 Level 4 (1,795 points)
    Currently Being Moderated
    Oct 24, 2011 4:56 AM (in response to jbuczny)

    jbuczny -

     

    Again, my solution could be premature, but the one BROTHER DRIVER I have doesn't seem to be causing the problem - deleting my HP PRINTER profiles definitely made a difference

     

    Anyways - many solutions to a similar problem - lol

  • LROCfromIndy Calculating status...
    Currently Being Moderated
    Oct 31, 2011 5:24 PM (in response to jbuczny)

    My problem was my iMac not wanting to sleep. I had just loaded Lion and also the October Apple update of all printer drivers.  When Sleep was clicked the machine shut down for about 10 seconds , then restarted.  If I just left the machine ON, it would sleep per the settings under Preferences-Energy Saving, but then awake again after about 15 minutes.  Finally I shut down the iMac, the printer and the scanner. Disconnected the usb cables.  Restarted the iMac.  Plugged in the usb cables. Turned the printer and scanner ON.  Made sure there was not a que of items to be printed.  After this, the iMac went to sleep properly.

  • Ali Hasan3 Level 4 Level 4 (1,795 points)
    Currently Being Moderated
    Nov 2, 2011 12:39 AM (in response to Ali Hasan3)

    Been one week now and everything is still awesome - the solution above worked well for me

  • Ali Hasan3 Level 4 Level 4 (1,795 points)
    Currently Being Moderated
    Nov 2, 2011 1:54 AM (in response to Vival)

    Viv -

     

    No need to touch your library folder

     

    Open SYSTEM PREFERENCES and click on PRINT & SCAN - your printers will be on the left-hand side - just delete whatever printers you're not using - also, click on SHARING PREFERENCES as that will be on the right-hand side, and I would recommend turning off any sharing that you're not using

     

    BTW - disabling the remote (the other thing I did) could also solve the problem outright - I just deleted my HP printers because I don't use them anymore

     

    Anyways - hope that answers your question

  • LROCfromIndy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2011 4:40 PM (in response to Vival)

    I did not fuss with anything in the system library etc. (I am too much a novice) but, I would think that because I downloaded an Apple printer update dated Oct 27, their download would have done some houskeeping.  See Apple downloads.

  • PaulHenderson Calculating status...
    Currently Being Moderated
    Nov 12, 2011 4:34 AM (in response to Vival)

    Ditto on the print queue problem here. Cancelled the a job left in the queue to a shared printer and now my MacBook Pro is sleeping as well as ever.

    Thanks all.

  • cingulomaniac Calculating status...
    Currently Being Moderated
    Nov 15, 2011 9:02 AM (in response to Vival)

    Unfortunately, my MBP is still not falling asleep.  Forcing it by shutting the lid or through the Apple menu works, but my Energy Saver prefs are not acknowledged, either plugged in or on battery.

     

    pmset -g assertions shows this:

     

    ChargeInhibit                           0

    PreventUserIdleDisplaySleep             0

    PreventUserIdleSystemSleep              0

    NoRealPowerSources_debug                0

    CPUBoundAssertion                       0

    EnableIdleSleep                         1

    PreventSystemSleep                      0

    DisableInflow                           0

    DisableLowPowerBatteryWarnings          0

    ExternalMedia                           0

     

    And I have nothing in my printer queues.  I have no File Sharing or any other preferences turned on that have been mentioned here.  This has been an issue since I clean installed Lion a few months ago.

1 ... 3 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.